sci-calculators/units: USE flag 'units_cur' uses reserved underscore character
authorJeroen Roovers <jer@gentoo.org>
Thu, 10 Oct 2019 07:49:39 +0000 (09:49 +0200)
committerJeroen Roovers <jer@gentoo.org>
Thu, 10 Oct 2019 07:55:37 +0000 (09:55 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
sci-calculators/units/metadata.xml
sci-calculators/units/units-2.16.ebuild
sci-calculators/units/units-2.18.ebuild
sci-calculators/units/units-2.19.ebuild

index 9aa83b1ef40a2661e96183da189621e5812eee67..f0a40a93849fc27d8b23c0170a29c286621ef702 100644 (file)
@@ -6,6 +6,6 @@
 <name>Jeroen Roovers</name>
 </maintainer>
 <use>
-<flag name="units_cur">Install the units_cur python script that updates currencies</flag>
+<flag name="units--cur">Install the units_cur python script that updates currencies</flag>
 </use>
 </pkgmetadata>
index 0d30fa56ad00f4728bfc78212c764681c7b28b79..f72ff8ee12f4477a983f5f07e172a724faf75d8e 100644 (file)
@@ -12,12 +12,12 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
 LICENSE="FDL-1.3 GPL-3"
 SLOT="0"
 KEYWORDS="alpha amd64 ~arm hppa ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="+units_cur"
-REQUIRED_USE="units_cur? ( ${PYTHON_REQUIRED_USE} )"
+IUSE="+units--cur"
+REQUIRED_USE="units--cur? ( ${PYTHON_REQUIRED_USE} )"
 
 RDEPEND="
        sys-libs/readline:=
-       units_cur? (
+       units--cur? (
                ${PYTHON_DEPS}
                dev-python/future[${PYTHON_USEDEP}]
                dev-python/requests[${PYTHON_USEDEP}]
@@ -28,7 +28,7 @@ DEPEND="
 "
 
 pkg_setup() {
-       use units_cur && python-single-r1_pkg_setup
+       use units--cur && python-single-r1_pkg_setup
 }
 
 src_configure() {
@@ -47,7 +47,7 @@ src_install() {
        # we're intentionally delaying this since 'make install' would
        # get confused if we shove 'units_cur' there, and there is no real
        # need to add more complexity for it
-       if use units_cur; then
+       if use units--cur; then
                sed \
                        -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
                        -e 's|^#!|&/usr/bin/python|g' \
index 4d61f6f6676c1453235462cf5721fc7d1ee3a1a2..3df5a8826c2703c4f6971bb0eea46342aa7dbf2b 100644 (file)
@@ -12,12 +12,12 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
 LICENSE="FDL-1.3 GPL-3"
 SLOT="0"
 KEYWORDS="~alpha amd64 ~arm hppa ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="+units_cur"
-REQUIRED_USE="units_cur? ( ${PYTHON_REQUIRED_USE} )"
+IUSE="+units--cur"
+REQUIRED_USE="units--cur? ( ${PYTHON_REQUIRED_USE} )"
 
 RDEPEND="
        sys-libs/readline:=
-       units_cur? (
+       units--cur? (
                ${PYTHON_DEPS}
                dev-python/future[${PYTHON_USEDEP}]
                dev-python/requests[${PYTHON_USEDEP}]
@@ -31,7 +31,7 @@ PATCHES=(
 )
 
 pkg_setup() {
-       use units_cur && python-single-r1_pkg_setup
+       use units--cur && python-single-r1_pkg_setup
 }
 
 src_configure() {
@@ -52,7 +52,7 @@ src_install() {
        # we're intentionally delaying this since 'make install' would
        # get confused if we shove 'units_cur' there, and there is no real
        # need to add more complexity for it
-       if use units_cur; then
+       if use units--cur; then
                sed \
                        -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
                        -e 's|^#!|&/usr/bin/python|g' \
index 9e35768509d5cfdaa9ac5e05ba3996d0f4708fba..5bbc862db2478afe8e626db576b4db33b4813932 100644 (file)
@@ -12,12 +12,12 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
 LICENSE="FDL-1.3 GPL-3"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="+units_cur"
-REQUIRED_USE="units_cur? ( ${PYTHON_REQUIRED_USE} )"
+IUSE="+units--cur"
+REQUIRED_USE="units--cur? ( ${PYTHON_REQUIRED_USE} )"
 
 RDEPEND="
        sys-libs/readline:=
-       units_cur? (
+       units--cur? (
                ${PYTHON_DEPS}
                dev-python/future[${PYTHON_USEDEP}]
                dev-python/requests[${PYTHON_USEDEP}]
@@ -29,9 +29,12 @@ DEPEND="
 PATCHES=(
        "${FILESDIR}"/${PN}-2.17-network-sandbox.patch
 )
+DOCS=(
+       ChangeLog NEWS README
+)
 
 pkg_setup() {
-       use units_cur && python-single-r1_pkg_setup
+       use units--cur && python-single-r1_pkg_setup
 }
 
 src_configure() {
@@ -45,14 +48,12 @@ src_compile() {
 }
 
 src_install() {
-       emake DESTDIR="${D}" install
-
-       dodoc ChangeLog NEWS README
+       default
 
        # we're intentionally delaying this since 'make install' would
        # get confused if we shove 'units_cur' there, and there is no real
        # need to add more complexity for it
-       if use units_cur; then
+       if use units--cur; then
                sed \
                        -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
                        -e 's|^#!|&/usr/bin/python|g' \