Initial import for app-sci/transfac
authorOlivier Fisette <ribosome@gentoo.org>
Fri, 25 Jun 2004 03:42:08 +0000 (03:42 +0000)
committerOlivier Fisette <ribosome@gentoo.org>
Fri, 25 Jun 2004 03:42:08 +0000 (03:42 +0000)
app-sci/transfac/ChangeLog [new file with mode: 0644]
app-sci/transfac/files/digest-transfac-3.2 [new file with mode: 0644]
app-sci/transfac/metadata.xml [new file with mode: 0644]
app-sci/transfac/transfac-3.2.ebuild [new file with mode: 0644]

diff --git a/app-sci/transfac/ChangeLog b/app-sci/transfac/ChangeLog
new file mode 100644 (file)
index 0000000..8cea2e8
--- /dev/null
@@ -0,0 +1,11 @@
+# ChangeLog for app-sci/transfac
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/transfac/ChangeLog,v 1.1 2004/06/25 03:42:08 ribosome Exp $
+
+*transfac-3.2 (24 Jun 2004)
+
+  24 Jun 2004; Olivier Fisette <ribosome@gentoo.org>
+  transfac-3.2.ebuild, metadata.xml :
+  Initial import.  Ebuild submitted by Olivier Fisette <ribosome@gentoo.org>.
+  Reference: Gentoo Bugzilla, bug #54327
+
diff --git a/app-sci/transfac/files/digest-transfac-3.2 b/app-sci/transfac/files/digest-transfac-3.2
new file mode 100644 (file)
index 0000000..6317944
--- /dev/null
@@ -0,0 +1 @@
+MD5 f65c3263ff45f1f69bc76caa0e0705ec transfac32.tar.Z 3346266
diff --git a/app-sci/transfac/metadata.xml b/app-sci/transfac/metadata.xml
new file mode 100644 (file)
index 0000000..870758f
--- /dev/null
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer>
+               <email>ribosome@gentoo.org</email>
+               <name>Olivier Fisette</name>
+       </maintainer>
+       <herd>sci</herd>
+       <longdescription>
+               TRANSFAC® is a database of eukaryotic transcription factors, of their
+               genomic binding sites and DNA-binding profiles. TRANSFAC 3.2 is an old
+               public version available at the European Bioinformatics Institute.
+               TRANSFAC® is currently maintained by the BIOBASE company. Altough they
+               offer public access to a more recent version of the database, they
+               offer no free downloadable version.
+       </longdescription>
+</pkgmetadata>
diff --git a/app-sci/transfac/transfac-3.2.ebuild b/app-sci/transfac/transfac-3.2.ebuild
new file mode 100644 (file)
index 0000000..a449335
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/transfac/transfac-3.2.ebuild,v 1.1 2004/06/25 03:42:08 ribosome Exp $
+
+DESCRIPTION="A database of eucaryotic transcription factors"
+HOMEPAGE="http://www.gene-regulation.com/pub/databases.html"
+SRC_URI="ftp://ftp.ebi.ac.uk/pub/databases/${PN}/${PN}32.tar.Z"
+LICENSE="public-domain"
+
+SLOT="3"
+KEYWORDS="~x86"
+IUSE="no-emboss no-rawdb"
+
+S=${WORKDIR}
+
+src_compile() {
+       # Index the database for use with emboss if emboss is installed and
+       # the user did not explicitly request not to index the database.
+       if [ -e /usr/bin/tfextract ] && ! use no-emboss; then
+               einfo "Indexing TRANSFAC for usage with EMBOSS."
+               EMBOSS_DATA=. tfextract -auto -infile class.dat  || die \
+                       "Indexing TRANSFAC failed."
+       fi
+}
+
+src_install() {
+       if ! use no-rawdb; then
+               insinto /usr/share/${PN}-${SLOT}
+               doins *.dat
+       fi
+       if [ -e /usr/bin/tfextract ] && ! use no-emboss; then
+               insinto /usr/share/EMBOSS/data
+               doins tf*
+       fi
+}