dev-python/httpbin: Port to py39
authorMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 09:58:05 +0000 (11:58 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 10:35:40 +0000 (12:35 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/httpbin/httpbin-0.7.0.ebuild

index a2639d7ce4e3a217c5c03f23f6317f9f314900a6..0c6a3d727d4e8abe01a96cab9b5aedb0e0eedbf4 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
 
 inherit distutils-r1
 
@@ -24,8 +24,6 @@ RDEPEND="
        dev-python/markupsafe[${PYTHON_USEDEP}]
        dev-python/six[${PYTHON_USEDEP}]
        >=dev-python/werkzeug-0.14.1[${PYTHON_USEDEP}]"
-BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]"
 
 PATCHES=(
        # do not import raven if it's not going to be used