net-libs/webkit-gtk: security cleanup
authorMart Raudsepp <leio@gentoo.org>
Mon, 14 Jan 2019 19:41:56 +0000 (21:41 +0200)
committerMart Raudsepp <leio@gentoo.org>
Mon, 14 Jan 2019 19:50:59 +0000 (21:50 +0200)
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
net-libs/webkit-gtk/Manifest
net-libs/webkit-gtk/webkit-gtk-2.22.2.ebuild [deleted file]
net-libs/webkit-gtk/webkit-gtk-2.22.4.ebuild [deleted file]

index 682450d5c3dff205951685b57ed10a736a315175..0d1f8e478e92dc8976189991b6700f66ba991f32 100644 (file)
@@ -1,3 +1 @@
-DIST webkitgtk-2.22.2.tar.xz 16769120 BLAKE2B 19b226e657a324ab0efcfdcda3b22bc21a3b1cae29325f89ebd555dfb45d02d23f495ebf3817cb4c5e662c813b8d75754e0051d84afb84ea1347bf25a321e5d0 SHA512 0bb885726872f128a0e0d71cbc75ba076e5c0c928c40e71e030c87444a7068568c568587514407d6549c27d0bfe121dc33f96f0c516d2ae1c6801e005ad52756
-DIST webkitgtk-2.22.4.tar.xz 16752132 BLAKE2B a60f1c6168ba1ef19c931030017a58a640f0ff4a8d5bf97b278fff50f86374d5e10e06d95837e90c5a653a4c226095321ae86fdd64e61d846821979343b7350b SHA512 a46107f7da8513b06bd1e5685c03ca7f1a48af66b817908b8e61f1b343d98e122af73ccdeb47657cf4378fe33107fdc119a9a51d87db07ad5316ab39ed0db55f
 DIST webkitgtk-2.22.5.tar.xz 16774560 BLAKE2B fb022febf72727d59a1ca9490c8de48ade5a07ff3688b6962481608b9e0d27319282c842eb214783021745c1beb893b8842036c62542874e011f2ab60d275f17 SHA512 fcea9fab3d71869cc10e322b1b63864a9594624f6aa3e29efd8b47e5ca639145f8c2cdb299ecb51eadf3ac1238dac06b4b7ebe94969b2f61a21cea8b609007bc
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.22.2.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.22.2.ebuild
deleted file mode 100644 (file)
index 4b4d6c0..0000000
+++ /dev/null
@@ -1,274 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-CMAKE_MAKEFILE_GENERATOR="ninja"
-PYTHON_COMPAT=( python2_7 )
-USE_RUBY="ruby23 ruby24 ruby25"
-
-inherit check-reqs cmake-utils flag-o-matic gnome2 pax-utils python-any-r1 ruby-single toolchain-funcs virtualx
-
-MY_P="webkitgtk-${PV}"
-DESCRIPTION="Open source web browser engine"
-HOMEPAGE="https://www.webkitgtk.org"
-SRC_URI="https://www.webkitgtk.org/releases/${MY_P}.tar.xz"
-
-LICENSE="LGPL-2+ BSD"
-SLOT="4/37" # soname version of libwebkit2gtk-4.0
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x86-macos"
-
-IUSE="aqua coverage doc +egl +geolocation gles2 gnome-keyring +gstreamer +introspection +jit libnotify nsplugin +opengl spell wayland +webgl +X"
-
-# webgl needs gstreamer, bug #560612
-REQUIRED_USE="
-       geolocation? ( introspection )
-       gles2? ( egl !opengl )
-       introspection? ( gstreamer )
-       nsplugin? ( X )
-       webgl? ( gstreamer
-               || ( gles2 opengl ) )
-       wayland? ( egl )
-       || ( aqua wayland X )
-"
-
-# Tests fail to link for inexplicable reasons
-# https://bugs.webkit.org/show_bug.cgi?id=148210
-RESTRICT="test"
-
-# Aqua support in gtk3 is untested
-# Dependencies found at Source/cmake/OptionsGTK.cmake
-# Various compile-time optionals for gtk+-3.22.0 - ensure it
-# Missing OpenWebRTC checks and conditionals, but ENABLE_MEDIA_STREAM/ENABLE_WEB_RTC is experimental upstream (PRIVATE OFF)
-# TODO: Raise gst-plugins-opus dep to 1.14.4-r1 once we can, and eventually drop the blocker from epiphany; or remove the dep when older than -opus-1.14.4-r1 is not available anymore
-RDEPEND="
-       >=x11-libs/cairo-1.10.2:=[X?]
-       >=media-libs/fontconfig-2.8.0:1.0
-       >=media-libs/freetype-2.4.2:2
-       >=dev-libs/libgcrypt-1.6.0:0=
-       >=x11-libs/gtk+-3.22:3[aqua?,introspection?,wayland?,X?]
-       >=media-libs/harfbuzz-1.3.3:=[icu(+)]
-       >=dev-libs/icu-3.8.1-r1:=
-       virtual/jpeg:0=
-       >=net-libs/libsoup-2.48:2.4[introspection?]
-       >=dev-libs/libxml2-2.8.0:2
-       >=media-libs/libpng-1.4:0=
-       dev-db/sqlite:3=
-       sys-libs/zlib:0
-       >=dev-libs/atk-2.8.0
-       media-libs/libwebp:=
-
-       >=dev-libs/glib-2.40:2
-       >=dev-libs/libxslt-1.1.7
-       media-libs/woff2
-       gnome-keyring? ( app-crypt/libsecret )
-       geolocation? ( >=app-misc/geoclue-2.1.5:2.0 )
-       introspection? ( >=dev-libs/gobject-introspection-1.32.0:= )
-       dev-libs/libtasn1:=
-       >=dev-libs/libgcrypt-1.7.0:0=
-       nsplugin? ( >=x11-libs/gtk+-2.24.10:2 )
-       spell? ( >=app-text/enchant-0.22:= )
-       gstreamer? (
-               >=media-libs/gstreamer-1.8.3:1.0
-               >=media-libs/gst-plugins-base-1.8.3:1.0
-               >=media-plugins/gst-plugins-opus-1.8.3:1.0
-               >=media-libs/gst-plugins-bad-1.10:1.0[egl?,gles2?,opengl?] )
-
-       X? (
-               x11-libs/libX11
-               x11-libs/libXcomposite
-               x11-libs/libXdamage
-               x11-libs/libXrender
-               x11-libs/libXt )
-
-       libnotify? ( x11-libs/libnotify )
-       dev-libs/hyphen
-
-       egl? ( media-libs/mesa[egl] )
-       gles2? ( media-libs/mesa[gles2] )
-       opengl? ( virtual/opengl )
-       webgl? (
-               x11-libs/libXcomposite
-               x11-libs/libXdamage )
-"
-
-# paxctl needed for bug #407085
-# Need real bison, not yacc
-DEPEND="${RDEPEND}
-       ${PYTHON_DEPS}
-       ${RUBY_DEPS}
-       >=app-accessibility/at-spi2-core-2.5.3
-       >=dev-lang/perl-5.10
-       dev-util/glib-utils
-       >=dev-util/gtk-doc-am-1.10
-       >=dev-util/gperf-3.0.1
-       >=sys-devel/bison-2.4.3
-       || ( >=sys-devel/gcc-6.0 >=sys-devel/clang-3.3 )
-       sys-devel/gettext
-       virtual/pkgconfig
-
-       dev-lang/perl
-       virtual/perl-Data-Dumper
-       virtual/perl-Carp
-       virtual/perl-JSON-PP
-
-       doc? ( >=dev-util/gtk-doc-1.10 )
-       geolocation? ( dev-util/gdbus-codegen )
-       introspection? ( jit? ( sys-apps/paxctl ) )
-"
-#      test? (
-#              dev-python/pygobject:3[python_targets_python2_7]
-#              x11-themes/hicolor-icon-theme
-#              jit? ( sys-apps/paxctl ) )
-
-S="${WORKDIR}/${MY_P}"
-
-CHECKREQS_DISK_BUILD="18G" # and even this might not be enough, bug #417307
-
-pkg_pretend() {
-       if [[ ${MERGE_TYPE} != "binary" ]] ; then
-               if is-flagq "-g*" && ! is-flagq "-g*0" ; then
-                       einfo "Checking for sufficient disk space to build ${PN} with debugging CFLAGS"
-                       check-reqs_pkg_pretend
-               fi
-
-               if ! test-flag-CXX -std=c++11 ; then
-                       die "You need at least GCC 4.9.x or Clang >= 3.3 for C++11-specific compiler flags"
-               fi
-
-               if tc-is-gcc && [[ $(gcc-version) < 4.9 ]] ; then
-                       die 'The active compiler needs to be gcc 4.9 (or newer)'
-               fi
-       fi
-}
-
-pkg_setup() {
-       if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
-               check-reqs_pkg_setup
-       fi
-
-       python-any-r1_pkg_setup
-}
-
-src_prepare() {
-       cmake-utils_src_prepare
-       gnome2_src_prepare
-}
-
-src_configure() {
-       # Respect CC, otherwise fails on prefix #395875
-       tc-export CC
-
-       # Arches without JIT support also need this to really disable it in all places
-       use jit || append-cppflags -DENABLE_JIT=0 -DENABLE_YARR_JIT=0 -DENABLE_ASSEMBLER=0
-
-       # It does not compile on alpha without this in LDFLAGS
-       # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
-       use alpha && append-ldflags "-Wl,--no-relax"
-
-       # ld segfaults on ia64 with LDFLAGS --as-needed, bug #555504
-       use ia64 && append-ldflags "-Wl,--no-as-needed"
-
-       # Sigbuses on SPARC with mcpu and co., bug #???
-       use sparc && filter-flags "-mvis"
-
-       # https://bugs.webkit.org/show_bug.cgi?id=42070 , #301634
-       use ppc64 && append-flags "-mminimal-toc"
-
-       # Try to use less memory, bug #469942 (see Fedora .spec for reference)
-       # --no-keep-memory doesn't work on ia64, bug #502492
-       if ! use ia64; then
-               append-ldflags "-Wl,--no-keep-memory"
-       fi
-
-       # We try to use gold when possible for this package
-#      if ! tc-ld-is-gold ; then
-#              append-ldflags "-Wl,--reduce-memory-overheads"
-#      fi
-
-       # Multiple rendering bugs on youtube, github, etc without this, bug #547224
-       append-flags $(test-flags -fno-strict-aliasing)
-
-       # Ruby situation is a bit complicated. See bug 513888
-       local rubyimpl
-       local ruby_interpreter=""
-       for rubyimpl in ${USE_RUBY}; do
-               if has_version "virtual/rubygems[ruby_targets_${rubyimpl}]"; then
-                       ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ${rubyimpl})"
-               fi
-       done
-       # This will rarely occur. Only a couple of corner cases could lead us to
-       # that failure. See bug 513888
-       [[ -z $ruby_interpreter ]] && die "No suitable ruby interpreter found"
-
-       # TODO: Check Web Audio support
-       # should somehow let user select between them?
-       #
-       # FTL_JIT requires llvm
-       #
-       # opengl needs to be explicetly handled, bug #576634
-
-       local opengl_enabled
-       if use opengl || use gles2; then
-               opengl_enabled=ON
-       else
-               opengl_enabled=OFF
-       fi
-
-       local mycmakeargs=(
-               -DENABLE_QUARTZ_TARGET=$(usex aqua)
-               -DENABLE_API_TESTS=$(usex test)
-               -DENABLE_GTKDOC=$(usex doc)
-               -DENABLE_GEOLOCATION=$(usex geolocation)
-               $(cmake-utils_use_find_package gles2 OpenGLES2)
-               -DENABLE_GLES2=$(usex gles2)
-               -DENABLE_VIDEO=$(usex gstreamer)
-               -DENABLE_WEB_AUDIO=$(usex gstreamer)
-               -DENABLE_INTROSPECTION=$(usex introspection)
-               -DENABLE_JIT=$(usex jit)
-               -DUSE_LIBNOTIFY=$(usex libnotify)
-               -DUSE_LIBSECRET=$(usex gnome-keyring)
-               -DUSE_WOFF2=ON
-               -DENABLE_PLUGIN_PROCESS_GTK2=$(usex nsplugin)
-               -DENABLE_SPELLCHECK=$(usex spell)
-               -DENABLE_WAYLAND_TARGET=$(usex wayland)
-               -DENABLE_WEBGL=$(usex webgl)
-               $(cmake-utils_use_find_package egl EGL)
-               $(cmake-utils_use_find_package opengl OpenGL)
-               -DENABLE_X11_TARGET=$(usex X)
-               -DENABLE_OPENGL=${opengl_enabled}
-               -DCMAKE_BUILD_TYPE=Release
-               -DPORT=GTK
-               ${ruby_interpreter}
-       )
-
-       # Allow it to use GOLD when possible as it has all the magic to
-       # detect when to use it and using gold for this concrete package has
-       # multiple advantages and is also the upstream default, bug #585788
-#      if tc-ld-is-gold ; then
-#              mycmakeargs+=( -DUSE_LD_GOLD=ON )
-#      else
-#              mycmakeargs+=( -DUSE_LD_GOLD=OFF )
-#      fi
-
-       cmake-utils_src_configure
-}
-
-src_compile() {
-       cmake-utils_src_compile
-}
-
-src_test() {
-       # Prevents test failures on PaX systems
-       use jit && pax-mark m $(list-paxables Programs/*[Tt]ests/*) # Programs/unittests/.libs/test*
-
-       cmake-utils_src_test
-}
-
-src_install() {
-       cmake-utils_src_install
-
-       # Prevents crashes on PaX systems, bug #522808
-       use jit && pax-mark m "${ED}usr/libexec/webkit2gtk-4.0/jsc" "${ED}usr/libexec/webkit2gtk-4.0/WebKitWebProcess"
-       pax-mark m "${ED}usr/libexec/webkit2gtk-4.0/WebKitPluginProcess"
-       use nsplugin && pax-mark m "${ED}usr/libexec/webkit2gtk-4.0/WebKitPluginProcess"2
-}
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.22.4.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.22.4.ebuild
deleted file mode 100644 (file)
index 3b79a26..0000000
+++ /dev/null
@@ -1,279 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-CMAKE_MAKEFILE_GENERATOR="ninja"
-PYTHON_COMPAT=( python2_7 )
-USE_RUBY="ruby23 ruby24 ruby25"
-
-inherit check-reqs cmake-utils flag-o-matic gnome2 pax-utils python-any-r1 ruby-single toolchain-funcs virtualx
-
-MY_P="webkitgtk-${PV}"
-DESCRIPTION="Open source web browser engine"
-HOMEPAGE="https://www.webkitgtk.org"
-SRC_URI="https://www.webkitgtk.org/releases/${MY_P}.tar.xz"
-
-LICENSE="LGPL-2+ BSD"
-SLOT="4/37" # soname version of libwebkit2gtk-4.0
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x86-macos"
-
-IUSE="aqua coverage doc +egl +geolocation gles2 gnome-keyring +gstreamer +introspection +jit libnotify nsplugin +opengl spell wayland +webgl +X"
-
-# webgl needs gstreamer, bug #560612
-# gstreamer with opengl/gles2 needs egl
-# Review on bumps if fixed upstream and adjust accordingly:
-# non-GL builds are broken - https://bugs.webkit.org/show_bug.cgi?id=191997
-# GstreamerGL gets built even with GL disabled (thus requiring opengl or gles2 with gstreamer) - https://bugs.webkit.org/show_bug.cgi?id=191998
-REQUIRED_USE="
-       ^^ ( opengl gles2 )
-       geolocation? ( introspection )
-       gles2? ( egl !opengl )
-       gstreamer? ( opengl? ( egl ) )
-       nsplugin? ( X )
-       webgl? ( gstreamer
-               || ( gles2 opengl ) )
-       wayland? ( egl )
-       || ( aqua wayland X )
-"
-
-# Tests fail to link for inexplicable reasons
-# https://bugs.webkit.org/show_bug.cgi?id=148210
-RESTRICT="test"
-
-# Aqua support in gtk3 is untested
-# Dependencies found at Source/cmake/OptionsGTK.cmake
-# Various compile-time optionals for gtk+-3.22.0 - ensure it
-# Missing OpenWebRTC checks and conditionals, but ENABLE_MEDIA_STREAM/ENABLE_WEB_RTC is experimental upstream (PRIVATE OFF)
-# >=gst-plugins-opus-1.14.4-r1 for opusparse (required by MSE)
-RDEPEND="
-       >=x11-libs/cairo-1.10.2:=[X?]
-       >=media-libs/fontconfig-2.8.0:1.0
-       >=media-libs/freetype-2.4.2:2
-       >=dev-libs/libgcrypt-1.6.0:0=
-       >=x11-libs/gtk+-3.22:3[aqua?,introspection?,wayland?,X?]
-       >=media-libs/harfbuzz-1.3.3:=[icu(+)]
-       >=dev-libs/icu-3.8.1-r1:=
-       virtual/jpeg:0=
-       >=net-libs/libsoup-2.48:2.4[introspection?]
-       >=dev-libs/libxml2-2.8.0:2
-       >=media-libs/libpng-1.4:0=
-       dev-db/sqlite:3=
-       sys-libs/zlib:0
-       >=dev-libs/atk-2.8.0
-       media-libs/libwebp:=
-
-       >=dev-libs/glib-2.40:2
-       >=dev-libs/libxslt-1.1.7
-       media-libs/woff2
-       gnome-keyring? ( app-crypt/libsecret )
-       geolocation? ( >=app-misc/geoclue-2.1.5:2.0 )
-       introspection? ( >=dev-libs/gobject-introspection-1.32.0:= )
-       dev-libs/libtasn1:=
-       >=dev-libs/libgcrypt-1.7.0:0=
-       nsplugin? ( >=x11-libs/gtk+-2.24.10:2 )
-       spell? ( >=app-text/enchant-0.22:= )
-       gstreamer? (
-               >=media-libs/gstreamer-1.14:1.0
-               >=media-libs/gst-plugins-base-1.14:1.0[egl?,gles2?,opengl?]
-               >=media-plugins/gst-plugins-opus-1.14.4-r1:1.0
-               >=media-libs/gst-plugins-bad-1.14:1.0 )
-
-       X? (
-               x11-libs/libX11
-               x11-libs/libXcomposite
-               x11-libs/libXdamage
-               x11-libs/libXrender
-               x11-libs/libXt )
-
-       libnotify? ( x11-libs/libnotify )
-       dev-libs/hyphen
-
-       egl? ( media-libs/mesa[egl] )
-       gles2? ( media-libs/mesa[gles2] )
-       opengl? ( virtual/opengl )
-       webgl? (
-               x11-libs/libXcomposite
-               x11-libs/libXdamage )
-"
-
-# paxctl needed for bug #407085
-# Need real bison, not yacc
-DEPEND="${RDEPEND}
-       ${PYTHON_DEPS}
-       ${RUBY_DEPS}
-       >=app-accessibility/at-spi2-core-2.5.3
-       >=dev-lang/perl-5.10
-       dev-util/glib-utils
-       >=dev-util/gtk-doc-am-1.10
-       >=dev-util/gperf-3.0.1
-       >=sys-devel/bison-2.4.3
-       || ( >=sys-devel/gcc-6.0 >=sys-devel/clang-3.3 )
-       sys-devel/gettext
-       virtual/pkgconfig
-
-       dev-lang/perl
-       virtual/perl-Data-Dumper
-       virtual/perl-Carp
-       virtual/perl-JSON-PP
-
-       doc? ( >=dev-util/gtk-doc-1.10 )
-       geolocation? ( dev-util/gdbus-codegen )
-       introspection? ( jit? ( sys-apps/paxctl ) )
-"
-#      test? (
-#              dev-python/pygobject:3[python_targets_python2_7]
-#              x11-themes/hicolor-icon-theme
-#              jit? ( sys-apps/paxctl ) )
-
-S="${WORKDIR}/${MY_P}"
-
-CHECKREQS_DISK_BUILD="18G" # and even this might not be enough, bug #417307
-
-pkg_pretend() {
-       if [[ ${MERGE_TYPE} != "binary" ]] ; then
-               if is-flagq "-g*" && ! is-flagq "-g*0" ; then
-                       einfo "Checking for sufficient disk space to build ${PN} with debugging CFLAGS"
-                       check-reqs_pkg_pretend
-               fi
-
-               if ! test-flag-CXX -std=c++11 ; then
-                       die "You need at least GCC 4.9.x or Clang >= 3.3 for C++11-specific compiler flags"
-               fi
-
-               if tc-is-gcc && [[ $(gcc-version) < 4.9 ]] ; then
-                       die 'The active compiler needs to be gcc 4.9 (or newer)'
-               fi
-       fi
-}
-
-pkg_setup() {
-       if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
-               check-reqs_pkg_setup
-       fi
-
-       python-any-r1_pkg_setup
-}
-
-src_prepare() {
-       cmake-utils_src_prepare
-       gnome2_src_prepare
-}
-
-src_configure() {
-       # Respect CC, otherwise fails on prefix #395875
-       tc-export CC
-
-       # Arches without JIT support also need this to really disable it in all places
-       use jit || append-cppflags -DENABLE_JIT=0 -DENABLE_YARR_JIT=0 -DENABLE_ASSEMBLER=0
-
-       # It does not compile on alpha without this in LDFLAGS
-       # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
-       use alpha && append-ldflags "-Wl,--no-relax"
-
-       # ld segfaults on ia64 with LDFLAGS --as-needed, bug #555504
-       use ia64 && append-ldflags "-Wl,--no-as-needed"
-
-       # Sigbuses on SPARC with mcpu and co., bug #???
-       use sparc && filter-flags "-mvis"
-
-       # https://bugs.webkit.org/show_bug.cgi?id=42070 , #301634
-       use ppc64 && append-flags "-mminimal-toc"
-
-       # Try to use less memory, bug #469942 (see Fedora .spec for reference)
-       # --no-keep-memory doesn't work on ia64, bug #502492
-       if ! use ia64; then
-               append-ldflags "-Wl,--no-keep-memory"
-       fi
-
-       # We try to use gold when possible for this package
-#      if ! tc-ld-is-gold ; then
-#              append-ldflags "-Wl,--reduce-memory-overheads"
-#      fi
-
-       # Multiple rendering bugs on youtube, github, etc without this, bug #547224
-       append-flags $(test-flags -fno-strict-aliasing)
-
-       # Ruby situation is a bit complicated. See bug 513888
-       local rubyimpl
-       local ruby_interpreter=""
-       for rubyimpl in ${USE_RUBY}; do
-               if has_version "virtual/rubygems[ruby_targets_${rubyimpl}]"; then
-                       ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ${rubyimpl})"
-               fi
-       done
-       # This will rarely occur. Only a couple of corner cases could lead us to
-       # that failure. See bug 513888
-       [[ -z $ruby_interpreter ]] && die "No suitable ruby interpreter found"
-
-       # TODO: Check Web Audio support
-       # should somehow let user select between them?
-       #
-       # FTL_JIT requires llvm
-       #
-       # opengl needs to be explicetly handled, bug #576634
-
-       local opengl_enabled
-       if use opengl || use gles2; then
-               opengl_enabled=ON
-       else
-               opengl_enabled=OFF
-       fi
-
-       local mycmakeargs=(
-               -DENABLE_QUARTZ_TARGET=$(usex aqua)
-               -DENABLE_API_TESTS=$(usex test)
-               -DENABLE_GTKDOC=$(usex doc)
-               -DENABLE_GEOLOCATION=$(usex geolocation)
-               $(cmake-utils_use_find_package gles2 OpenGLES2)
-               -DENABLE_GLES2=$(usex gles2)
-               -DENABLE_VIDEO=$(usex gstreamer)
-               -DENABLE_WEB_AUDIO=$(usex gstreamer)
-               -DENABLE_INTROSPECTION=$(usex introspection)
-               -DENABLE_JIT=$(usex jit)
-               -DUSE_LIBNOTIFY=$(usex libnotify)
-               -DUSE_LIBSECRET=$(usex gnome-keyring)
-               -DUSE_WOFF2=ON
-               -DENABLE_PLUGIN_PROCESS_GTK2=$(usex nsplugin)
-               -DENABLE_SPELLCHECK=$(usex spell)
-               -DENABLE_WAYLAND_TARGET=$(usex wayland)
-               -DENABLE_WEBGL=$(usex webgl)
-               $(cmake-utils_use_find_package egl EGL)
-               $(cmake-utils_use_find_package opengl OpenGL)
-               -DENABLE_X11_TARGET=$(usex X)
-               -DENABLE_OPENGL=${opengl_enabled}
-               -DCMAKE_BUILD_TYPE=Release
-               -DPORT=GTK
-               ${ruby_interpreter}
-       )
-
-       # Allow it to use GOLD when possible as it has all the magic to
-       # detect when to use it and using gold for this concrete package has
-       # multiple advantages and is also the upstream default, bug #585788
-#      if tc-ld-is-gold ; then
-#              mycmakeargs+=( -DUSE_LD_GOLD=ON )
-#      else
-#              mycmakeargs+=( -DUSE_LD_GOLD=OFF )
-#      fi
-
-       cmake-utils_src_configure
-}
-
-src_compile() {
-       cmake-utils_src_compile
-}
-
-src_test() {
-       # Prevents test failures on PaX systems
-       use jit && pax-mark m $(list-paxables Programs/*[Tt]ests/*) # Programs/unittests/.libs/test*
-
-       cmake-utils_src_test
-}
-
-src_install() {
-       cmake-utils_src_install
-
-       # Prevents crashes on PaX systems, bug #522808
-       use jit && pax-mark m "${ED}usr/libexec/webkit2gtk-4.0/jsc" "${ED}usr/libexec/webkit2gtk-4.0/WebKitWebProcess"
-       pax-mark m "${ED}usr/libexec/webkit2gtk-4.0/WebKitPluginProcess"
-       use nsplugin && pax-mark m "${ED}usr/libexec/webkit2gtk-4.0/WebKitPluginProcess"2
-}