add use deps for libsdl; tidy
authorMichael Sterrett <mr_bones_@gentoo.org>
Thu, 24 Sep 2015 16:03:00 +0000 (12:03 -0400)
committerMichael Sterrett <mr_bones_@gentoo.org>
Thu, 24 Sep 2015 16:03:00 +0000 (12:03 -0400)
Package-Manager: portage-2.2.20.1

games-puzzle/fbg/fbg-0.9-r1.ebuild

index d409745878c4bd0e37c4a9b1de71b7e5e3505d18..47b2a2af1dbdb7542945824c0b3b4ef82d3af5e7 100644 (file)
@@ -1,6 +1,7 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
+
 EAPI=5
 inherit eutils games
 
@@ -16,17 +17,16 @@ IUSE=""
 DEPEND="virtual/opengl
        virtual/glu
        dev-games/physfs
-       media-libs/libsdl
+       media-libs/libsdl[opengl,video]
        media-libs/libmikmod
        x11-libs/libXt"
-RDEPEND="${DEPEND}"
+RDEPEND=${DEPEND}
 
 src_prepare() {
        sed -i \
                -e "/FBGDATADIR=/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" \
                -e '/^datadir=/d' \
-               configure \
-               || die "sed failed"
+               configure || die
 }
 
 src_configure() {