net-print/cnijfilter2: fix compiling with fno-common
authorAlfredo Tupone <tupone@gentoo.org>
Sat, 16 May 2020 17:34:42 +0000 (19:34 +0200)
committerAlfredo Tupone <tupone@gentoo.org>
Sat, 16 May 2020 17:34:42 +0000 (19:34 +0200)
Closes: https://bugs.gentoo.org/723186
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
net-print/cnijfilter2/cnijfilter2-5.80.ebuild
net-print/cnijfilter2/files/cnijfilter2-5.80-fno-common.patch [new file with mode: 0644]

index 4efba8cd2e1cc5246bcdff3f223ce50b7d93cbad..ec45c101ab1f2c81d9459510449aa849e657bf3e 100644 (file)
@@ -34,6 +34,7 @@ S="${WORKDIR}"/${MY_P}
 PATCHES=(
        "${FILESDIR}"/${PN}-5.70-gentoo.patch
        "${FILESDIR}"/${P}-cflags.patch
+       "${FILESDIR}"/${P}-fno-common.patch
 )
 
 src_prepare() {
diff --git a/net-print/cnijfilter2/files/cnijfilter2-5.80-fno-common.patch b/net-print/cnijfilter2/files/cnijfilter2-5.80-fno-common.patch
new file mode 100644 (file)
index 0000000..7374aa9
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/lgmon3/src/cnijlgmon3.c  2020-05-16 19:28:03.585781655 +0200
++++ b/lgmon3/src/cnijlgmon3.c  2020-05-16 19:28:13.488625335 +0200
+@@ -55,7 +55,7 @@
+ int (*GET_STATUS)(char *, int, int *, int * , char *);
+ int (*GET_STATUS2)(char *, int, char *, int *, int * , char *, char *);
+ int (*GET_STATUS2_MAINTENANCE)(char *, int, char *, int *, int * , char *, char *);
+-int (*GET_PROTOCOL)(char *, size_t);
++static int (*GET_PROTOCOL)(char *, size_t);
+  int main(int argc, char *argv[])