Version bump for 2.18.1
authorSaleem Abdulrasool <compnerd@gentoo.org>
Tue, 17 Apr 2007 03:34:30 +0000 (03:34 +0000)
committerSaleem Abdulrasool <compnerd@gentoo.org>
Tue, 17 Apr 2007 03:34:30 +0000 (03:34 +0000)
Package-Manager: portage-2.1.2.4

gnome-base/gnome-vfs/ChangeLog
gnome-base/gnome-vfs/files/digest-gnome-vfs-2.18.1 [new file with mode: 0644]
gnome-base/gnome-vfs/gnome-vfs-2.18.1.ebuild [new file with mode: 0644]
gnome-base/nautilus/ChangeLog
gnome-base/nautilus/files/digest-nautilus-2.18.1 [new file with mode: 0644]
gnome-base/nautilus/nautilus-2.18.1.ebuild [new file with mode: 0644]

index adbc0f3cf1168bfc12afea9209ac7a5c04af6bda..33155fb953b78ddad793f232e630d5ac409dc33c 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for gnome-base/gnome-vfs
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/ChangeLog,v 1.245 2007/03/24 02:09:30 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/ChangeLog,v 1.246 2007/04/17 03:32:28 compnerd Exp $
+
+*gnome-vfs-2.18.1 (17 Apr 2007)
+
+  17 Apr 2007; Saleem Abdulrasool <compnerd@gentoo.org>
+  +gnome-vfs-2.18.1.ebuild:
+  Version bump for 2.18.1
 
   24 Mar 2007; Daniel Gryniewicz <dang@gentoo.org>
   +gnome-vfs-2.18.0.1.ebuild:
diff --git a/gnome-base/gnome-vfs/files/digest-gnome-vfs-2.18.1 b/gnome-base/gnome-vfs/files/digest-gnome-vfs-2.18.1
new file mode 100644 (file)
index 0000000..c745ebe
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 bf4a6d95180d05981893e5d021c6695c gnome-vfs-2.18.1.tar.bz2 1916897
+RMD160 ff2fc7a7c47b85a03d65964a8ad1d7d585698f3d gnome-vfs-2.18.1.tar.bz2 1916897
+SHA256 098d920cb7d4a50e245deaafabfd8e06b86c88771d56be567597c09c09207f5e gnome-vfs-2.18.1.tar.bz2 1916897
diff --git a/gnome-base/gnome-vfs/gnome-vfs-2.18.1.ebuild b/gnome-base/gnome-vfs/gnome-vfs-2.18.1.ebuild
new file mode 100644 (file)
index 0000000..2e63d9a
--- /dev/null
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/gnome-vfs-2.18.1.ebuild,v 1.1 2007/04/17 03:32:28 compnerd Exp $
+
+WANT_AUTOMAKE=1.8
+inherit eutils gnome2 autotools
+
+DESCRIPTION="Gnome Virtual Filesystem"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi doc gnutls hal ipv6 samba ssl"
+
+RDEPEND=">=gnome-base/gconf-2
+       >=dev-libs/glib-2.9.3
+       >=gnome-base/orbit-2.12.4
+       >=dev-libs/libxml2-2.6
+       >=net-misc/neon-0.25.3
+       app-arch/bzip2
+       virtual/fam
+       gnome-base/gnome-mime-data
+       >=x11-misc/shared-mime-info-0.14
+       || ( >=dev-libs/dbus-glib-0.71 <sys-apps/dbus-0.90 )
+       samba? ( >=net-fs/samba-3 )
+       gnutls? (
+                               net-libs/gnutls
+                               !gnome-extra/gnome-vfs-sftp
+                       )
+       ssl?    (
+               !gnutls?        (
+                               >=dev-libs/openssl-0.9.5
+                               !gnome-extra/gnome-vfs-sftp
+                               )
+               )
+       hal?    (
+                               >=sys-apps/hal-0.5.7
+                       )
+       avahi? ( >=net-dns/avahi-0.6 )"
+DEPEND="${RDEPEND}
+       sys-devel/gettext
+       >=dev-util/gtk-doc-1
+       gnome-base/gnome-common
+       >=dev-util/intltool-0.35
+       >=dev-util/pkgconfig-0.9"
+PDEPEND="hal? ( >=gnome-base/gnome-mount-0.4 )"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README TODO"
+
+pkg_setup() {
+       if use hal ; then
+               G2CONF="--with-hal-mount=/usr/bin/gnome-mount \
+                               --with-hal-umount=/usr/bin/gnome-umount \
+                               --with-hal-eject=/usr/bin/gnome-eject"
+       fi
+
+       G2CONF="${G2CONF}                 \
+               --disable-schemas-install     \
+               --disable-cdda                \
+               --disable-howl                \
+               --enable-http-neon            \
+               $(use_enable ssl openssl)     \
+               $(use_enable gnutls)          \
+               $(use_enable samba)           \
+               $(use_enable ipv6)            \
+               $(use_enable hal)             \
+               $(use_enable avahi)"
+
+       # this works because of the order of conifgure parsing
+       # so should always be behind the use_enable options
+       # foser <foser@gentoo.org 19 Apr 2004
+       use gnutls && use ssl && G2CONF="${G2CONF} --disable-openssl"
+}
+
+src_unpack() {
+       gnome2_src_unpack
+
+       # Allow the Trash on afs filesystems (#106118)
+       epatch "${FILESDIR}"/${PN}-2.12.0-afs.patch
+
+       # Fix compiling with headers missing
+       epatch "${FILESDIR}"/${PN}-2.15.2-headers-define.patch
+
+       # Fix for crashes running programs via sudo
+       epatch "${FILESDIR}"/${PN}-2.16.0-no-dbus-crash.patch
+
+       eautoreconf
+       intltoolize --force
+}
index 240010434453581524cfd0ee417e4d7347b2d97e..63ac3863b441ea6ae6d6f926485e8d22bef74508 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for gnome-base/nautilus
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.219 2007/03/28 01:34:36 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.220 2007/04/17 03:34:30 compnerd Exp $
+
+*nautilus-2.18.1 (17 Apr 2007)
+
+  17 Apr 2007; Saleem Abdulrasool <compnerd@gentoo.org>
+  +nautilus-2.18.1.ebuild:
+  Version bump for 2.18.1
 
   28 Mar 2007; Daniel Gryniewicz <dang@gentoo.org> nautilus-2.18.0.1.ebuild:
   Missed this one; should be unstable
diff --git a/gnome-base/nautilus/files/digest-nautilus-2.18.1 b/gnome-base/nautilus/files/digest-nautilus-2.18.1
new file mode 100644 (file)
index 0000000..fc98946
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 e4718f37080b7d98cd5707e617d43ae6 nautilus-2.18.1.tar.bz2 4325821
+RMD160 3cdef422befc96bbd921f2f4788d302cf9249204 nautilus-2.18.1.tar.bz2 4325821
+SHA256 b42e90788c14a4aecd748963135bf54fef20d7a19a448f7393d446028f73ec3b nautilus-2.18.1.tar.bz2 4325821
diff --git a/gnome-base/nautilus/nautilus-2.18.1.ebuild b/gnome-base/nautilus/nautilus-2.18.1.ebuild
new file mode 100644 (file)
index 0000000..a8e2d3a
--- /dev/null
@@ -0,0 +1,80 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-2.18.1.ebuild,v 1.1 2007/04/17 03:34:30 compnerd Exp $
+
+inherit virtualx eutils gnome2
+
+DESCRIPTION="A file manager for the GNOME desktop"
+HOMEPAGE="http://www.gnome.org/projects/nautilus/"
+
+LICENSE="GPL-2 LGPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="beagle gnome tracker"
+# cups flac gstreamer mad ogg vorbis
+
+RDEPEND=">=media-libs/libart_lgpl-2.3.10
+       >=gnome-base/libbonobo-2.1
+       >=gnome-base/eel-2.15.92
+       >=media-sound/esound-0.2.27
+       >=dev-libs/glib-2.6
+       >=gnome-base/gnome-desktop-2.9.91
+       >=gnome-base/libgnome-2.14.0
+       >=gnome-base/libgnomeui-2.6
+       >=gnome-base/gnome-vfs-2.15
+       >=gnome-base/orbit-2.4
+       >=x11-libs/pango-1.1.2
+       >=x11-libs/gtk+-2.10
+       >=gnome-base/librsvg-2.0.1
+       >=dev-libs/libxml2-2.4.7
+       >=x11-libs/startup-notification-0.8
+       >=media-libs/libexif-0.5.12
+       >=gnome-base/gconf-2
+       beagle? ( >=app-misc/beagle-0.0.12 )
+       x86? ( tracker? ( >=app-misc/tracker-0.0.1 ) )
+       x11-libs/libICE
+       x11-libs/libSM
+       x11-proto/xproto
+       virtual/eject"
+#      !gstreamer? ( vorbis? ( media-sound/vorbis-tools ) )
+#      gstreamer? (
+#              >=media-libs/gstreamer-0.8
+#              >=media-libs/gst-plugins-0.8
+#              >=media-plugins/gst-plugins-gnomevfs-0.8
+#              mad? ( >=media-plugins/gst-plugins-mad-0.8 )
+#              ogg? ( >=media-plugins/gst-plugins-ogg-0.8 )
+#              vorbis? ( >=media-plugins/gst-plugins-vorbis-0.8 )
+#              flac? ( >=media-plugins/gst-plugins-flac-0.8 ) )"
+
+DEPEND="${RDEPEND}
+       sys-devel/gettext
+       >=dev-util/intltool-0.35
+       >=dev-util/pkgconfig-0.9"
+
+PDEPEND="gnome? ( >=x11-themes/gnome-icon-theme-1.1.91 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README THANKS TODO"
+
+
+pkg_setup() {
+       G2CONF="--disable-update-mimedb $(use_enable beagle) $(use_enable tracker)"
+}
+
+src_test() {
+       addwrite "/root/.gnome2_private"
+       Xmake check || die "Test phase failed"
+}
+
+src_unpack() {
+       gnome2_src_unpack
+
+       # fix relative include path breaking libIDL (#129366)
+       epatch "${FILESDIR}"/${PN}-2.16.0-idl_include.patch
+}
+
+pkg_postinst() {
+       gnome2_pkg_postinst
+       elog "nautilus can use mpg123 (media-sound/mpg123 or media-sound/mpg321)"
+       elog "to preview mp3 files, and ogg123 (media-sound/vorbis-tools) to"
+       elog "preview ogg files.  If you want such previews, emerge those packages"
+}