Cleaning up and using improved ebuild from bug #95845 thanks to Sebastien Fabbro
authorMarkus Ullmann <jokey@gentoo.org>
Thu, 30 Nov 2006 20:00:19 +0000 (20:00 +0000)
committerMarkus Ullmann <jokey@gentoo.org>
Thu, 30 Nov 2006 20:00:19 +0000 (20:00 +0000)
Package-Manager: portage-2.1.2_rc2-r2

dev-tcltk/tclx/ChangeLog
dev-tcltk/tclx/files/digest-tclx-8.4-r1 [new file with mode: 0644]
dev-tcltk/tclx/files/tclx-8.4-relid.patch [new file with mode: 0644]
dev-tcltk/tclx/files/tclx-8.4-varinit.patch [new file with mode: 0644]
dev-tcltk/tclx/tclx-8.4-r1.ebuild [new file with mode: 0644]

index 8d0b0c4275ed0305666b152d40413d18743cab91..7f1b00c75369ae6e4a322e23ecdf74730b89f60e 100644 (file)
@@ -1,6 +1,15 @@
 # ChangeLog for dev-tcltk/tclx
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/ChangeLog,v 1.30 2006/11/01 19:35:43 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/ChangeLog,v 1.31 2006/11/30 20:00:19 jokey Exp $
+
+*tclx-8.4-r1 (30 Nov 2006)
+
+30 Nov 2006; Markus Ullmann <jokey@gentoo.org> -files/tclx-8.3-argv.patch,
+  -files/tclx-8.3-makecfg.patch, +files/tclx-8.4-relid.patch,
+  +files/tclx-8.4-varinit.patch, -tclx-8.3-r1.ebuild, -tclx-8.4.ebuild,
+  +tclx-8.4-r1.ebuild:
+  Cleaning up and using improved ebuild from bug #95845 thanks to Sebastien
+  Fabbro
 
 *tclx-8.4 (01 Nov 2006)
 
diff --git a/dev-tcltk/tclx/files/digest-tclx-8.4-r1 b/dev-tcltk/tclx/files/digest-tclx-8.4-r1
new file mode 100644 (file)
index 0000000..f16f0f1
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 395c2fbe35e1723570b005161b9fc8f8 tclx8.4.tar.bz2 313595
+RMD160 96c10fdebfe97f4d2c59b61d1116ca0b3efddf7b tclx8.4.tar.bz2 313595
+SHA256 257591f9dffc21cf3ed541a9ef81a3ff5dd739dff5cebb70c4cec7010e2def66 tclx8.4.tar.bz2 313595
diff --git a/dev-tcltk/tclx/files/tclx-8.4-relid.patch b/dev-tcltk/tclx/files/tclx-8.4-relid.patch
new file mode 100644 (file)
index 0000000..45fe687
--- /dev/null
@@ -0,0 +1,31 @@
+--- tclx8.4/configure.relid    2006-02-03 16:13:25.000000000 -0500
++++ tclx8.4/configure  2006-02-03 16:13:33.000000000 -0500
+@@ -6999,7 +6999,7 @@
+           # results, and the version is kept in special file).
+           if test -r /etc/.relid -a "X`uname -n`" = "X`uname -s`" ; then
+-              system=MP-RAS-`awk '{print }' /etc/.relid'`
++              system=MP-RAS-`awk '{print }' /etc/.relid`
+           fi
+           if test "`uname -s`" = "AIX" ; then
+               system=AIX-`uname -v`.`uname -r`
+--- tclx8.4/tclconfig/tcl.m4.relid     2006-02-03 16:13:43.000000000 -0500
++++ tclx8.4/tclconfig/tcl.m4   2006-02-03 16:13:57.000000000 -0500
+@@ -859,7 +859,7 @@
+           # results, and the version is kept in special file).
+       
+           if test -r /etc/.relid -a "X`uname -n`" = "X`uname -s`" ; then
+-              system=MP-RAS-`awk '{print $3}' /etc/.relid'`
++              system=MP-RAS-`awk '{print $3}' /etc/.relid`
+           fi
+           if test "`uname -s`" = "AIX" ; then
+               system=AIX-`uname -v`.`uname -r`
+@@ -2302,7 +2302,7 @@
+           # results, and the version is kept in special file).
+       
+           if test -r /etc/.relid -a "X`uname -n`" = "X`uname -s`" ; then
+-              system=MP-RAS-`awk '{print $3}' /etc/.relid'`
++              system=MP-RAS-`awk '{print $3}' /etc/.relid`
+           fi
+           if test "`uname -s`" = "AIX" ; then
+               system=AIX-`uname -v`.`uname -r`
diff --git a/dev-tcltk/tclx/files/tclx-8.4-varinit.patch b/dev-tcltk/tclx/files/tclx-8.4-varinit.patch
new file mode 100644 (file)
index 0000000..08fe7d8
--- /dev/null
@@ -0,0 +1,11 @@
+--- tclx8.4/generic/tclXdup.c.varinit  2006-02-03 15:54:38.000000000 -0500
++++ tclx8.4/generic/tclXdup.c  2006-02-03 15:54:53.000000000 -0500
+@@ -202,7 +202,7 @@
+ {
+     Tcl_Channel newChannel;
+     int bindFnum, fnum;
+-    char *srcChannelId, *targetChannelId;
++    char *srcChannelId = NULL, *targetChannelId;
+     if ((objc < 2) || (objc > 3)) {
+         return TclX_WrongArgs (interp, objv [0],
diff --git a/dev-tcltk/tclx/tclx-8.4-r1.ebuild b/dev-tcltk/tclx/tclx-8.4-r1.ebuild
new file mode 100644 (file)
index 0000000..c433a8c
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/tclx-8.4-r1.ebuild,v 1.1 2006/11/30 20:00:19 jokey Exp $
+
+inherit eutils
+
+IUSE="tk threads"
+
+DESCRIPTION="A set of extensions to TCL"
+HOMEPAGE="http://tclx.sourceforge.net"
+SRC_URI="mirror://sourceforge/tclx/${PN}${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-lang/tcl-8.4.6
+       tk? ( >=dev-lang/tk-8.4.6 )"
+
+S=${WORKDIR}/${PN}${PV}
+
+src_unpack() {
+       unpack ${A}
+       epatch ${FILESDIR}/${P}-relid.patch
+       epatch ${FILESDIR}/${P}-varinit.patch
+}
+
+src_compile() {
+       econf \
+               $(use_enable tk) \
+               $(use_enable threads) \
+               --enable-shared \
+               || die "econf failed"
+       emake || die "emake failed"
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "emake install failed"
+       dodoc ChangeLog README
+       doman doc/*.[n3]
+}