media-libs/x265: bump to 3.0
authorAlexis Ballier <aballier@gentoo.org>
Wed, 6 Feb 2019 13:41:50 +0000 (14:41 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 6 Feb 2019 13:56:03 +0000 (14:56 +0100)
Package-Manager: Portage-2.3.59, Repoman-2.3.12
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
media-libs/x265/Manifest
media-libs/x265/x265-3.0.ebuild [new file with mode: 0644]
media-libs/x265/x265-9999.ebuild

index a10aac354ec00e879c57ec0ec9bcf6d078265bd3..7bdfb7745e7442f83e5a6e8ff365607da77340dc 100644 (file)
@@ -1,2 +1,3 @@
 DIST x265_2.8.tar.gz 1379551 BLAKE2B c124864a08492739cdde89e44d72c84ad94a0b236d2c59d995e53a26d1a5fb9ec1557a03640a3065a727be69bfb0c0633b50351dc875c9706a1550f488c8ee24 SHA512 c2a8eaec64aa022badcbcd2a96304a9abd9d08489300b6a9c4c9d76066f3d9848e6948238c84ae16ea91bff0b2fac528a67ee29950d94dcd0ea7c0e9e7baa714
 DIST x265_2.9.tar.gz 1385848 BLAKE2B ff14eba55cea0646ad0ffc12f9032c9033d23c9d805939fc3a049911ebae459eee097349f074dcd224bef97d6140dbc37ee9bd3db54c5473b158e135784d2179 SHA512 270818c7fd84947fde371e32bef225c1880cfb0bcd95378d95b51f50577a134d7cd585fcdfa43b103a24d76c5ad826b09509a07eb9e208e8f2b56f2f77365cf3
+DIST x265_3.0.tar.gz 1398519 BLAKE2B e3ac28b01e89ce8a428f294c759644a8177e1b79941aba5e1b53033c236e3445f9afeea96f8adf7e5cdcfff8c790ca9fcadcc8b2de6c31ba3fe9ba87321a8ca8 SHA512 bb7665194ddd4bccbb91c16337463ad4ef32111a1e7779e4cc16964df0992aa99e578cb74fef0edbf41119105e4085574247f60541b0558cc36730ea12d2c6ba
diff --git a/media-libs/x265/x265-3.0.ebuild b/media-libs/x265/x265-3.0.ebuild
new file mode 100644 (file)
index 0000000..8fff39d
--- /dev/null
@@ -0,0 +1,195 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils multilib-minimal multilib multibuild flag-o-matic
+
+if [[ ${PV} = 9999* ]]; then
+       inherit mercurial
+       EHG_REPO_URI="https://bitbucket.org/multicoreware/x265"
+else
+       SRC_URI="https://bitbucket.org/multicoreware/x265/downloads/${PN}_${PV}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Library for encoding video streams into the H.265/HEVC format"
+HOMEPAGE="http://x265.org/"
+
+LICENSE="GPL-2"
+# subslot = libx265 soname
+SLOT="0/169"
+IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
+
+ASM_DEPEND=">=dev-lang/yasm-1.2.0"
+RDEPEND="numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+       abi_x86_32? ( ${ASM_DEPEND} )
+       abi_x86_64? ( ${ASM_DEPEND} )"
+
+PATCHES=(
+       "${FILESDIR}/arm.patch"
+       "${FILESDIR}/neon.patch"
+       "${FILESDIR}/ppc64.patch"
+)
+
+src_unpack() {
+       if [[ ${PV} = 9999* ]]; then
+               mercurial_src_unpack
+               # Can't set it at global scope due to mercurial.eclass limitations...
+               export S=${WORKDIR}/${P}/source
+       else
+               unpack ${A}
+               export S="$(echo "${WORKDIR}/${PN}_"*"/source")"
+       fi
+}
+
+# By default, the library and the encoder is configured for only one output bit
+# depth. Meaning, one has to rebuild libx265 if (s)he wants to produce HEVC
+# files with a different bit depth, which is annoying. However, upstream
+# supports proper namespacing for 8bits, 10bits & 12bits HEVC and linking all
+# that together so that the resulting library can produce all three of them
+# instead of only one.
+# The API requires the bit depth parameter, so that libx265 can then chose which
+# variant of the encoder to use.
+# To achieve this, we have to build one (static) library for each non-main
+# variant, and link it into the main library.
+# Upstream documents using the 8bit variant as main library, hence we do not
+# allow disabling it: "main" *MUST* come last in the following list.
+
+x265_get_variants() {
+       local variants=""
+       use 12bit && variants+="main12 "
+       use 10bit && variants+="main10 "
+       variants+="main"
+       echo "${variants}"
+}
+
+x265_variant_src_configure() {
+       mkdir -p "${BUILD_DIR}" || die
+       pushd "${BUILD_DIR}" >/dev/null || die
+
+       local mycmakeargs=( "${myabicmakeargs[@]}" )
+       case "${MULTIBUILD_VARIANT}" in
+               "main12")
+                       mycmakeargs+=(
+                               -DHIGH_BIT_DEPTH=ON
+                               -DEXPORT_C_API=OFF
+                               -DENABLE_SHARED=OFF
+                               -DENABLE_CLI=OFF
+                               -DMAIN12=ON
+                       )
+                       if [[ ${ABI} = x86 ]] ; then
+                               mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
+                       fi
+                       if [[ ${ABI} = arm ]] ; then
+                               # 589674
+                               mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
+                       fi
+                       if [[ ${ABI} = ppc64 ]] ; then
+                               # https://bugs.gentoo.org/show_bug.cgi?id=607802#c5
+                               mycmakeargs+=( -DENABLE_ASSEMBLY=OFF -DENABLE_ALTIVEC=OFF )
+                       fi
+                       ;;
+               "main10")
+                       mycmakeargs+=(
+                               -DHIGH_BIT_DEPTH=ON
+                               -DEXPORT_C_API=OFF
+                               -DENABLE_SHARED=OFF
+                               -DENABLE_CLI=OFF
+                       )
+                       if [[ ${ABI} = x86 ]] ; then
+                               mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
+                       fi
+                       if [[ ${ABI} = arm ]] ; then
+                               # 589674
+                               mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
+                       fi
+                       if [[ ${ABI} = ppc64 ]] ; then
+                               # https://bugs.gentoo.org/show_bug.cgi?id=607802#c5
+                               mycmakeargs+=( -DENABLE_ASSEMBLY=OFF -DENABLE_ALTIVEC=OFF )
+                       fi
+                       ;;
+               "main")
+                       if (( "${#MULTIBUILD_VARIANTS[@]}" > 1 )) ; then
+                               local myvariants=( "${MULTIBUILD_VARIANTS[@]}" )
+                               unset myvariants[${#MULTIBUILD_VARIANTS[@]}-1]
+                               local liblist=""
+                               for v in "${myvariants[@]}" ; do
+                                       ln -s "${BUILD_DIR%-*}-${v}/libx265.a" "libx265_${v}.a" ||      die
+                                       liblist+="libx265_${v}.a;"
+                               done
+                               mycmakeargs+=(
+                                       -DEXTRA_LIB="${liblist}"
+                                       -DEXTRA_LINK_FLAGS=-L.
+                                       -DLINKED_10BIT=$(usex 10bit)
+                                       -DLINKED_12BIT=$(usex 12bit)
+                               )
+                       fi
+                       ;;
+               *)
+                       die "Unknown variant: ${MULTIBUILD_VARIANT}";;
+       esac
+       cmake-utils_src_configure
+       popd >/dev/null || die
+}
+
+multilib_src_configure() {
+       append-cflags -fPIC
+       append-cxxflags -fPIC
+       local myabicmakeargs=(
+               $(cmake-utils_use_enable test TESTS)
+               $(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
+               -DENABLE_LIBNUMA=$(usex numa ON OFF)
+               -DCPU_POWER8=$(usex power8 ON OFF)
+               -DENABLE_ALTIVEC=$(usex power8 ON OFF)
+               -DLIB_INSTALL_DIR="$(get_libdir)"
+       )
+
+       if [[ ${ABI} = x86 ]] ; then
+               # Bug #528202
+               if use pic ; then
+                       ewarn "PIC has been requested but x86 asm is not PIC-safe, disabling it."
+                       myabicmakeargs+=( -DENABLE_ASSEMBLY=OFF )
+               fi
+       elif [[ ${ABI} = x32 ]] ; then
+               # bug #510890
+               myabicmakeargs+=( -DENABLE_ASSEMBLY=OFF )
+       elif [[ ${ABI} = arm ]] ; then
+               myabicmakeargs+=( -DENABLE_ASSEMBLY=$(usex pic OFF $(usex cpu_flags_arm_neon ON OFF)) )
+               use cpu_flags_arm_neon && use pic && ewarn "PIC has been requested but arm neon asm is not PIC-safe, disabling it."
+       fi
+
+       local MULTIBUILD_VARIANTS=( $(x265_get_variants) )
+       multibuild_foreach_variant x265_variant_src_configure
+}
+
+multilib_src_compile() {
+       local MULTIBUILD_VARIANTS=( $(x265_get_variants) )
+       multibuild_foreach_variant cmake-utils_src_compile
+}
+
+x265_variant_src_test() {
+       if [ -x "${BUILD_DIR}/test/TestBench" ] ; then
+               "${BUILD_DIR}/test/TestBench" || die
+       else
+               einfo "Unit tests check only assembly."
+               einfo "You do not seem to have any for ABI=${ABI}, x265 variant=${MULTIBUILD_VARIANT}"
+               einfo "Skipping tests."
+       fi
+}
+
+multilib_src_test() {
+       local MULTIBUILD_VARIANTS=( $(x265_get_variants) )
+       multibuild_foreach_variant x265_variant_src_test
+}
+
+multilib_src_install() {
+       # Install only "main" variant since the others are already linked into it.
+       local MULTIBUILD_VARIANTS=( "main" )
+       multibuild_foreach_variant cmake-utils_src_install
+}
+
+multilib_src_install_all() {
+       dodoc -r "${S}/../doc/"*
+}
index b62476a545d013e86483df92a466c4e345cd9118..8fff39d6afbcf9ceb0fcf3c152c681dac14931e7 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -18,7 +18,7 @@ HOMEPAGE="http://x265.org/"
 
 LICENSE="GPL-2"
 # subslot = libx265 soname
-SLOT="0/165"
+SLOT="0/169"
 IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
 
 ASM_DEPEND=">=dev-lang/yasm-1.2.0"