Add user_pw only support, thanks to Georg Sauthoff <g_sauthoff@web.de> in bug 127891...
authorStefan Schweizer <genstef@gentoo.org>
Mon, 5 Jun 2006 22:16:06 +0000 (22:16 +0000)
committerStefan Schweizer <genstef@gentoo.org>
Mon, 5 Jun 2006 22:16:06 +0000 (22:16 +0000)
Package-Manager: portage-2.1_rc4-r2

app-text/pdftk/ChangeLog
app-text/pdftk/files/pdftk-1.12-user-pw.patch [new file with mode: 0644]
app-text/pdftk/pdftk-1.12.ebuild

index 2430fe128dea8a05a1daf08e018a8da473438b88..36837e0b1c2fd6e436748bf232e9f3284806d1a7 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for app-text/pdftk
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pdftk/ChangeLog,v 1.17 2006/03/19 23:11:42 ehmsen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdftk/ChangeLog,v 1.18 2006/06/05 22:16:06 genstef Exp $
+
+  05 Jun 2006; Stefan Schweizer <genstef@gentoo.org>
+  +files/pdftk-1.12-user-pw.patch, -pdftk-0.94.1.ebuild, -pdftk-1.00.ebuild,
+  pdftk-1.12.ebuild:
+  Add user_pw only support, thanks to Georg Sauthoff <g_sauthoff@web.de> in
+  bug 127891 and remove old ebuilds
 
   19 Mar 2006; Martin Ehmsen <ehmsen@gentoo.org>
   +files/pdftk-1.12-gcc-4-compilation.patch, pdftk-1.12.ebuild:
diff --git a/app-text/pdftk/files/pdftk-1.12-user-pw.patch b/app-text/pdftk/files/pdftk-1.12-user-pw.patch
new file mode 100644 (file)
index 0000000..58fee35
--- /dev/null
@@ -0,0 +1,12 @@
+diff -ur -x '*.o' -x '*.a' -x '*.class' -x tags -x '*.h' -x pdftk pdftk-1.12.orig/java_libs/com/lowagie/text/pdf/PdfReader.java pdftk-1.12/java_libs/com/lowagie/text/pdf/PdfReader.java
+--- pdftk-1.12.orig/java_libs/com/lowagie/text/pdf/PdfReader.java      2004-10-23 02:22:44.000000000 +0200
++++ pdftk-1.12/java_libs/com/lowagie/text/pdf/PdfReader.java   2006-03-28 21:15:37.000000000 +0200
+@@ -107,7 +107,7 @@
+     protected char pdfVersion;\r
+     protected PdfEncryption decrypt;\r
+     protected byte password[] = null; //added by ujihara for decryption\r
+-    protected boolean passwordIsOwner= false; // added by ssteward\r
++    protected boolean passwordIsOwner= true;\r
+     protected ArrayList strings = new ArrayList();\r
+     protected boolean sharedStreams = true;\r
+     protected boolean consolidateNamedDestinations = false;\r
index d5ee4d0ca52c1113cec20afed8723efbc8139bc3..a8d2f45e2d4a09b6dcecb0ada3c58a235abbfa3e 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pdftk/pdftk-1.12.ebuild,v 1.8 2006/03/19 23:11:42 ehmsen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdftk/pdftk-1.12.ebuild,v 1.9 2006/06/05 22:16:06 genstef Exp $
 
 inherit eutils
 
@@ -10,7 +10,7 @@ SRC_URI="http://www.pdfhacks.com/pdftk/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="x86 amd64 ppc"
-IUSE=""
+IUSE="nodrm"
 DEPEND="virtual/libc
        >=sys-devel/gcc-3.3"
 S=${WORKDIR}/${P}/${PN}
@@ -31,6 +31,7 @@ src_unpack() {
                < ${T}/Makefile.Generic.orig > ${S}/Makefile.Generic
        # Fix gcc-4 compilation, bug #126735.
        epatch "${FILESDIR}/${P}-gcc-4-compilation.patch" || die
+       use nodrm && epatch "${FILESDIR}"/${P}-user-pw.patch
 }
 
 src_compile() {