media-sound/mp3diags: avoid unused dependency
authorMichael Palimaka <kensington@gentoo.org>
Sun, 1 Mar 2020 03:18:22 +0000 (14:18 +1100)
committerMichael Palimaka <kensington@gentoo.org>
Sun, 1 Mar 2020 03:18:41 +0000 (14:18 +1100)
Closes: https://bugs.gentoo.org/711086
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Michael Palimaka <kensington@gentoo.org>
media-sound/mp3diags/mp3diags-1.5.01.ebuild

index 2d96e59d193124dbd87941a70f514aec2ffbfcd3..58c6ebc2190dd765f0ea391f89561ce0d25e5298 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -31,6 +31,13 @@ RDEPEND="${DEPEND}
 
 S=${WORKDIR}/${MY_P}
 
+src_prepare() {
+       # unused dependency - bug #711086
+       sed -i -e "/^network/d" src/src.pro || die
+
+       default
+}
+
 src_configure() {
        eqmake5 ${PN}.pro
 }