sci-libs/fftw: Workaround missing -mavx2 with avx2 flag
authorMichał Górny <mgorny@gentoo.org>
Wed, 13 May 2020 08:18:09 +0000 (10:18 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 13 May 2020 09:02:57 +0000 (11:02 +0200)
Bug: https://bugs.gentoo.org/698572
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sci-libs/fftw/fftw-3.3.8-r1.ebuild

index 9266b28d174d9e58f608305c5134e8f9c58c9c14..f8105f1e1b41a3dc07328858fd77d580f8bf196a 100644 (file)
@@ -136,6 +136,10 @@ multilib_src_configure() {
 }
 
 src_configure() {
+       # upstream does not append proper -m flags
+       # https://bugs.gentoo.org/698572
+       use cpu_flags_x86_avx2 && append-flags -mavx2
+
        multibuild_foreach_variant multilib-minimal_src_configure
 }