initial import, closes #37227
authorJon Hood <squinky86@gentoo.org>
Tue, 13 Apr 2004 21:47:01 +0000 (21:47 +0000)
committerJon Hood <squinky86@gentoo.org>
Tue, 13 Apr 2004 21:47:01 +0000 (21:47 +0000)
net-p2p/Circle/ChangeLog [new file with mode: 0644]
net-p2p/Circle/Circle-0.39.ebuild [new file with mode: 0644]
net-p2p/Circle/Manifest [new file with mode: 0644]
net-p2p/Circle/files/digest-Circle-0.39 [new file with mode: 0644]
net-p2p/Circle/metadata.xml [new file with mode: 0644]

diff --git a/net-p2p/Circle/ChangeLog b/net-p2p/Circle/ChangeLog
new file mode 100644 (file)
index 0000000..6fb7d80
--- /dev/null
@@ -0,0 +1,9 @@
+# ChangeLog for net-p2p/Circle
+# Copyright 1999-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/Circle/ChangeLog,v 1.1 2004/04/13 21:46:59 squinky86 Exp $
+
+*Circle-0.39 (13 Apr 2004)
+
+  13 Apr 2004; Jon Hood <squinky86@gentoo.org> Circle-0.39.ebuild:
+  Initial ebuild for The Circle.
+  Thanks to Andrew Mahone for this ebuild, closes #37227.
diff --git a/net-p2p/Circle/Circle-0.39.ebuild b/net-p2p/Circle/Circle-0.39.ebuild
new file mode 100644 (file)
index 0000000..7a170c0
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/Circle/Circle-0.39.ebuild,v 1.1 2004/04/13 21:46:59 squinky86 Exp $
+
+inherit python
+
+DESCRIPTION="The Circle messaging and file sharing system"
+HOMEPAGE="http://thecircle.org.au/"
+SRC_URI="http://thecircle.org.au/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="oggvorbis gnome"
+
+DEPEND="virtual/python
+       >=dev-python/pygtk-1.99.14
+       >=gtk+-2
+       oggvorbis? ( dev-python/pyogg
+               dev-python/pyvorbis )
+       gnome? ( dev-python/gnome-python )"
+
+src_compile() {
+       einfo "Nothing to compile."
+}
+
+src_install() {
+       python_version
+       exeinto /usr/bin/
+       doexe circle
+       exeinto /usr/lib/apt/methods/
+       doexe cftp chttp
+       insinto /usr/lib/python${PYVER}/site-packages/circlelib/
+       doins circlelib/*.py*
+       doins circlelib/*.xpm
+       insinto /usr/share/pixmaps/
+       doins circle-icon.png
+       if [ `use gnome` ] ; then
+               insinto /usr/share/gnome/apps/Internet/
+               doins circle.desktop
+       fi
+       dohtml circlelib/*.html
+       dodoc NEWS PKG-INFO README
+}
diff --git a/net-p2p/Circle/Manifest b/net-p2p/Circle/Manifest
new file mode 100644 (file)
index 0000000..741f8c3
--- /dev/null
@@ -0,0 +1,4 @@
+MD5 d8a1b7efcaa62309034f62f1d44256d7 Circle-0.39.ebuild 1074
+MD5 71b175acce6a28b2c10b266c41b9e4a4 ChangeLog 399
+MD5 8abcb326775f027b2e13f23344036e34 metadata.xml 224
+MD5 ba1dc7ed119049827966f37f58172fe3 files/digest-Circle-0.39 63
diff --git a/net-p2p/Circle/files/digest-Circle-0.39 b/net-p2p/Circle/files/digest-Circle-0.39
new file mode 100644 (file)
index 0000000..ff31ea0
--- /dev/null
@@ -0,0 +1 @@
+MD5 e2879eb59e801c5a01f0c33192d440e3 Circle-0.39.tar.gz 372862
diff --git a/net-p2p/Circle/metadata.xml b/net-p2p/Circle/metadata.xml
new file mode 100644 (file)
index 0000000..a6f4b1d
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-p2p</herd>
+<maintainer>
+ <email>squinky86@gentoo.org</email>
+</maintainer>
+</pkgmetadata>