dev-haskell/happy: bump up to 1.19.12
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 14 Dec 2019 21:21:39 +0000 (21:21 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 14 Dec 2019 21:27:12 +0000 (21:27 +0000)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-haskell/happy/Manifest
dev-haskell/happy/happy-1.19.12.ebuild [new file with mode: 0644]

index 88ce2a4dceac98b2ae94575e509d008f235f20f6..1bbc723221e97951906902a7bd9cd1fe8dbd5602 100644 (file)
@@ -1,2 +1,3 @@
+DIST happy-1.19.12.tar.gz 183254 BLAKE2B 17b0d30f4aaf194a0e36c06bd6349665c704b5ab61dce16cae47f0ca6bfef0a0e2d4bbf3456f47cebf0f71f1a0b4a59ff6b581cb4ff76a26d82573eb0e7b056a SHA512 20f36b17adf7330852fd4c05335adbf31e6f19907b4ec247c85a40ee1f8496c6dc432055026696906b149cec7f982b88c9a2eeedf14a11d34b1f6f73272e5208
 DIST happy-1.19.4.tar.gz 160497 BLAKE2B a8a271ea69100d24b9a293d53e2a3262ad34c26cc9b511648cf64df719c49936b5badc6651191ca52b48ed96660335e86e706763e186f5275de1b58ae528631c SHA512 d49893098f9982321fc03dad464bf787873a1a82167165d53f617ba04923c7e5d8f177def7fa045a5669d1c7f886a88087ba8f668ef1900a71498b5800cc4b1a
 DIST happy-1.19.5.tar.gz 159280 BLAKE2B 5cfbddd981d689cfd076367e49f5b9fcfa38eca071a3d1d347a2074eb9c56436f6c7169d524b6628228472ee31ae1ccce3b5e1bcd0ae2b70d31283e3b4e33ee8 SHA512 7b43ef5236bdfba82bbddedb7edc7a8094990a389c0d3f5f848cb6208c3577e7b394cb290e51a2b2eebca25c97978a85ee932e74bbf6a792e261e5b5bff25a2b
diff --git a/dev-haskell/happy/happy-1.19.12.ebuild b/dev-haskell/happy/happy-1.19.12.ebuild
new file mode 100644 (file)
index 0000000..cfeff40
--- /dev/null
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+#hackport: flags: +small_base
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal autotools
+
+DESCRIPTION="Happy is a parser generator for Haskell"
+HOMEPAGE="https://www.haskell.org/happy/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-haskell/mtl-2.2.1:=
+       >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.8
+       doc? ( ~app-text/docbook-xml-dtd-4.2
+                       app-text/docbook-xsl-stylesheets )
+"
+
+src_prepare() {
+       default
+
+       if use doc; then
+               cd doc || die
+               eautoconf
+       fi
+}
+
+src_configure() {
+       # '--with-happy=false' allows detecting circular
+       # depends even when 'happy' is installed in system
+       haskell-cabal_src_configure \
+               --with-happy=false\
+               --flag=small_base
+
+       if use doc; then
+               # does not like out-of-source builds
+               cd doc || die
+               econf
+       fi
+}
+
+src_compile() {
+       haskell-cabal_src_compile
+
+       if use doc; then
+               emake -C doc -j1
+       fi
+}
+
+src_install() {
+       haskell-cabal_src_install
+
+       if use doc; then
+               docinto html
+               dodoc -r doc/happy/.
+               doman doc/happy.1
+       fi
+}