app-editors/gedit: bump to 3.34.1
authorMart Raudsepp <leio@gentoo.org>
Tue, 17 Mar 2020 21:31:41 +0000 (23:31 +0200)
committerMart Raudsepp <leio@gentoo.org>
Tue, 17 Mar 2020 21:31:53 +0000 (23:31 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
app-editors/gedit/Manifest
app-editors/gedit/gedit-3.34.1.ebuild [new file with mode: 0644]

index bd16ddee802e2d605a6f4f93cd57de128e992e2a..16b9e6098bbf0b6a4a4fe1e3ca740405a99177c5 100644 (file)
@@ -1 +1,2 @@
 DIST gedit-3.32.2.tar.xz 14789660 BLAKE2B 574a490e3beda9e8b4f8324409f3a1e3361b1fdd097c4bf8d05475be2a6bb66b230ab6d2047caa62c393458c29b6647c32293ce5c1428d030cb2345c19bf41c3 SHA512 a3ed4dea3d0f60fb2371d2b6bbf5f5db1f67c9a71d0d47836456e022903e86b8b127c88ece6a6d817b0c86ff82612c963a9e8ed60f9841af68474a1d129c886d
+DIST gedit-3.34.1.tar.xz 14797588 BLAKE2B 8dfaac4660575d67e3f8396dfed675a737fc69bc2b34866ee467a3464a338240133cab8d067db7b87fdc129f06a2450b91f4e0f70a73912d4a274cca980196d6 SHA512 22968c678a2f7ecf062f490d5eedc97aaa53b15932db801ea83eb336f01f41e7a6037a85508a40164f38dee406f8db097b7ef6f1481ab44ea82668766d24966d
diff --git a/app-editors/gedit/gedit-3.34.1.ebuild b/app-editors/gedit/gedit-3.34.1.ebuild
new file mode 100644 (file)
index 0000000..6225fb1
--- /dev/null
@@ -0,0 +1,101 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+VALA_MIN_API_VERSION="0.26"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="+introspection +python gtk-doc spell vala"
+REQUIRED_USE="python? ( introspection ${PYTHON_REQUIRED_USE} ) spell? ( python )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# X libs are not needed for OSX (aqua)
+DEPEND="
+       >=dev-libs/glib-2.44:2
+       >=x11-libs/gtk+-3.22.0:3[introspection?]
+       >=x11-libs/gtksourceview-4.0.2:4[introspection?]
+       >=dev-libs/libpeas-1.14.1[gtk]
+       >=dev-libs/libxml2-2.5.0:2
+       >=net-libs/libsoup-2.60:2.4
+       x11-libs/libX11
+
+       spell? ( >=app-text/gspell-0.2.5:0= )
+       introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+       python? (
+               ${PYTHON_DEPS}
+               $(python_gen_cond_dep '
+                       dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+                       >=dev-python/pygobject-3:3[cairo,${PYTHON_MULTI_USEDEP}]
+                       dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+               ')
+       )
+"
+RDEPEND="${DEPEND}
+       x11-themes/adwaita-icon-theme
+       gnome-base/gsettings-desktop-schemas
+       gnome-base/gvfs
+"
+BDEPEND="
+       ${vala_depend}
+       app-text/docbook-xml-dtd:4.1.2
+       dev-util/glib-utils
+       gtk-doc? ( >=dev-util/gtk-doc-1 )
+       dev-util/itstool
+       >=sys-devel/gettext-0.18
+       virtual/pkgconfig
+"
+PATCHES=(
+       "${FILESDIR}"/3.32.2-make-spell-optional.patch
+)
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       use vala && vala_src_prepare
+       xdg_src_prepare
+}
+
+src_configure() {
+       local emesonargs=(
+               $(meson_use introspection)
+               $(meson_use vala vapi)
+               $(meson_use python plugins)
+               $(meson_use gtk-doc documentation)
+               -Denable-gvfs-metadata=yes
+               $(meson_use spell)
+       )
+       meson_src_configure
+}
+
+# Only appdata and desktop file validation in v3.32.2
+src_test() { :; }
+
+src_install() {
+       meson_src_install
+       if use python; then
+               python_optimize
+               python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+       fi
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+}