dev-python/pysyck: Use append-cflags
authorJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 16:41:44 +0000 (18:41 +0200)
committerJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 16:53:44 +0000 (18:53 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/pysyck/pysyck-0.61.2-r1.ebuild

index 9cad1c0be05210de30eca1535e0dade755b83461..eca2258c19e819345b51225ed6d44b54240cc4d4 100644 (file)
@@ -3,9 +3,10 @@
 # $Id$
 
 EAPI=5
+
 PYTHON_COMPAT=( python2_7 )
 
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
 
 MY_P="PySyck-${PV}"
 
@@ -21,9 +22,13 @@ IUSE=""
 DEPEND=">=dev-libs/syck-0.55"
 RDEPEND="${DEPEND}"
 
-CFLAGS="${CFLAGS} -fno-strict-aliasing"
 S="${WORKDIR}/${MY_P}"
 
+python_prepare_all() {
+       distutils-r1_python_prepare_all
+       append-cflags -fno-strict-aliasing
+}
+
 python_test() {
        "${PYTHON}" tests/test_syck.py
        einfo "Some tests may have failed due to pending bugs in dev-libs/syck"