old
authorMike Frysinger <vapier@gentoo.org>
Wed, 2 May 2007 05:39:41 +0000 (05:39 +0000)
committerMike Frysinger <vapier@gentoo.org>
Wed, 2 May 2007 05:39:41 +0000 (05:39 +0000)
sys-libs/readline/files/digest-readline-5.2 [deleted file]
sys-libs/readline/files/digest-readline-5.2_p1 [deleted file]
sys-libs/readline/readline-5.2.ebuild [deleted file]
sys-libs/readline/readline-5.2_p1.ebuild [deleted file]

diff --git a/sys-libs/readline/files/digest-readline-5.2 b/sys-libs/readline/files/digest-readline-5.2
deleted file mode 100644 (file)
index e9ccac1..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 e39331f32ad14009b9ff49cc10c5e751 readline-5.2.tar.gz 2037705
-RMD160 983cbb25192e0a376b80cb2428fe8ee254a041c7 readline-5.2.tar.gz 2037705
-SHA256 12e88d96aee2cd1192500356f0535540db499282ca7f76339fb4228c31249f45 readline-5.2.tar.gz 2037705
diff --git a/sys-libs/readline/files/digest-readline-5.2_p1 b/sys-libs/readline/files/digest-readline-5.2_p1
deleted file mode 100644 (file)
index ab0f584..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 e39331f32ad14009b9ff49cc10c5e751 readline-5.2.tar.gz 2037705
-RMD160 983cbb25192e0a376b80cb2428fe8ee254a041c7 readline-5.2.tar.gz 2037705
-SHA256 12e88d96aee2cd1192500356f0535540db499282ca7f76339fb4228c31249f45 readline-5.2.tar.gz 2037705
-MD5 9d4d41622aa9b230c57f68548ce87d8f readline52-001 874
-RMD160 0cedb82ccc4709e6b39e6cb95143131259b0e7c5 readline52-001 874
-SHA256 eac304c369154059f93049ada328739faaf40338d3cb1fb4b544c93d5ce3f8d5 readline52-001 874
diff --git a/sys-libs/readline/readline-5.2.ebuild b/sys-libs/readline/readline-5.2.ebuild
deleted file mode 100644 (file)
index 6cc2ee9..0000000
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-5.2.ebuild,v 1.6 2007/02/28 22:25:01 genstef Exp $
-
-inherit eutils multilib toolchain-funcs
-
-# Official patches
-# See ftp://ftp.cwru.edu/pub/bash/readline-5.1-patches/
-PLEVEL=0 #${PV##*_p}
-MY_PV=${PV/_p*}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Another cute console display library"
-HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
-SRC_URI="mirror://gnu/readline/${MY_P}.tar.gz
-       $(for ((i=1; i<=PLEVEL; i++)); do
-               printf 'ftp://ftp.cwru.edu/pub/bash/readline-%s-patches/readline%s-%03d\n' \
-                       ${MY_PV} ${MY_PV/\.} ${i}
-               printf 'mirror://gnu/bash/readline-%s-patches/readline%s-%03d\n' \
-                       ${MY_PV} ${MY_PV/\.} ${i}
-       done)"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE=""
-
-# We must be certain that we have a bash that is linked
-# to its internal readline, else we may get problems.
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
-DEPEND="${RDEPEND}
-       >=app-shells/bash-2.05b-r2"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
-       unpack ${MY_P}.tar.gz
-
-       cd "${S}"
-       # Official patches
-       local i
-       for ((i=1; i<=PLEVEL; i++)); do
-               epatch "${DISTDIR}"/${PN}${MY_PV/\.}-$(printf '%03d' ${i})
-       done
-       epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
-       epatch "${FILESDIR}"/${PN}-5.2-rlfe-build.patch #151174
-       epatch "${FILESDIR}"/${PN}-5.1-rlfe-uclibc.patch
-       epatch "${FILESDIR}"/${PN}-5.1-fbsd-pic.patch
-
-       ln -s ../.. examples/rlfe/readline
-
-       # force ncurses linking #71420
-       sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
-}
-
-src_compile() {
-       # the --libdir= is needed because if lib64 is a directory, it will default
-       # to using that... even if CONF_LIBDIR isnt set or we're using a version
-       # of portage without CONF_LIBDIR support.
-       econf --with-curses --libdir=/usr/$(get_libdir) || die
-       emake || die
-
-       if ! tc-is-cross-compiler; then
-               cd examples/rlfe
-               econf || die
-               emake || die "make rlfe failed"
-       fi
-}
-
-src_install() {
-       make DESTDIR="${D}" install || die
-       dodir /$(get_libdir)
-
-       if ! use userland_Darwin ; then
-               mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
-               chmod a+rx "${D}"/$(get_libdir)/*.so*
-
-               # Bug #4411
-               gen_usr_ldscript libreadline.so
-               gen_usr_ldscript libhistory.so
-       fi
-
-       if ! tc-is-cross-compiler; then
-               dobin examples/rlfe/rlfe || die
-       fi
-
-       dodoc CHANGELOG CHANGES README USAGE NEWS
-       docinto ps
-       dodoc doc/*.ps
-       dohtml -r doc
-}
-
-pkg_preinst() {
-       preserve_old_lib /$(get_libdir)/lib{history,readline}.so.4 #29865
-}
-
-pkg_postinst() {
-       preserve_old_lib_notify /$(get_libdir)/lib{history,readline}.so.4
-}
diff --git a/sys-libs/readline/readline-5.2_p1.ebuild b/sys-libs/readline/readline-5.2_p1.ebuild
deleted file mode 100644 (file)
index 65fdc71..0000000
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-5.2_p1.ebuild,v 1.5 2007/02/28 22:25:01 genstef Exp $
-
-inherit eutils multilib toolchain-funcs flag-o-matic
-
-# Official patches
-# See ftp://ftp.cwru.edu/pub/bash/readline-5.1-patches/
-PLEVEL=${PV##*_p}
-MY_PV=${PV/_p*}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Another cute console display library"
-HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
-SRC_URI="mirror://gnu/readline/${MY_P}.tar.gz
-       $(for ((i=1; i<=PLEVEL; i++)); do
-               printf 'ftp://ftp.cwru.edu/pub/bash/readline-%s-patches/readline%s-%03d\n' \
-                       ${MY_PV} ${MY_PV/\.} ${i}
-               printf 'mirror://gnu/bash/readline-%s-patches/readline%s-%03d\n' \
-                       ${MY_PV} ${MY_PV/\.} ${i}
-       done)"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE=""
-
-# We must be certain that we have a bash that is linked
-# to its internal readline, else we may get problems.
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
-DEPEND="${RDEPEND}
-       >=app-shells/bash-2.05b-r2"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
-       unpack ${MY_P}.tar.gz
-
-       cd "${S}"
-       # Official patches
-       local i
-       for ((i=1; i<=PLEVEL; i++)); do
-               epatch "${DISTDIR}"/${PN}${MY_PV/\.}-$(printf '%03d' ${i})
-       done
-       epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
-       epatch "${FILESDIR}"/${PN}-5.2-rlfe-build.patch #151174
-       epatch "${FILESDIR}"/${PN}-5.1-rlfe-uclibc.patch
-       epatch "${FILESDIR}"/${PN}-5.1-fbsd-pic.patch
-
-       ln -s ../.. examples/rlfe/readline
-
-       # force ncurses linking #71420
-       sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
-}
-
-src_compile() {
-       append-flags -D_GNU_SOURCE
-
-       # the --libdir= is needed because if lib64 is a directory, it will default
-       # to using that... even if CONF_LIBDIR isnt set or we're using a version
-       # of portage without CONF_LIBDIR support.
-       econf --with-curses --libdir=/usr/$(get_libdir) || die
-       emake || die
-
-       if ! tc-is-cross-compiler; then
-               cd examples/rlfe
-               econf || die
-               emake || die "make rlfe failed"
-       fi
-}
-
-src_install() {
-       emake DESTDIR="${D}" install || die
-       dodir /$(get_libdir)
-
-       if ! use userland_Darwin ; then
-               mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
-               chmod a+rx "${D}"/$(get_libdir)/*.so*
-
-               # Bug #4411
-               gen_usr_ldscript libreadline.so
-               gen_usr_ldscript libhistory.so
-       fi
-
-       if ! tc-is-cross-compiler; then
-               dobin examples/rlfe/rlfe || die
-       fi
-
-       dodoc CHANGELOG CHANGES README USAGE NEWS
-       docinto ps
-       dodoc doc/*.ps
-       dohtml -r doc
-}
-
-pkg_preinst() {
-       preserve_old_lib /$(get_libdir)/lib{history,readline}.so.4 #29865
-}
-
-pkg_postinst() {
-       preserve_old_lib_notify /$(get_libdir)/lib{history,readline}.so.4
-}