media-libs/vulkan-loader: Fix build
authorNick Sarnie <sarnex@gentoo.org>
Tue, 22 Oct 2019 03:09:51 +0000 (23:09 -0400)
committerNick Sarnie <sarnex@gentoo.org>
Tue, 22 Oct 2019 03:09:51 +0000 (23:09 -0400)
Closes: https://bugs.gentoo.org/698230
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
media-libs/vulkan-loader/vulkan-loader-1.1.125.ebuild
media-libs/vulkan-loader/vulkan-loader-9999.ebuild

index 7b03900c566681758cd3af7b456057dc3e71e722..644dce6b34395926b7427d23be99b71c30e8b8fc 100644 (file)
@@ -41,7 +41,7 @@ DEPEND="${PYTHON_DEPS}
 
 multilib_src_configure() {
        # Integrated clang assembler doesn't work with x86 - Bug #698164
-       if [[ tc-is-clang && ${ABI} == x86 ]]; then
+       if tc-is-clang && [[ ${ABI} == x86 ]]; then
                append-cflags -fno-integrated-as
        fi
 
index 7b03900c566681758cd3af7b456057dc3e71e722..644dce6b34395926b7427d23be99b71c30e8b8fc 100644 (file)
@@ -41,7 +41,7 @@ DEPEND="${PYTHON_DEPS}
 
 multilib_src_configure() {
        # Integrated clang assembler doesn't work with x86 - Bug #698164
-       if [[ tc-is-clang && ${ABI} == x86 ]]; then
+       if tc-is-clang && [[ ${ABI} == x86 ]]; then
                append-cflags -fno-integrated-as
        fi