dev-python/jupyter_client: Version bump to 5.2.3
authorMarius Brehler <marbre@linux.sungazer.de>
Mon, 28 May 2018 08:07:31 +0000 (10:07 +0200)
committerDavid Seifert <soap@gentoo.org>
Tue, 29 May 2018 08:00:21 +0000 (10:00 +0200)
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Closes: https://github.com/gentoo/gentoo/pull/8633

dev-python/jupyter_client/Manifest
dev-python/jupyter_client/jupyter_client-5.2.3.ebuild [new file with mode: 0644]

index c06c1bce5c12aa51d93f2193fe53da90bb453063..8520968e679d5814de7163002a66332e82bf4366 100644 (file)
@@ -1 +1,2 @@
 DIST jupyter_client-5.1.0.tar.gz 265233 BLAKE2B 1f4533e1c6578e61b1a7591889805d5e324a3cd368cb3998131f2047056c87984ae26d83c9de0277aa6f19b61db4c4d9b39083b795e0891ef7d5394949b5fa44 SHA512 eca7adab1f8aae05743c341a257d4ca4338b0838cc3441939dda48229cdfa13b267bdc338b951bc4e6e139d03d26b40a1294140218f84ab800d211f7e0d8bfc7
+DIST jupyter_client-5.2.3.tar.gz 271787 BLAKE2B 36761e53050874c141c38f545f8f6fb53c144c30f686b3706594d124a65e410c205379b7ecbeed12f1520f0f568c7db3c802223f6fdb8f76407074beacc21918 SHA512 89b980ecc281bc1512e1fc4ba35862cc6e541f825ee07a1382d300c8088f24611225ab415d6a7c1e4209c47a74c113ec95f863e8fb0b33c6db9eb9c3521fc0ae
diff --git a/dev-python/jupyter_client/jupyter_client-5.2.3.ebuild b/dev-python/jupyter_client/jupyter_client-5.2.3.ebuild
new file mode 100644 (file)
index 0000000..df80a23
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+       dev-python/python-dateutil[${PYTHON_USEDEP}]
+       dev-python/traitlets[${PYTHON_USEDEP}]
+       dev-python/jupyter_core[${PYTHON_USEDEP}]
+       >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+       "
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pytest-cov[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*')
+               dev-python/ipykernel[${PYTHON_USEDEP}]
+       )
+       "
+
+python_test() {
+       pytest --cov jupyter_client jupyter_client || die
+}