dev-python/h5py: Clean old up
authorMichał Górny <mgorny@gentoo.org>
Thu, 4 Jan 2018 20:02:14 +0000 (21:02 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 4 Jan 2018 20:34:52 +0000 (21:34 +0100)
dev-python/h5py/Manifest
dev-python/h5py/h5py-2.3.1.ebuild [deleted file]

index 605d92e21daf736736548e83b85d6431890c9180..a52869c7e6bca417496837a2e9e023de222e1a5c 100644 (file)
@@ -1,2 +1 @@
-DIST h5py-2.3.1.tar.gz 1072766 BLAKE2B 40c5739a72e381cd5b7fcfcb1c7aaa771f2ba0c8145f65e6310d6181fcb5b8bdb5d3f14828f4ab164b5d1f16194e79000b1af55ffcda56890fe2631b11cc544e SHA512 f0da1d2ac855c02fb828444d719a1b23a580adb049335f3e732ace67558a125ac8cd3b3a68ac6bf9d10aa3ab19e4672b814eb28cc8c66910750c62efb655d744
 DIST h5py-2.7.0.tar.gz 256471 BLAKE2B c232eb86d00b9d1bb76903ea04bfd384bae7c9eb7b301de6aa450a46918f69132ab8d8d5a3f9b54095feee436a8aa9e9045c27ca1a120d665d6031c14218f0f5 SHA512 7c1e5d8b47c176521f5f62cfc4f782c09a0e003c5cbc07a673ccc3dfbe97df930b33801ef7311360892e3fad1d7d72561a8578aed9cb630d44e1a73543bb5da4
diff --git a/dev-python/h5py/h5py-2.3.1.ebuild b/dev-python/h5py/h5py-2.3.1.ebuild
deleted file mode 100644 (file)
index 29efd5b..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Simple Python interface to HDF5 files"
-HOMEPAGE="http://www.h5py.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="test examples mpi"
-
-RDEPEND="
-       sci-libs/hdf5:=[mpi=,hl(+)]
-       dev-python/numpy[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-python/cython[${PYTHON_USEDEP}]
-       mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )"
-
-pkg_setup() {
-       use mpi && export CC=mpicc
-}
-
-python_prepare_all() {
-       append-cflags -fno-strict-aliasing
-       distutils-r1_python_prepare_all
-}
-
-python_compile() {
-       distutils-r1_python_compile --mpi=$(usex mpi yes no)
-}
-
-python_test() {
-       esetup.py test --mpi=$(usex mpi yes no)
-}
-
-python_install() {
-       distutils-r1_python_install --mpi=$(usex mpi yes no)
-}
-
-python_install_all() {
-       DOCS=( README.rst ANN.rst )
-       use examples && local EXAMPLES=( examples/. )
-
-       distutils-r1_python_install_all
-}