www-client/firefox: disable Normandy service by default
authorThomas Deutschmann <whissi@gentoo.org>
Fri, 27 Mar 2020 22:38:51 +0000 (23:38 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 30 Mar 2020 11:45:08 +0000 (13:45 +0200)
Bug: https://bugs.gentoo.org/713782
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
www-client/firefox/files/gentoo-default-prefs.js-3
www-client/firefox/firefox-68.6.0-r2.ebuild [moved from www-client/firefox/firefox-68.6.0-r1.ebuild with 96% similarity]
www-client/firefox/firefox-74.0-r2.ebuild

index d2a4dc82c94a55f2c1e3c97136424740bc8a87a7..073ea77e51174438a106ca5f22ba9789676aedc8 100644 (file)
@@ -16,3 +16,4 @@ pref("intl.locale.requested",              "");
 pref("extensions.autoDisableScopes",       0);
 pref("layout.css.dpi",                     0);
 pref("network.trr.mode",                   5);
+pref("app.normandy.enabled",               false);
similarity index 96%
rename from www-client/firefox/firefox-68.6.0-r1.ebuild
rename to www-client/firefox/firefox-68.6.0-r2.ebuild
index c59249a49534483835e1fef4aff8ce40435a7ef3..d610d428cc59c7fbfe25a40e4b43bd1d1138b4bb 100644 (file)
@@ -775,6 +775,39 @@ pkg_postinst() {
                elog "media-sound/apulse."
                elog
        fi
+
+       local show_normandy_information
+
+       if [[ -z "${REPLACING_VERSIONS}" ]] ; then
+               # New install
+               show_normandy_information=yes
+       else
+               local replacing_version
+               for replacing_version in ${REPLACING_VERSIONS} ; do
+                       if ver_test "${replacing_version}" -lt 68.6.0-r2 ; then
+                               # Tell user only once about our Normandy default
+                               show_normandy_information=yes
+                               break
+                       fi
+               done
+       fi
+
+       # bug 713782
+       if [[ -n "${show_normandy_information}" ]] ; then
+               elog
+               elog "Upstream operates a service named Normandy which allows Mozilla to"
+               elog "push changes for default settings or even install new add-ons remotely."
+               elog "While this can be useful to address problems like 'Armagadd-on 2.0' or"
+               elog "revert previous decisions to disable TLS 1.0/1.1, privacy and security"
+               elog "concerns prevail, which is why we have switched off the use of this"
+               elog "service by default."
+               elog
+               elog "To re-enable this service set"
+               elog
+               elog "    app.normandy.enabled=true"
+               elog
+               elog "in about:config."
+       fi
 }
 
 pkg_postrm() {
index 11e72681132cd17720f71f4dccf62fcf6518f91b..739761cdb2f26eee099a1e4f2ed9118c00dc241c 100644 (file)
@@ -793,18 +793,23 @@ pkg_postinst() {
                elog
        fi
 
-       local show_doh_information
+       local show_doh_information show_normandy_information
 
        if [[ -z "${REPLACING_VERSIONS}" ]] ; then
                # New install; Tell user that DoH is disabled by default
                show_doh_information=yes
+               show_normandy_information=yes
        else
                local replacing_version
                for replacing_version in ${REPLACING_VERSIONS} ; do
                        if ver_test "${replacing_version}" -lt 70 ; then
                                # Tell user only once about our DoH default
                                show_doh_information=yes
-                               break
+                       fi
+
+                       if ver_test "${replacing_version}" -lt 74.0-r2 ; then
+                               # Tell user only once about our Normandy default
+                               show_normandy_information=yes
                        fi
                done
        fi
@@ -818,6 +823,23 @@ pkg_postinst() {
                elog "(\"Off by choice\") by default."
                elog "You can enable DNS-over-HTTPS in ${PN^}'s preferences."
        fi
+
+       # bug 713782
+       if [[ -n "${show_normandy_information}" ]] ; then
+               elog
+               elog "Upstream operates a service named Normandy which allows Mozilla to"
+               elog "push changes for default settings or even install new add-ons remotely."
+               elog "While this can be useful to address problems like 'Armagadd-on 2.0' or"
+               elog "revert previous decisions to disable TLS 1.0/1.1, privacy and security"
+               elog "concerns prevail, which is why we have switched off the use of this"
+               elog "service by default."
+               elog
+               elog "To re-enable this service set"
+               elog
+               elog "    app.normandy.enabled=true"
+               elog
+               elog "in about:config."
+       fi
 }
 
 pkg_postrm() {