app-editors/focuswriter: version bump 1.6.16
authorMichael Palimaka <kensington@gentoo.org>
Thu, 8 Nov 2018 13:52:28 +0000 (00:52 +1100)
committerMichael Palimaka <kensington@gentoo.org>
Thu, 8 Nov 2018 13:56:02 +0000 (00:56 +1100)
Package-Manager: Portage-2.3.51, Repoman-2.3.12
Signed-off-by: Michael Palimaka <kensington@gentoo.org>
app-editors/focuswriter/Manifest
app-editors/focuswriter/focuswriter-1.6.16.ebuild [new file with mode: 0644]

index ca74672f6204be087ddd45177fc26ed93f914c09..99a0e3344d3f8638f15f159d2b643a3df94557b2 100644 (file)
@@ -1 +1,2 @@
 DIST focuswriter-1.6.13-src.tar.bz2 10342493 BLAKE2B 11086bf7d35cc392169e7b6de57ea0b65c919bef0d845946893641f705ba0522bdef7244f4035104188d3fdf0dd3b6ad30ed6bf347b5ce8c422d7eea6c6dc714 SHA512 d78719d5a1e25afec8035759d0ebff17728e856fe346d4d8fefd38a15eea3476eb1c6e2aca30955ac148fadd4701a9c4a83399baffe93239a18b93854fab9858
+DIST focuswriter-1.6.16-src.tar.bz2 10301446 BLAKE2B ade186dffe87b4256c85b876b7121fa144f264d358479ef46c34579f96ea15fdd55da2c036d35119fe1eee3498d64ad1ac72737fa2e9f45aa13535dec599b168 SHA512 aefffcde693f4e7627f11cc37d763936f85dd749293daf910934da99e858471399618243c20ff88cd4993cffcb4b3270cb38bd97834519484c463b1b1b7e5f0d
diff --git a/app-editors/focuswriter/focuswriter-1.6.16.ebuild b/app-editors/focuswriter/focuswriter-1.6.16.ebuild
new file mode 100644 (file)
index 0000000..ea35e3d
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils qmake-utils xdg-utils
+
+DESCRIPTION="A fullscreen and distraction-free word processor"
+HOMEPAGE="https://gottcode.org/focuswriter/"
+SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="LGPL-3 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       app-text/hunspell:=
+       >=dev-qt/qtcore-5.11:5
+       >=dev-qt/qtgui-5.11:5
+       >=dev-qt/qtmultimedia-5.11:5
+       >=dev-qt/qtprintsupport-5.11:5
+       dev-qt/qtsingleapplication[qt5(+),X]
+       >=dev-qt/qtwidgets-5.11:5
+       sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+       dev-qt/linguist-tools:5
+       dev-qt/qtconcurrent:5
+       virtual/pkgconfig
+"
+
+DOCS=( ChangeLog CREDITS README )
+
+PATCHES=( "${FILESDIR}/${PN}-1.6.0-unbundle-qtsingleapplication.patch" )
+
+src_configure() {
+       eqmake5 PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+       emake INSTALL_ROOT="${D}" install
+       einstalldocs
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+       xdg_desktop_database_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+       xdg_desktop_database_update
+}