media-libs/quvi: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Thu, 12 Dec 2019 17:31:19 +0000 (18:31 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 12 Dec 2019 17:31:19 +0000 (18:31 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
media-libs/quvi/quvi-0.9.5.ebuild

index bed5ac447b8bc791531cbb9b3712630ffc714cc8..fbeb2f5d6dfcc25cfac2d02066b1a0e79e8ca737 100644 (file)
@@ -1,10 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-AUTOTOOLS_AUTORECONF=1
+EAPI=7
 
-inherit autotools-utils
+inherit autotools
 
 DESCRIPTION="A command line tool for parsing video download links"
 HOMEPAGE="http://quvi.sourceforge.net/"
@@ -15,24 +14,29 @@ SLOT="0"
 KEYWORDS="amd64 ~hppa ppc64 x86"
 IUSE="json nls xml"
 
-RDEPEND=">=dev-libs/glib-2.24:2
-       >=net-misc/curl-7.21.0
-       >=media-libs/libquvi-0.9.2:=
-       json? ( >=dev-libs/json-glib-0.12 )
+RDEPEND="
+       dev-libs/glib:2
+       net-misc/curl:=
+       media-libs/libquvi:=
+       json? ( dev-libs/json-glib:= )
        nls? ( virtual/libintl )
-       xml? ( >=dev-libs/libxml2-2.7.8:2 )"
-DEPEND="${RDEPEND}
+       xml? ( dev-libs/libxml2:2= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
        app-arch/xz-utils
        virtual/pkgconfig
        nls? ( sys-devel/gettext )"
 
 PATCHES=( "${FILESDIR}"/${PN}-0.9.1-automagic.patch )
 
+src_prepare() {
+       default
+       eautoreconf
+}
+
 src_configure() {
-       local myeconfargs=(
-               --with-manual
-               $(use_enable json)
+       econf \
+               --with-manual \
+               $(use_enable json) \
                $(use_enable xml)
-       )
-       autotools-utils_src_configure
 }