app-emulation/vagrant: bump to 2.0.1
authorTomáš Mózes <hydrapolic@gmail.com>
Sat, 4 Nov 2017 22:05:10 +0000 (22:05 +0000)
committerAmy Liffey <amynka@gentoo.org>
Mon, 6 Nov 2017 07:35:38 +0000 (08:35 +0100)
app-emulation/vagrant/Manifest
app-emulation/vagrant/files/vagrant.in-r1 [new file with mode: 0644]
app-emulation/vagrant/vagrant-2.0.1.ebuild [new file with mode: 0644]

index 34dfc7b9412794ec1537fc9692a76ab3767eb81e..c626066ee4a6008de094d5b0023514cd83b84d92 100644 (file)
@@ -1,3 +1,4 @@
 DIST vagrant-1.9.7.tar.gz 1119024 SHA256 194de72442a2d08f6e04fbed8698a99d190a0e7203d35b49e80d4ddfcb71fb1b SHA512 062921070ace7ce93145981b5b768dc9dc447559fc12c52c8da323d1e3523fbff2a8e7afca0e2f751e232aae822c969b5d166b3b0f01a0744ca20c4e4e33567f WHIRLPOOL ef0331781cf6a71dca9eb485943c459a5360f55b1db45b4f23b413b848eeac1700afe3ea51b6dd2e0da1a7c1ba6ad456bd9fcb7a7b3532145e95a38fc997dd99
 DIST vagrant-1.9.8.tar.gz 1127560 SHA256 59c1d50437d2f50eeae219bc03c90d397fe8d8c974cce7c51b017b8ceeaefb54 SHA512 d22cc0a6800aa5ef84085c750f5ec8729f7b3adefd9a5df1a1fcaf60d1219e781869ede4f57ce4fdeb269224603dfc3a8024545a0250ebd9e144745ce9aa670b WHIRLPOOL d9c199322798e792a895aef03f729b4db8bb5eb3eaab960092d5aa2831032106a9f55ac3957b43378cceea2d27cf53f8ecf6ff38ff54ff2f8c4451c0238029ee
 DIST vagrant-2.0.0.tar.gz 1142850 SHA256 c25d3a5f18abdf349047f4d80bb74e6cb526959536e4bef5aa771de9d39cb260 SHA512 ee9059dfd205253d6f978fd225d85eef5a281532a1992bc9382eb713c95a0280d4b6518460106227237ae4e93cf5e2eaf670bd378627c3e9696b0fe9a2427ac1 WHIRLPOOL 8337800f6c5cc88081dc6f8630de60ecba8c851687d14143f34dc41b62cbd67b1e463f7351ecc0e1c764742004fdba389bc33c0bb2a5c043d1fbf6dde352171c
+DIST vagrant-2.0.1.tar.gz 1153702 SHA256 212b91c45f60a825fcfc656424021e2550833778a6d4ebe13458676201a04eba SHA512 4458fd819cfcbf732dcbb5e334986afc986e3da4f4ea883260ed9b7ff8dd90ef9b0078c067a1bf7fbf51562f235ab447234762a38aa0ac539974f6205f6d9cfd WHIRLPOOL 7c66469b1fc0078524b62dd62dd66ae45f6527602df650dbe755bbbe12d4d4b04d6e0964606705a2c9ef4113d5b6abdc5619d223f4913cb9425d4032921ec0d9
diff --git a/app-emulation/vagrant/files/vagrant.in-r1 b/app-emulation/vagrant/files/vagrant.in-r1
new file mode 100644 (file)
index 0000000..7c0405e
--- /dev/null
@@ -0,0 +1,50 @@
+#!/usr/bin/env bash
+#
+# This is a wrapper to properly execute Vagrant within the embedded
+# Vagrant installation directory. This sets up proper environmental variables
+# so that everything loads and compiles to proper directories.
+
+for r in ruby24 ruby23 ruby22; do
+  VAGRANT_DIR="$( "${r}" -e 'print Gem::default_path[-1] + "/gems/vagrant-@VAGRANT_VERSION@"' )"
+  # Export the VAGRANT_EXECUTABLE so that pre-rubygems can optimize a bit
+  export VAGRANT_EXECUTABLE="${VAGRANT_DIR}/bin/vagrant"
+  "${r}" "${VAGRANT_EXECUTABLE}" "version" &> /dev/null
+  if [ $? -eq 0 ]; then
+    ruby="${r}"
+    break
+  fi
+done
+
+# Export GEM_HOME based on VAGRANT_HOME
+#
+# This needs to be set because Bundler includes gem paths
+# from RubyGems' Gem.paths.
+if [ -z ${VAGRANT_HOME} ]; then
+  VAGRANT_HOME="~/.vagrant.d"
+fi
+export GEM_HOME="${VAGRANT_HOME}/gems"
+
+# SSL certs
+export SSL_CERT_FILE="/etc/ssl/certs/ca-certificates.crt"
+
+# Export an environmental variable to say we're in a Vagrant
+# installer created environment.
+export VAGRANT_INSTALLER_ENV=1
+
+# This is currently used only in Vagrant::Plugin::Manager.system_plugins_file
+# to locate plugins configuration file.
+export VAGRANT_INSTALLER_EMBEDDED_DIR="/var/lib/vagrant"
+export VAGRANT_INSTALLER_VERSION=2
+
+# Export the OS as an environmental variable that Vagrant can access
+# so that it can behave better.
+export VAGRANT_DETECTED_OS="$(uname -s 2>/dev/null)"
+
+# Allow to install plugins even with deps in different slots (Bug #628648)
+export VAGRANT_DISABLE_STRICT_DEPENDENCY_ENFORCEMENT=1
+
+# Make it work with rvm (Bugs #474476 #628648)
+unset GEM_HOME GEM_PATH
+
+# Call the actual Vagrant bin with our arguments
+exec "${ruby}" "${VAGRANT_EXECUTABLE}" "$@"
diff --git a/app-emulation/vagrant/vagrant-2.0.1.ebuild b/app-emulation/vagrant/vagrant-2.0.1.ebuild
new file mode 100644 (file)
index 0000000..a496014
--- /dev/null
@@ -0,0 +1,78 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+USE_RUBY="ruby22 ruby23"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
+RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit bash-completion-r1 ruby-fakegem
+
+DESCRIPTION="A tool for building and distributing development environments"
+HOMEPAGE="http://vagrantup.com/"
+SRC_URI="https://github.com/mitchellh/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+virtualbox"
+
+RDEPEND="${RDEPEND}
+       app-arch/libarchive
+       net-misc/curl
+       virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
+
+ruby_add_rdepend "
+       >=dev-ruby/childprocess-0.6.0
+       >=dev-ruby/erubis-2.7.0
+       <dev-ruby/i18n-0.8.0:*
+       >=dev-ruby/listen-3.1.5
+       >=dev-ruby/hashicorp-checkpoint-0.1.1
+       >=dev-ruby/log4r-1.1.9 <dev-ruby/log4r-1.1.11
+       >=dev-ruby/net-ssh-4.1.0:*
+       >=dev-ruby/net-sftp-2.1
+       >=dev-ruby/net-scp-1.2.0
+       || ( dev-ruby/rest-client:2 >=dev-ruby/rest-client-1.6.0:0 )
+       >=dev-ruby/nokogiri-1.7.1
+       <dev-ruby/mime-types-3:*
+"
+
+ruby_add_bdepend "
+       >=dev-ruby/rake-12.0.0
+"
+
+all_ruby_prepare() {
+       # remove bundler support
+       sed -i '/[Bb]undler/d' Rakefile || die
+       rm Gemfile || die
+
+       # loosen dependencies
+       sed -e '/hashicorp-checkpoint\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
+               -e '/ruby_dep/s/<=/>=/' \
+               -i ${PN}.gemspec || die
+
+       # remove windows-specific gems
+       sed -e '/wdm\|winrm/d' \
+               -i ${PN}.gemspec || die
+
+       # remove bsd-specific gems
+       sed -e '/rb-kqueue/d' \
+               -i ${PN}.gemspec || die
+
+       sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}.in-r1" > "${PN}" || die
+}
+
+all_ruby_install() {
+       newbashcomp contrib/bash/completion.sh ${PN}
+       all_fakegem_install
+
+       # provide executable similar to upstream:
+       # https://github.com/mitchellh/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
+       dobin "${PN}"
+
+       # directory for plugins.json
+       dodir /var/lib/vagrant
+}