gnome-base/gnome-desktop: bump to 3.32.2
authorMart Raudsepp <leio@gentoo.org>
Wed, 18 Sep 2019 20:33:39 +0000 (23:33 +0300)
committerMart Raudsepp <leio@gentoo.org>
Wed, 18 Sep 2019 20:40:21 +0000 (23:40 +0300)
Package-Manager: Portage-2.3.69, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
gnome-base/gnome-desktop/Manifest
gnome-base/gnome-desktop/files/3.32.2-fix-tests-without-locale.patch [new file with mode: 0644]
gnome-base/gnome-desktop/files/3.32.2-optional-introspection.patch [new file with mode: 0644]
gnome-base/gnome-desktop/gnome-desktop-3.32.2.ebuild [new file with mode: 0644]

index d348865c7799110bdedc77b4fd508bafc02a8ece..967e76c847fc9d46f2405d2bbefedada5232d24c 100644 (file)
@@ -1,3 +1,5 @@
 DIST gnome-desktop-2.32.1.tar.bz2 1633847 BLAKE2B 9c69504b0f904fe04bdaa2e2fd3c6fbdd0cdd67033bae6e21377cce2deb68f05ed85bc735547c036923978ebdb8952c262676a01a33f8d7acffb0b964f97366a SHA512 b8084d08366dab661a7ee369cd03ba62beddbdfa9a36b988b7d13d207b33d6916f7fa8691717fba7b6a70d8276779e35360b1dc385e6ec876f30ea7b8b373c28
 DIST gnome-desktop-3.30.2.3-patchset.tar.xz 3568 BLAKE2B 20d13d7e396d7cddcfb6f761815df7ce6a2d910be5e9588eac519ade536848cfc09d1aca0e4478f97177b8ee26f8049da21542d502b427973991b47c7097bbe3 SHA512 8b9eab01e79e3d67dec51ed07a086f04df1890e638a0c1696742cf5e3b6a42dccbd514fc3cfd3610791c4905346847af83e813845ad14e0b57b790fedd0ae8e0
 DIST gnome-desktop-3.30.2.3.tar.xz 1164500 BLAKE2B e78256bc3319ea9794b4666c82eb466a0c884fd43c3c776fd08aaf789905893ff93acec35a1fb6903c0049b3a169afe5b43a71ac1e93e8c63c013682c3316fa8 SHA512 36303de8fa70e65c40aeb7862156fa404b965d1724171ec5bb0a00cb1049efbfba79cdcff76278f53e4e27199f1ef9dcb574b0f465b0f4e04bb46c50d516ad0f
+DIST gnome-desktop-3.32.2-patchset.tar.xz 7404 BLAKE2B ecc821d3338957d0a123d625607d727019d9500915a76ff6d10d3000e1fc1e51fc7c0382374752582aef641d005cd73d39148466b08c53dc1ce9872e73a21215 SHA512 0471f0a6d9213ea60e867bd4f381575f6a94fa0fde57cc1a360e2d4ef98c11f2f973d3d95347db8f24aacb2249ba84ffc4e35e05bb595d9d3b6debe561ed88da
+DIST gnome-desktop-3.32.2.tar.xz 709128 BLAKE2B f0335d1ad583f0b000c47826cd4b6eb24624862b22b00e9d42759ed1cfcf3dba6f091dd85504c9c8da8b9789bf78cf53d284942ba6e2d3c630db028b4a0a69c6 SHA512 7dfa5c3e4b77637cc40e6244eb8ce8cb314cf92d865b64e36c5dffa8a699e91c81bd359f0a89a725c064eafec965d2b9d119aa05f1de103cd836a4bff9119a99
diff --git a/gnome-base/gnome-desktop/files/3.32.2-fix-tests-without-locale.patch b/gnome-base/gnome-desktop/files/3.32.2-fix-tests-without-locale.patch
new file mode 100644 (file)
index 0000000..bd4df1c
--- /dev/null
@@ -0,0 +1,82 @@
+From 9ae847ec875efe443d51d584fa6c61966c7c3c7c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Javier=20Jard=C3=B3n?= <jjardon@gnome.org>
+Date: Wed, 4 Sep 2019 22:09:26 +0100
+Subject: [PATCH] tests/wall*: Do not fail if some of the locales is missing
+
+---
+ tests/wall-clock.c        | 14 ++++++++++++++
+ tests/wallclock-reftest.c |  5 +++++
+ 2 files changed, 19 insertions(+)
+
+diff --git a/tests/wall-clock.c b/tests/wall-clock.c
+index 4937ee66..23929ebd 100644
+--- a/tests/wall-clock.c
++++ b/tests/wall-clock.c
+@@ -48,6 +48,7 @@ test_utf8_character (const char *utf8_char,
+       /* In the C locale, make sure the time string is formatted with regular
+          * colons */
+       locale = newlocale (LC_ALL_MASK, "C", (locale_t) 0);
++      g_assert_true (locale != (locale_t)0);
+       save_locale = uselocale (locale);
+       clock = gnome_wall_clock_new ();
+       str = gnome_wall_clock_string_for_datetime (clock,
+@@ -60,6 +61,10 @@ test_utf8_character (const char *utf8_char,
+       /* In a UTF8 locale, we want ratio characters and no colons. */
+       locale = newlocale (LC_ALL_MASK, "en_US.utf8", locale);
++      if (locale == (locale_t)0) {
++              g_test_skip("en_US.utf8 locale not found, skipping");
++              return;
++      }
+       uselocale (locale);
+       clock = gnome_wall_clock_new ();
+       str = gnome_wall_clock_string_for_datetime (clock,
+@@ -73,6 +78,10 @@ test_utf8_character (const char *utf8_char,
+       /* ... and same thing with an RTL locale: should be formatted with
+          * ratio characters */
+       locale = newlocale (LC_ALL_MASK, "he_IL.utf8", locale);
++      if (locale == (locale_t)0) {
++              g_test_skip("he_IL.utf8 locale not found, skipping");
++              return;
++      }
+       uselocale (locale);
+       clock = gnome_wall_clock_new ();
+       str = gnome_wall_clock_string_for_datetime (clock,
+@@ -112,6 +121,10 @@ test_clock_format_setting (void)
+       const char *str;
+       locale = newlocale (LC_ALL_MASK, "en_US.utf8", (locale_t) 0);
++      if (locale == (locale_t)0) {
++              g_test_skip("en_US.utf8 locale not found, skipping");
++              return;
++      }
+       save_locale = uselocale (locale);
+       settings = g_settings_new ("org.gnome.desktop.interface");
+@@ -192,6 +205,7 @@ test_weekday_setting (void)
+       /* Save current locale */
+       locale = newlocale (LC_ALL_MASK, "C", (locale_t) 0);
++      g_assert_true (locale != (locale_t)0);
+       save_locale = uselocale (locale);
+       settings = g_settings_new ("org.gnome.desktop.interface");
+diff --git a/tests/wallclock-reftest.c b/tests/wallclock-reftest.c
+index 8ac630f2..0a7e812d 100644
+--- a/tests/wallclock-reftest.c
++++ b/tests/wallclock-reftest.c
+@@ -446,6 +446,11 @@ test_ui_file (GFile         *file,
+   locale = get_locale_for_file (ui_file);
+   g_assert (locale);
+   loc = newlocale (LC_ALL_MASK, locale, (locale_t) 0);
++  if (loc == (locale_t)0)
++    {
++      g_test_skip("locale not found, skipping");
++      return;
++    }
+   previous_locale = uselocale (loc);
+   g_assert_true (previous_locale != (locale_t) 0);
+-- 
+2.20.1
+
diff --git a/gnome-base/gnome-desktop/files/3.32.2-optional-introspection.patch b/gnome-base/gnome-desktop/files/3.32.2-optional-introspection.patch
new file mode 100644 (file)
index 0000000..7471a3e
--- /dev/null
@@ -0,0 +1,48 @@
+From 1b8fb6b0fd155975f64b5e2ef03bece96a5e3340 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Wed, 18 Sep 2019 22:28:21 +0300
+Subject: [PATCH] build: Add optionality for introspection
+
+---
+ libgnome-desktop/meson.build | 2 ++
+ meson_options.txt            | 4 ++++
+ 2 files changed, 6 insertions(+)
+
+diff --git a/libgnome-desktop/meson.build b/libgnome-desktop/meson.build
+index c365b448..a7355f31 100644
+--- a/libgnome-desktop/meson.build
++++ b/libgnome-desktop/meson.build
+@@ -96,6 +96,7 @@ libgnome_desktop_dep = declare_dependency(
+   link_with: libgnome_desktop
+ )
++if get_option('introspection')
+ gnome.generate_gir(libgnome_desktop,
+   sources: introspection_sources + libgnome_desktop_headers,
+   export_packages: 'gnome-desktop-3.0',
+@@ -107,6 +108,7 @@ gnome.generate_gir(libgnome_desktop,
+   symbol_prefix: 'gnome',
+   install: true
+ )
++endif
+ desktop_pc = pkg.generate(
+   libraries: libgnome_desktop,
+diff --git a/meson_options.txt b/meson_options.txt
+index e3402a11..7efe43ce 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -17,6 +17,10 @@ option('debug_tools',
+   type: 'boolean', value: true, description: 'Build debug tools'
+ )
++option('introspection',
++  type: 'boolean', value: true, description: 'Whether to build introspection files'
++)
++
+ option('udev',
+   type: 'feature', description: 'Udev support'
+ )
+-- 
+2.20.1
+
diff --git a/gnome-base/gnome-desktop/gnome-desktop-3.32.2.ebuild b/gnome-base/gnome-desktop/gnome-desktop-3.32.2.ebuild
new file mode 100644 (file)
index 0000000..1bcfa93
--- /dev/null
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson virtualx xdg
+
+DESCRIPTION="Library with common API for various GNOME modules"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-desktop/"
+SRC_URI+=" https://dev.gentoo.org/~leio/distfiles/${P}-patchset.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2+ FDL-1.1+"
+SLOT="3/17" # subslot = libgnome-desktop-3 soname version
+IUSE="debug gtk-doc +introspection seccomp udev"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+
+# cairo[X] needed for gnome-bg
+COMMON_DEPEND="
+       >=x11-libs/gdk-pixbuf-2.36.5:2[introspection?]
+       >=x11-libs/gtk+-3.3.6:3[X,introspection?]
+       >=dev-libs/glib-2.53.0:2
+       >=gnome-base/gsettings-desktop-schemas-3.27.0[introspection?]
+       x11-misc/xkeyboard-config
+       app-text/iso-codes
+       x11-libs/libX11
+       udev? (
+               sys-apps/hwids
+               virtual/libudev:= )
+       seccomp? ( sys-libs/libseccomp )
+
+       x11-libs/cairo:=[X]
+       introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+BDEPEND="${COMMON_DEPEND}
+       media-libs/fontconfig
+"
+RDEPEND="${COMMON_DEPEND}
+       seccomp? ( sys-apps/bubblewrap )
+"
+DEPEND="
+       app-text/docbook-xml-dtd:4.1.2
+       dev-util/gdbus-codegen
+       gtk-doc? ( >=dev-util/gtk-doc-1.14 )
+       dev-util/itstool
+       >=sys-devel/gettext-0.19.8
+       x11-base/xorg-proto
+       virtual/pkgconfig
+"
+# Includes X11/Xatom.h in libgnome-desktop/gnome-bg.c which comes from xorg-proto
+
+PATCHES=(
+       # Translation updates and nvidia builtin display detection fix from origin/gnome-3-32
+       "${WORKDIR}"/patches/
+       "${FILESDIR}"/${PV}-optional-introspection.patch # add introspection meson option
+       "${FILESDIR}"/${PV}-fix-tests-without-locale.patch # fix tests when he_IL.utf8 or other tested locales not present
+)
+
+src_prepare() {
+       # Don't build manual test programs that will never get run
+       sed -i -e "/'test-.*'/d" libgnome-desktop/meson.build || die
+       xdg_src_prepare
+}
+
+src_configure() {
+       local emesonargs=(
+               -Dgnome_distributor=Gentoo
+               -Ddate_in_gnome_version=true
+               -Ddesktop_docs=true
+               $(meson_use debug debug_tools)
+               $(meson_use introspection)
+               $(meson_feature udev)
+               $(meson_use gtk-doc gtk_doc)
+               -Dinstalled_tests=false
+       )
+       meson_src_configure
+}
+
+src_test() {
+       virtx meson_src_test
+}