dev-libs/libclc: Revert "fix llvm-config path."
authorMichał Górny <mgorny@gentoo.org>
Sat, 12 Aug 2017 20:51:23 +0000 (22:51 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 12 Aug 2017 20:51:23 +0000 (22:51 +0200)
Revert the non-maintainer commit that reintroduced the cross-slot clang
mismatch bug.

dev-libs/libclc/libclc-0.2.0_pre20170118.ebuild

index 003757a0998e2b8c98da4e90737fd5f3df0f62fb..c0ac06980cb486c781af3c3979116e8de834214a 100644 (file)
@@ -39,9 +39,13 @@ DEPEND="${RDEPEND}
        ${PYTHON_DEPS}"
 
 src_configure() {
+       # we need to find llvm with matching clang version, so look for
+       # clang first, and then use llvm-config from the same location
+       local clang_path=$(type -P clang) || die
+
        ./configure.py \
                --with-cxx-compiler="$(tc-getCXX)" \
-               --with-llvm-config="$(tc-getPROG LLVM_CONFIG llvm-config)" \
+               --with-llvm-config="${clang_path%/*}/llvm-config" \
                --prefix="${EPREFIX}/usr" || die
 }