dev-haskell/quickcheck: rename IUSE from underscores to dashes
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 2 Oct 2019 21:37:21 +0000 (22:37 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Wed, 2 Oct 2019 21:41:22 +0000 (22:41 +0100)
Reported-by: Michał Górny
Closes: https://bugs.gentoo.org/695038
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-haskell/quickcheck/metadata.xml
dev-haskell/quickcheck/quickcheck-2.6.ebuild
dev-haskell/quickcheck/quickcheck-2.7.6.ebuild
dev-haskell/quickcheck/quickcheck-2.8.1.ebuild
dev-haskell/quickcheck/quickcheck-2.8.2.ebuild
dev-haskell/quickcheck/quickcheck-2.9.2.ebuild

index d5aff4a020bbe0b19b41569d05104df69b611dc8..120011b0413e341a1a45d29125827702cd7836fd 100644 (file)
@@ -6,7 +6,7 @@
                <name>Gentoo Haskell</name>
        </maintainer>
        <use>
-               <flag name="template_haskell">Enable additional test modules requiring Template Haskell support.</flag>
+               <flag name="template-haskell">Enable additional test modules requiring Template Haskell support.</flag>
        </use>
        <longdescription>
                QuickCheck is a library for random testing of program properties.
index e362bb8b3e28a6ca53096f33a41696eb5a4ea840..c83c7d97c40077714928b6368c0b08a8801e5f70 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -18,7 +18,7 @@ SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
 LICENSE="BSD"
 SLOT="2/${PV}"
 KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux"
-IUSE="+template_haskell"
+IUSE="+template-haskell"
 
 RDEPEND="dev-haskell/extensible-exceptions:=[profile?]
                dev-haskell/random:=[profile?]
@@ -30,5 +30,5 @@ S="${WORKDIR}/${MY_P}"
 
 src_configure() {
        haskell-cabal_src_configure \
-               $(cabal_flag template_haskell templatehaskell)
+               $(cabal_flag template-haskell templatehaskell)
 }
index 0d9bfb69fc6181d09fea883a4447341954ed7fe9..a15e1fbef4cb172e743940e18580f7c295d52fde 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
 
 # ebuild generated by hackport 0.4.9999
-#hackport: flags: +base4,-base3,templatehaskell:template_haskell
+#hackport: flags: +base4,-base3,templatehaskell:template-haskell
 
 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
 inherit haskell-cabal
@@ -19,7 +19,7 @@ SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
 LICENSE="BSD"
 SLOT="2/${PV}"
 KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
-IUSE="+template_haskell"
+IUSE="+template-haskell"
 
 RDEPEND="dev-haskell/random:=[profile?]
        >=dev-haskell/tf-random-0.4:=[profile?]
@@ -37,5 +37,5 @@ src_configure() {
        haskell-cabal_src_configure \
                --flag=-base3 \
                --flag=base4 \
-               $(cabal_flag template_haskell templatehaskell)
+               $(cabal_flag template-haskell templatehaskell)
 }
index b6f22e236bdc4c239aa12de2453e92c92c31e125..8a9db261e6aa20adbadbcf1a9f60cc5e08cfe0cf 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
 
 # ebuild generated by hackport 0.4.4.9999
-#hackport: flags: +base4,-base3,templatehaskell:template_haskell
+#hackport: flags: +base4,-base3,templatehaskell:template-haskell
 
 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
 inherit haskell-cabal
@@ -19,7 +19,7 @@ SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
 LICENSE="BSD"
 SLOT="2/${PV}"
 KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux"
-IUSE="+template_haskell"
+IUSE="+template-haskell"
 
 RDEPEND="dev-haskell/random:=[profile?]
        >=dev-haskell/tf-random-0.4:=[profile?]
@@ -37,5 +37,5 @@ src_configure() {
        haskell-cabal_src_configure \
                --flag=-base3 \
                --flag=base4 \
-               $(cabal_flag template_haskell templatehaskell)
+               $(cabal_flag template-haskell templatehaskell)
 }
index a1fe598d4e75442dab1cb1376406f444be5c9ef8..6c00030de7f82034e4d54f5d5f22a8a775bf5f3d 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=5
 
 # ebuild generated by hackport 0.4.6.9999
-#hackport: flags: +base4,-base3,templatehaskell:template_haskell
+#hackport: flags: +base4,-base3,templatehaskell:template-haskell
 
 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
 inherit haskell-cabal
@@ -19,7 +19,7 @@ SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
 LICENSE="BSD"
 SLOT="2/${PV}"
 KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux"
-IUSE="+template_haskell"
+IUSE="+template-haskell"
 
 RESTRICT=test # to avoid test circular depends
 
@@ -39,5 +39,5 @@ src_configure() {
        haskell-cabal_src_configure \
                --flag=-base3 \
                --flag=base4 \
-               $(cabal_flag template_haskell templatehaskell)
+               $(cabal_flag template-haskell templatehaskell)
 }
index 87803b71b443a09c7903a0a2ae79a761204b71a2..db4778bb98b32e4ab8b0f2678ea9a0c055c2444c 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
 # ebuild generated by hackport 0.5.9999
-#hackport: flags: +base4,-base3,templatehaskell:template_haskell
+#hackport: flags: +base4,-base3,templatehaskell:template-haskell
 
 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
 inherit haskell-cabal
@@ -19,7 +19,7 @@ SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
 LICENSE="BSD"
 SLOT="2/${PV}"
 KEYWORDS="amd64 x86 ~x86-fbsd ~amd64-linux"
-IUSE="+template_haskell"
+IUSE="+template-haskell"
 
 RESTRICT=test # to avoid test circular depends
 
@@ -31,7 +31,7 @@ RDEPEND=">=dev-haskell/nats-1:=[profile?]
 "
 DEPEND="${RDEPEND}
        >=dev-haskell/cabal-1.18.1.3
-       test? ( template_haskell? ( >=dev-haskell/test-framework-0.4 <dev-haskell/test-framework-0.9 ) )
+       test? ( template-haskell? ( >=dev-haskell/test-framework-0.4 <dev-haskell/test-framework-0.9 ) )
 "
 
 S="${WORKDIR}/${MY_P}"
@@ -40,5 +40,5 @@ src_configure() {
        haskell-cabal_src_configure \
                --flag=-base3 \
                --flag=base4 \
-               $(cabal_flag template_haskell templatehaskell)
+               $(cabal_flag template-haskell templatehaskell)
 }