Cleanup.
authorLuca Longinotti <chtekk@gentoo.org>
Sun, 14 Jan 2007 21:36:04 +0000 (21:36 +0000)
committerLuca Longinotti <chtekk@gentoo.org>
Sun, 14 Jan 2007 21:36:04 +0000 (21:36 +0000)
Package-Manager: portage-2.1.2_rc4-r8

net-www/mod_watch/ChangeLog
net-www/mod_watch/mod_watch-3.18-r2.ebuild
net-www/mod_watch/mod_watch-4.03-r2.ebuild
net-www/mod_xslt/ChangeLog
net-www/mod_xslt/metadata.xml
net-www/mod_xslt/mod_xslt-2.0.4.ebuild

index f36f90f9ab1cab560b9caa298a18d1410711e422..bd64ee0ccb29d51dc17f5af5f24c856439ccd9fb 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for net-www/mod_watch
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_watch/ChangeLog,v 1.15 2006/06/06 09:56:00 hollow Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_watch/ChangeLog,v 1.16 2007/01/14 21:31:33 chtekk Exp $
+
+  14 Jan 2007; Luca Longinotti <chtekk@gentoo.org>
+  -mod_watch-3.18-r1.ebuild, mod_watch-3.18-r2.ebuild,
+  -mod_watch-4.03-r1.ebuild, mod_watch-4.03-r2.ebuild:
+  Cleanup.
 
 *mod_watch-4.03-r2 (06 Jun 2006)
 *mod_watch-3.18-r2 (06 Jun 2006)
index 8e985ef0c636f5ecbff0c5246c2b5e0389fdb3b6..3dd5cbcca202fcfe4c3f51d77ca552e9fdbc62af 100644 (file)
@@ -1,23 +1,25 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_watch/mod_watch-3.18-r2.ebuild,v 1.1 2006/06/06 09:56:00 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_watch/mod_watch-3.18-r2.ebuild,v 1.2 2007/01/14 21:31:33 chtekk Exp $
 
 inherit apache-module
 
-DESCRIPTION="Bandwidth graphing for Apache with MRTG"
-HOMEPAGE="http://www.snert.com/Software/mod_watch/"
-KEYWORDS="~x86"
-
-MY_V=${PV/./}
-SRC_URI="http://www.snert.com/Software/download/${PN}${MY_V}.tgz"
+KEYWORDS="x86"
 
-IUSE=""
+DESCRIPTION="Bandwidth graphing module for Apache1 with MRTG."
+HOMEPAGE="http://www.snert.com/Software/mod_watch/"
+SRC_URI="http://www.snert.com/Software/download/${PN}${PV/./}.tgz"
 LICENSE="as-is"
 SLOT="1"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+APXS1_ARGS="-c ${PN}.c Memory.c Mutex.c Shared.c SharedHash.c NetworkTable.c"
 
 APACHE1_MOD_CONF="77_mod_watch"
 APACHE1_MOD_DEFINE="WATCH"
-APXS1_ARGS="-c mod_watch.c Memory.c Mutex.c Shared.c SharedHash.c NetworkTable.c"
 
 DOCFILES="CHANGES.TXT LICENSE.TXT"
 
@@ -25,7 +27,7 @@ need_apache1
 
 src_compile() {
        sed -i -e "s:/usr/local/sbin:/usr/sbin:" \
-               apache2mrtg.pl || die "Path fixing failed."
+               apache2mrtg.pl || die "Path fixing failed"
 
        apache1_src_compile
 }
@@ -33,4 +35,5 @@ src_compile() {
 src_install() {
        apache1_src_install
        dosbin apache2mrtg.pl mod_watch.pl
+       keepdir "${ROOT}"/var/lib/${PN}
 }
index c0577eac8ab740441fc02ccd2d255a42e7d65a45..13bb0c7584a8a2257d8d3f9373b2ca8e2243f44d 100644 (file)
@@ -1,21 +1,21 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_watch/mod_watch-4.03-r2.ebuild,v 1.1 2006/06/06 09:56:00 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_watch/mod_watch-4.03-r2.ebuild,v 1.2 2007/01/14 21:31:33 chtekk Exp $
 
-inherit eutils apache-module
+inherit apache-module
 
-MY_V=${PV/./}
+KEYWORDS="ppc x86"
 
-DESCRIPTION="Bandwidth graphing for Apache with MRTG"
+DESCRIPTION="Bandwidth graphing module for Apache2 with MRTG."
 HOMEPAGE="http://www.snert.com/Software/mod_watch/"
-SRC_URI="http://www.snert.com/Software/download/${PN}${MY_V}.tgz"
-
-KEYWORDS="~ppc ~x86"
-DEPEND=""
+SRC_URI="http://www.snert.com/Software/download/${PN}${PV/./}.tgz"
 LICENSE="as-is"
 SLOT="0"
 IUSE=""
 
+DEPEND=""
+RDEPEND=""
+
 S="${WORKDIR}/${PN}-4.3"
 
 APACHE2_MOD_CONF="77_mod_watch"
@@ -29,16 +29,16 @@ src_compile() {
        sed -i \
                -e "s:APXS=\\(.*\\):APXS=${APXS2} # \\1:" \
                -e "s:APACHECTL=\\(.*\\):APACHECTL=${APACHECTL2} # \\1:" \
-               Makefile.dso || die "Path fixing failed."
+               Makefile.dso || die "Path fixing failed"
 
        sed -i -e "s:/usr/local/sbin:/usr/sbin:" \
-               apache2mrtg.pl || die "Path fixing failed."
+               apache2mrtg.pl || die "Path fixing failed"
 
-       emake -f Makefile.dso build || die "Make failed."
+       emake -f Makefile.dso build || die "emake failed"
 }
 
 src_install() {
        apache2_src_install
        dosbin apache2mrtg.pl mod_watch.pl Contrib/mod_watch_list.pl
-       keepdir /var/lib/mod_watch
+       keepdir "${ROOT}"/var/lib/${PN}
 }
index ad637d05e0c89b65e29d7b02586a849a6cf41c5e..f051bdf62f038bebe3c83cdee7d5d15eb7bde691 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for net-www/mod_xslt
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_xslt/ChangeLog,v 1.21 2006/06/05 18:41:13 chtekk Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_xslt/ChangeLog,v 1.22 2007/01/14 21:36:04 chtekk Exp $
+
+  14 Jan 2007; Luca Longinotti <chtekk@gentoo.org> metadata.xml,
+  mod_xslt-2.0.4.ebuild:
+  Cleanup.
 
   05 Jun 2006; Luca Longinotti <chtekk@gentoo.org>
   -files/mod-xslt-1.0.5a-debug.patch, -files/mod_xslt-1.0.5a-register.patch,
index 8f398d815b6c19f3767c5e0a321561dc9964d3c7..a1f5ceff235260de2b6b6d9c980c7f6c49e55198 100644 (file)
@@ -3,6 +3,6 @@
 <pkgmetadata>
        <herd>apache</herd>
        <maintainer>
-               <email>apache-bugs@gentoo.org</email>
+               <email>apache-bugs@gentoo.org</email>
        </maintainer>
 </pkgmetadata>
index e521f181526a0ece41df7e78e6ca9b3131e2f48c..59a2a78171a4f48520e51d921805eb50287cd4e5 100644 (file)
@@ -1,20 +1,20 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_xslt/mod_xslt-2.0.4.ebuild,v 1.11 2006/06/05 18:41:13 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_xslt/mod_xslt-2.0.4.ebuild,v 1.12 2007/01/14 21:36:04 chtekk Exp $
 
-inherit eutils apache-module
+inherit apache-module
 
-DESCRIPTION="An xslt filtering DSO module for Apache2."
+KEYWORDS="amd64 ppc x86"
+
+DESCRIPTION="An XSLT filtering module for Apache2."
 HOMEPAGE="http://www.mod-xslt.com/"
 SRC_URI="mirror://sourceforge/mod-xslt/${PN}.${PV}.tgz"
-
 LICENSE="GPL-2"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
 SLOT="0"
+IUSE=""
 
 RDEPEND="dev-libs/libxslt
-                dev-libs/libxml2"
+               dev-libs/libxml2"
 
 DEPEND="${RDEPEND}
                dev-lang/perl"
@@ -23,7 +23,7 @@ S="${WORKDIR}/${PN}.${PV}"
 
 APXS2_ARGS="-I/usr/include/libxml2 -lxslt -lxml2 -lpthread -lz -lm -c ${PN}.c"
 
-APACHE2_MOD_CONF="25_mod_xslt"
+APACHE2_MOD_CONF="25_${PN}"
 APACHE2_MOD_DEFINE="XSLT"
 
 DOCFILES="ChangeLog.txt README.txt"