media-plugins/vdr-freecell: fixed time_ms was not declared in this scope
authorJoerg Bornkessel <hd_brummy@gentoo.org>
Thu, 12 Dec 2019 20:41:54 +0000 (21:41 +0100)
committerJoerg Bornkessel <hd_brummy@gentoo.org>
Thu, 12 Dec 2019 20:41:54 +0000 (21:41 +0100)
Bug: https://bugs.gentoo.org/702612
Closes: https://bugs.gentoo.org/702612
Package-Manager: Portage-2.3.81, Repoman-2.3.18
Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
media-plugins/vdr-freecell/files/vdr-freecell-0.0.2_compilefix.patch [new file with mode: 0644]
media-plugins/vdr-freecell/vdr-freecell-0.0.2-r4.ebuild

diff --git a/media-plugins/vdr-freecell/files/vdr-freecell-0.0.2_compilefix.patch b/media-plugins/vdr-freecell/files/vdr-freecell-0.0.2_compilefix.patch
new file mode 100644 (file)
index 0000000..fb97d18
--- /dev/null
@@ -0,0 +1,17 @@
+https://bugs.gentoo.org/702612
+compile fix for: time_ms was not declared in this scope
+
+Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org> (12 Dec 2019) 
+
+diff -Naur freecell-0.0.2.orig/cards.c freecell-0.0.2/cards.c
+--- freecell-0.0.2.orig/cards.c        2019-12-12 21:25:43.000000000 +0100
++++ freecell-0.0.2/cards.c     2019-12-12 21:27:38.000000000 +0100
+@@ -52,7 +52,7 @@
+       mX = X;
+       mY = Y;
+       mStacked = Stacked;
+-      mSeed = time_ms();
++      mSeed = cTimeMs::Now();
+ }
+ cCardStack::~cCardStack() {
index 3d10e2af527e525820ad5d4b48214087ec4595ac..a8442bf991d2e0c6a1b6210cea0cf8a0f7be1f41 100644 (file)
@@ -24,6 +24,7 @@ src_prepare() {
        eapply -p2 "${FILESDIR}/gcc-3.4.patch"
        eapply "${FILESDIR}/${P}-gentoo.diff"
        eapply "${FILESDIR}/${P}_vdr-1.5.4-compile.diff"
+       eapply "${FILESDIR}/${P}_compilefix.patch"
 }
 
 src_install() {