dev-python/dnspython: Forcibly disable Internet-based tests
authorMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 17:31:32 +0000 (19:31 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 18:09:48 +0000 (20:09 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/dnspython/dnspython-1.16.0-r1.ebuild

index c1a63e4d0e3df1ae94ed4fe68c5d8287a1f93dac..f6749205a50520e7b246984f8bbd6420b3c97437 100644 (file)
@@ -23,6 +23,12 @@ RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
        !dev-python/dnspython:py2
        !dev-python/dnspython:py3"
 
+src_prepare() {
+       sed -i -e '/network_avail/s:True:False:' \
+               tests/test_resolver.py || die
+       distutils-r1_src_prepare
+}
+
 python_test() {
        pushd tests >/dev/null || die
        "${EPYTHON}" utest.py || die "tests failed under ${EPYTHON}"