app-i18n/ibus-typing-booster: use xdg eclass
authorAkinori Hattori <hattya@gentoo.org>
Sat, 16 May 2020 13:36:12 +0000 (22:36 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Sat, 16 May 2020 13:36:12 +0000 (22:36 +0900)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.0.ebuild
app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.2.ebuild

index bc08d3c8bedfe2b82954d6c0162600393af4d859..a1697767ab8d783f3c0b1b89c5fe5d4290813ed9 100644 (file)
@@ -5,7 +5,7 @@ EAPI="7"
 PYTHON_COMPAT=( python3_{6,7,8} )
 PYTHON_REQ_USE="sqlite(+)"
 
-inherit python-single-r1
+inherit python-single-r1 xdg
 
 DESCRIPTION="Completion input method for IBus"
 HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
@@ -31,3 +31,15 @@ RDEPEND="${DEPEND}
        >=dev-db/m17n-db-1.7"
 BDEPEND="sys-devel/gettext
        virtual/pkgconfig"
+
+pkg_preinst() {
+       xdg_pkg_preinst
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+}
index bc08d3c8bedfe2b82954d6c0162600393af4d859..a1697767ab8d783f3c0b1b89c5fe5d4290813ed9 100644 (file)
@@ -5,7 +5,7 @@ EAPI="7"
 PYTHON_COMPAT=( python3_{6,7,8} )
 PYTHON_REQ_USE="sqlite(+)"
 
-inherit python-single-r1
+inherit python-single-r1 xdg
 
 DESCRIPTION="Completion input method for IBus"
 HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
@@ -31,3 +31,15 @@ RDEPEND="${DEPEND}
        >=dev-db/m17n-db-1.7"
 BDEPEND="sys-devel/gettext
        virtual/pkgconfig"
+
+pkg_preinst() {
+       xdg_pkg_preinst
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+}