app-text/evince: bump to 3.34.2
authorMart Raudsepp <leio@gentoo.org>
Sun, 1 Mar 2020 15:57:01 +0000 (17:57 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sun, 1 Mar 2020 16:17:42 +0000 (18:17 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
app-text/evince/Manifest
app-text/evince/evince-3.34.2.ebuild [new file with mode: 0644]

index 6e92e978cc33e57b0f96aa1daf49f24afebbc8a2..fe164045a84c857af4a680a5200b455bdf476bff 100644 (file)
@@ -1 +1,2 @@
 DIST evince-3.32.1.tar.xz 2567868 BLAKE2B 8fec9ce1981fb2c5fc60c4b653f462f07f0341ebe64a5615f1e1a123533f8053c6f76a02d05da9245b4263c24df1cdd2e28aa89486b8c802a2aa14cf04faf13b SHA512 29028fedde9aff85e53a5059f63df007e1bac7d662a91fe01e1bb8c48349d5674afe3ce37f9c495e4b208fd476b22f4ecaf749c6d7c3362a03b05703400ece05
+DIST evince-3.34.2.tar.xz 2565752 BLAKE2B 76497c34ce2eb460a3f2c3e790a7c44b9eeddd566854061d49fba2ba7cefa3b523d7bfe973d08b7ec1e8d967e4cbd63c73a668a346bd158a67752897f25827ee SHA512 51bfa4671e17a98c536790185ece6f4f77b956062901f840cd298cdc3e42eb7e8cabe9bfa84387f185cdf7462a322ef54bbc463b988a677af68561e55acd9f12
diff --git a/app-text/evince/evince-3.34.2.ebuild b/app-text/evince/evince-3.34.2.ebuild
new file mode 100644 (file)
index 0000000..d840491
--- /dev/null
@@ -0,0 +1,107 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+GNOME2_EAUTORECONF="yes"
+
+inherit gnome2 systemd
+
+DESCRIPTION="Simple document viewer for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evince"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+# subslot = evd3.(suffix of libevdocument3)-evv3.(suffix of libevview3)
+SLOT="0/evd3.4-evv3.3"
+IUSE="djvu dvi gstreamer gnome gnome-keyring +introspection nautilus nsplugin postscript spell t1lib tiff xps"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+
+# atk used in libview
+# bundles unarr
+COMMON_DEPEND="
+       dev-libs/atk
+       >=dev-libs/glib-2.38.0:2
+       >=dev-libs/libxml2-2.5:2
+       sys-libs/zlib:=
+       >=x11-libs/gdk-pixbuf-2.36.5:2
+       >=x11-libs/gtk+-3.22.0:3[introspection?]
+       gnome-base/gsettings-desktop-schemas
+       >=x11-libs/cairo-1.10:=
+       >=app-text/poppler-0.76.0[cairo]
+       >=app-arch/libarchive-3.2.0
+       djvu? ( >=app-text/djvu-3.5.22:= )
+       dvi? (
+               virtual/tex-base
+               dev-libs/kpathsea:=
+               t1lib? ( >=media-libs/t1lib-5:= ) )
+       gstreamer? (
+               media-libs/gstreamer:1.0
+               media-libs/gst-plugins-base:1.0
+               media-libs/gst-plugins-good:1.0 )
+       gnome? ( gnome-base/gnome-desktop:3= )
+       gnome-keyring? ( >=app-crypt/libsecret-0.5 )
+       introspection? ( >=dev-libs/gobject-introspection-1:= )
+       nautilus? ( >=gnome-base/nautilus-2.91.4 )
+       postscript? ( >=app-text/libspectre-0.2:= )
+       spell? ( >=app-text/gspell-1.6.0:= )
+       tiff? ( >=media-libs/tiff-3.6:0= )
+       xps? ( >=app-text/libgxps-0.2.1:= )
+"
+RDEPEND="${COMMON_DEPEND}
+       gnome-base/gvfs
+       gnome-base/librsvg
+       || (
+               >=x11-themes/adwaita-icon-theme-2.17.1
+               >=x11-themes/hicolor-icon-theme-0.10 )
+"
+DEPEND="${COMMON_DEPEND}
+       app-text/docbook-xml-dtd:4.3
+       dev-libs/appstream-glib
+       dev-util/gdbus-codegen
+       dev-util/glib-utils
+       >=dev-util/gtk-doc-am-1.13
+       dev-util/itstool
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+       app-text/yelp-tools
+"
+# eautoreconf needs:
+#  app-text/yelp-tools
+
+PATCHES=(
+       "${FILESDIR}"/3.30.2-internal-synctex.patch # don't automagically link to synctex from texlive-core - always use internal copy of this small parser for now; requires eautoreconf
+)
+
+src_prepare() {
+       gnome2_src_prepare
+
+       # Do not depend on adwaita-icon-theme, bug #326855, #391859
+       # https://gitlab.freedesktop.org/xdg/default-icon-theme/issues/7
+       sed -e 's/adwaita-icon-theme >= $ADWAITA_ICON_THEME_REQUIRED//g' \
+               -i configure || die "sed failed"
+}
+
+src_configure() {
+       gnome2_src_configure \
+               --disable-static \
+               --enable-pdf \
+               --enable-comics \
+               --enable-thumbnailer \
+               --with-platform=gnome \
+               --enable-dbus \
+               $(use_enable djvu) \
+               $(use_enable dvi) \
+               $(use_enable gstreamer multimedia) \
+               $(use_enable gnome libgnome-desktop) \
+               $(use_with gnome-keyring keyring) \
+               $(use_enable introspection) \
+               $(use_enable nautilus) \
+               $(use_enable nsplugin browser-plugin) \
+               $(use_enable postscript ps) \
+               $(use_with spell gspell) \
+               $(use_enable t1lib) \
+               $(use_enable tiff) \
+               $(use_enable xps) \
+               BROWSER_PLUGIN_DIR="${EPREFIX}"/usr/$(get_libdir)/nsbrowser/plugins \
+               --with-systemduserunitdir="$(systemd_get_userunitdir)"
+}