dev-python/yapsy: drop old revision
authorSergey Popov <pinkbyte@gentoo.org>
Wed, 23 Oct 2019 11:33:52 +0000 (14:33 +0300)
committerSergey Popov <pinkbyte@gentoo.org>
Wed, 23 Oct 2019 11:34:55 +0000 (14:34 +0300)
Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

dev-python/yapsy/yapsy-1.11.223-r1.ebuild [deleted file]

diff --git a/dev-python/yapsy/yapsy-1.11.223-r1.ebuild b/dev-python/yapsy/yapsy-1.11.223-r1.ebuild
deleted file mode 100644 (file)
index 13dba5e..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-MY_P="Yapsy-${PV}"
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="A fat-free DIY Python plugin management toolkit"
-HOMEPAGE="http://yapsy.sourceforge.net/"
-SRC_URI="mirror://sourceforge/yapsy/${MY_P}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
-       # Disable erroneous test
-       sed -e 's:test_default_plugins_place_is_parent_dir:_&:' \
-               -i test/test_PluginFileLocator.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C doc html
-}
-
-python_test() {
-       esetup.py test
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/_build/html/. )
-       distutils-r1_python_install_all
-}