sys-devel/gcc-config: bump up to 2.3, bug #724454
authorSergei Trofimovich <slyfox@gentoo.org>
Fri, 22 May 2020 20:46:33 +0000 (21:46 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Fri, 22 May 2020 20:53:02 +0000 (21:53 +0100)
Main change is USE=native-symlinks to avoid symlinks
without ${CTARGET} qualifier.

Bug: https://bugs.gentoo.org/724454
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-devel/gcc-config/Manifest
sys-devel/gcc-config/gcc-config-2.3.ebuild [new file with mode: 0644]
sys-devel/gcc-config/gcc-config-9999.ebuild

index 88215b38d78d2c0b422440b9ad1383078fc8b9bc..11e25de7a6685169c1b521a9cb6010d68dbdca91 100644 (file)
@@ -1 +1,2 @@
 DIST gcc-config-2.2.1.tar.xz 16292 BLAKE2B bed319b73bb1dd1c693715654dab7d16c12929353eb28c6e93ffeda0d4539d8204e84287c58de65ed5198011130a6e0ef71421cf41e7cf59cc48781a94ec9af2 SHA512 783caf2f4236d7c84e7c76c2d001d069a1b8544644d7e6e12b79f4dc55f34c953a24a8cd8d01b2aa69fa7f8e02ec3380e0e33a83eda6b3cb00e8c43d2f69f673
+DIST gcc-config-2.3.tar.xz 16736 BLAKE2B e8c22348d73ec756ebe377c3f9b0aca8e22b7ef53507bfa4dc0fbd459bca38ba6bea9dbb290b4d83239c21c913d12f8262a263e1c078a3997558a0b14fdf355d SHA512 4ce1e46bee6b2182c664746d939a7d843d5b4323c860ea3ee24e36aa629e65f3aa99da99905d4a7091ad0a3a37c14a6a56a0f79c76d6bc93fa0dad39552f221d
diff --git a/sys-devel/gcc-config/gcc-config-2.3.ebuild b/sys-devel/gcc-config/gcc-config-2.3.ebuild
new file mode 100644 (file)
index 0000000..65dd7a3
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+       EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gcc-config.git"
+       inherit git-r3
+else
+       SRC_URI="https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Utility to manage compilers"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gcc-config.git/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+native-symlinks"
+
+RDEPEND=">=sys-apps/gentoo-functions-0.10"
+
+src_compile() {
+       emake CC="$(tc-getCC)" \
+               PV="${PV}" \
+               SUBLIBDIR="$(get_libdir)" \
+               USE_NATIVE_LINKS="$(usex native-symlinks)"
+}
+
+src_install() {
+       emake \
+               DESTDIR="${D}" \
+               PV="${PV}" \
+               SUBLIBDIR="$(get_libdir)" \
+               install
+}
+
+pkg_postinst() {
+       # Scrub eselect-compiler remains.
+       # To be removed in 2021.
+       rm -f "${ROOT}"/etc/env.d/05compiler
+
+       # We not longer use the /usr/include/g++-v3 hacks, as
+       # it is not needed ...
+       # To be removed in 2021.
+       rm -f "${ROOT}"/usr/include/g++{,-v3}
+
+       # Do we have a valid multi ver setup ?
+       local x
+       for x in $(gcc-config -C -l 2>/dev/null | awk '$NF == "*" { print $2 }') ; do
+               gcc-config ${x}
+       done
+
+       # USE flag change can add or delete files in /usr/bin worth recaching
+       if [[ ! ${ROOT%/} && -f ${EPREFIX}/usr/share/eselect/modules/compiler-shadow.eselect ]] ; then
+               eselect compiler-shadow update all
+       fi
+}
index e4f08729165acba380c16dded5d1b35f98f558ca..65dd7a38e1fba84470fecb498eb99350dc399ded 100644 (file)
@@ -9,9 +9,8 @@ if [[ ${PV} == 9999 ]]; then
        EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gcc-config.git"
        inherit git-r3
 else
-       SRC_URI="mirror://gentoo/${P}.tar.xz
-               https://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.xz"
-       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+       SRC_URI="https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
 fi
 
 DESCRIPTION="Utility to manage compilers"