net-fs/s3fs: Bump version to 1.86
authorPetr Vaněk <arkamar@atlas.cz>
Wed, 5 Feb 2020 14:41:34 +0000 (15:41 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 6 Feb 2020 06:19:57 +0000 (08:19 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Petr Vaněk <arkamar@atlas.cz>
Closes: https://github.com/gentoo/gentoo/pull/14573
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-fs/s3fs/Manifest
net-fs/s3fs/s3fs-1.86.ebuild [new file with mode: 0644]

index 888780bd740a85df5236322a575d10c66e994a94..75cc2e7254e77faa52845009b884b5e908f52886 100644 (file)
@@ -1,3 +1,4 @@
 DIST s3fs-1.80.tar.gz 135891 BLAKE2B a2e38154e1721a88042e49db22bbd607ce0776758a351f5a54e76cb1654518a4d3e30cf9faf3d6d04f6d45d3224491f6e55cbae83ee5b88c27211044255d51d0 SHA512 c98c61198a6c2132f98ef5a8c8f600787cf359c6f79010366f786a3758281257cbf79b4bb47892fd1e9e50d8e46a389125ea67f3828c1c8131cbee5462c74141
 DIST s3fs-1.83.tar.gz 150816 BLAKE2B 1b567708ea6264a619b664c5be3186374dcd3f50f01ac7d9aa093a82520f4685b7adc49a2d9c5a30e64334439c4c2676ae6cc74079251b4e47fe4ff7ad1f5945 SHA512 a925fb09c5786f2ff7fcb458e3cc37cce0eb2bd431b24e582cf02e7656716bfd9b7ffa3647f6f3c56ccfa313d2238cd263f28c2321850c1de082c48ebd9af5cb
 DIST s3fs-1.85.tar.gz 170209 BLAKE2B 1f879948d243d36c99186a4b6a52cd1200472c7f792583e56cd82e4f00e79374e82ee033152dac2642e626acbf9e0523a45fa41aed0bcd9b1743df418387d610 SHA512 c99920bf1f1dc04a0ff89a71ad027a5b65d22d75a77f5c6dd4559eaa299af36c71d29b4bcf9fe7e473478e7da1d328c7cfcb1fb77d414b65a289f38456ce5d7a
+DIST s3fs-1.86.tar.gz 183636 BLAKE2B 78996960725699fee4c0c2b131c227acc073fca407f1057ae636167a7a2313e460f1e3a89c7d8a3741987d8ba46ab1827f8f7c882261ed78bb5c5148ce935d42 SHA512 a4f79d9ae526427d5d41b5cd1519e4aac605e8bbd97079aec2a67562f0322fa5664d770d565aed4fca83ae254ab3c0454d25f4b86ec4d148a57c7745e07f5e14
diff --git a/net-fs/s3fs/s3fs-1.86.ebuild b/net-fs/s3fs/s3fs-1.86.ebuild
new file mode 100644 (file)
index 0000000..15c85de
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_PN=${PN}-fuse
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Amazon S3 mounting via fuse"
+HOMEPAGE="https://github.com/s3fs-fuse/s3fs-fuse/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls nettle nss +openssl test"
+REQUIRED_USE="
+       ^^ ( gnutls nss openssl )
+       nettle? ( gnutls )"
+
+# Requires active internet connection
+RESTRICT="test"
+
+DEPEND="
+       dev-libs/libxml2:2
+       net-misc/curl
+       sys-fs/fuse:0
+       gnutls? ( net-libs/gnutls:= )
+       nettle? ( dev-libs/nettle:= )
+       nss? ( dev-libs/nss )
+       openssl? ( dev-libs/openssl:0= )
+"
+
+RDEPEND="${DEPEND}
+       app-misc/mime-types
+"
+
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       local myeconfargs=(
+               $(use_with gnutls)
+               $(use_with nettle)
+               $(use_with nss)
+               $(use_with openssl)
+       )
+       econf "${myeconfargs[@]}"
+}