dev-python/gcs-oauth2-boto-plugin: Remove old
authorDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:51:41 +0000 (09:51 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:51:41 +0000 (09:51 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/gcs-oauth2-boto-plugin/Manifest
dev-python/gcs-oauth2-boto-plugin/files/gcs-oauth2-boto-plugin-1.13-py3.patch [deleted file]
dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.14.ebuild [deleted file]
dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.1-r1.ebuild [deleted file]
dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.1.ebuild [deleted file]
dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.4.ebuild [deleted file]

index 0af084014e4945ec07803f758618b4c0edbf7043..ddc69d263a688ad57ae328aaf832894686379df8 100644 (file)
@@ -1,5 +1,2 @@
-DIST gcs-oauth2-boto-plugin-1.14.tar.gz 14980 BLAKE2B 1123633b419291433d7cfa9a284303a7ae2a6b407f487b45897df6945a63f6b0cce733a5940e74acb70bcd9740a7c0cbd3828abfb4163f7ab845a9ff2c652a1b SHA512 86804a599c969c63587387df21a2396a27509981cc13a3f92bc98a645757362e77c63b68956ebd2663a721bb51993c9e61679db85a67de48d017ddad7de044b7
 DIST gcs-oauth2-boto-plugin-1.8.tar.gz 13248 BLAKE2B 831a1b88035d6331ac2cb122fda5ffabd6319b7a030ae8c46dac32be571bdff034d6e60830e5e4403b65a414487c874cd4743f537a9c1d3674bcb1461e457945 SHA512 5504fc38d58ee68a78ee2b8e6c3757045494d000748382bc26888a65085cec08d2d137c63cb51afd1cef72d31b3f0cac5d40014548cca47c5322a67a7f1ef204
-DIST gcs-oauth2-boto-plugin-2.1.tar.gz 15789 BLAKE2B f98eb41d07aede9379bb256723c217be1c2fcf2cda18e555a5d7e85bb402215052ff4d7770cdb4066fd989f7e78d070ea19e1a469f5e6dec2b94a367a6dc3c19 SHA512 26b519fa2987e83a687907aa72e0c9eb8b2a2c48143bc1bf13bad79791379daaae190a23f9f35d1a570e21c6800d5860bbb94f3c3f3b2ff7bfcfec8a5a39af7c
-DIST gcs-oauth2-boto-plugin-2.4.tar.gz 16721 BLAKE2B 38816f6f3e5a857967fad6698aa9a35df8d31d42f083584c1e24c4dcb9379b5e8dd18fbbcf0533dccbc2db9f5e4f400d8cd1f8baddf582894af918a2d2d1b23c SHA512 e3e6b7ffca4405a4c41ca1408f05e3c61acc342d236dd2dd857854242694fdca68e155baadb8be64239583954297dac82a07a73d6391cfb93a53d29f9bf67c99
 DIST gcs-oauth2-boto-plugin-2.5.tar.gz 16739 BLAKE2B a8ef124670063eb19119f7ab6cfd3101f68815a61ec183b3c9ac79ac158e3e47f48349b4f3faa0cf83ce9a203ab2f350e61fdd8a87872962bc1b24a8182f741f SHA512 db6810351c8364c9b217e092aa83803cdc7831136b3fa1be4c54f978f919e2e33bdaf32b8d36db359c5a328eb57f7ad2cee219b94d7f60403f27aaa6a6fd53cc
diff --git a/dev-python/gcs-oauth2-boto-plugin/files/gcs-oauth2-boto-plugin-1.13-py3.patch b/dev-python/gcs-oauth2-boto-plugin/files/gcs-oauth2-boto-plugin-1.13-py3.patch
deleted file mode 100644 (file)
index 15f6fc3..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-https://github.com/GoogleCloudPlatform/gcs-oauth2-boto-plugin/pull/18
-
---- a/gcs_oauth2_boto_plugin/oauth2_client.py
-+++ b/gcs_oauth2_boto_plugin/oauth2_client.py
-@@ -122,7 +122,7 @@ except ImportError:
-           retval.token_expiry = datetime.datetime.strptime(
-               data['token_expiry'], EXPIRY_FORMAT)
-         return retval
--      except KeyError, e:
-+      except KeyError as e:
-         raise Exception('Your JSON credentials are invalid; '
-                         'missing required entry %s.' % e[0])
-   # pylint: enable=protected-access
-@@ -274,7 +274,7 @@ class FileSystemTokenCache(TokenCache):
-       flags |= os.O_BINARY
-     try:
--      fd = os.open(cache_file, flags, 0600)
-+      fd = os.open(cache_file, flags, 0o0600)
-     except (OSError, IOError) as e:
-       LOG.warning('FileSystemTokenCache.PutToken: '
-                   'Failed to create cache file %s: %s', cache_file, e)
-@@ -633,7 +633,7 @@ class OAuth2UserAccountClient(OAuth2Client):
-       return AccessToken(
-           credentials.access_token, credentials.token_expiry,
-           datetime_strategy=self.datetime_strategy)
--    except AccessTokenRefreshError, e:
-+    except AccessTokenRefreshError as e:
-       if 'Invalid response 403' in e.message:
-         # This is the most we can do at the moment to accurately detect rate
-         # limiting errors since they come back as 403s with no further
-@@ -669,7 +669,7 @@ class OAuth2GCEClient(OAuth2Client):
-       http = httplib2.Http()
-       response, content = http.request(META_TOKEN_URI, method='GET',
-                                        body=None, headers=META_HEADERS)
--    except Exception, e:
-+    except Exception as e:
-       raise GsAccessTokenRefreshError(e)
-     if response.status == 200:
-@@ -695,7 +695,7 @@ def _IsGCE():
-     # this approach, we'll avoid having to enumerate all possible non-transient
-     # socket errors.
-     return False
--  except Exception, e:  # pylint: disable=broad-except
-+  except Exception as e:  # pylint: disable=broad-except
-     LOG.warning("Failed to determine whether we're running on GCE, so we'll"
-                 "assume that we aren't: %s", e)
-     return False
---- a/gcs_oauth2_boto_plugin/test_oauth2_client.py
-+++ b/gcs_oauth2_boto_plugin/test_oauth2_client.py
-@@ -248,7 +248,7 @@ class FileSystemTokenCacheTest(unittest.TestCase):
-     # Assert that the cache file exists and has correct permissions.
-     if not IS_WINDOWS:
-       self.assertEquals(
--          0600,
-+          0o0600,
-           stat.S_IMODE(os.stat(self.cache.CacheFileName(self.key)).st_mode))
-   def testPutGet(self):
diff --git a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.14.ebuild b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.14.ebuild
deleted file mode 100644 (file)
index 14f5c9c..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="OAuth 2.0 plugin for Google Cloud Storage credentials in the Boto library"
-HOMEPAGE="https://pypi.org/project/gcs-oauth2-boto-plugin/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="test"
-# The tests only work with py2 atm.
-RESTRICT="test"
-
-PATCHES=(
-       "${FILESDIR}/${PN}-1.13-use-friendy-version-checks.patch"
-       "${FILESDIR}/${PN}-1.13-py3.patch"
-)
-
-# Keep versions in sync with setup.py.
-DEPEND="${PYTHON_DEPS}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/freezegun[${PYTHON_USEDEP}]
-       )"
-RDEPEND="${PYTHON_DEPS}
-       >=dev-python/boto-2.29.1[${PYTHON_USEDEP}]
-       >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
-       >=dev-python/oauth2client-1.5.2[${PYTHON_USEDEP}]
-       !=dev-python/oauth2client-2.0*
-       >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
-       >=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
-       >=dev-python/PySocks-1.01[${PYTHON_USEDEP}]
-       >=dev-python/six-1.6.1[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
-       distutils-r1_python_prepare_all
-       sed -i \
-               -e '/SocksiPy-branch/d' \
-               setup.py || die
-       # Make sure the unittests aren't installed.
-       mv gcs_oauth2_boto_plugin/test_oauth2_client.py ./ || die
-}
-
-python_test() {
-       ${EPYTHON} "${S}"/test_oauth2_client.py || die
-}
diff --git a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.1-r1.ebuild b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.1-r1.ebuild
deleted file mode 100644 (file)
index aebf352..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="OAuth 2.0 plugin for Google Cloud Storage credentials in the Boto library"
-HOMEPAGE="https://pypi.org/project/gcs-oauth2-boto-plugin/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-PATCHES=(
-       "${FILESDIR}/${PN}-1.13-use-friendy-version-checks.patch"
-)
-
-# Keep versions in sync with setup.py.
-DEPEND="${PYTHON_DEPS}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/freezegun[${PYTHON_USEDEP}]
-       )"
-RDEPEND="${PYTHON_DEPS}
-       >=dev-python/boto-2.29.1[${PYTHON_USEDEP}]
-       dev-python/google-reauth-python[${PYTHON_USEDEP}]
-       >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
-       >=dev-python/oauth2client-1.5.2[${PYTHON_USEDEP}]
-       !=dev-python/oauth2client-2.0*
-       >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
-       >=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
-       >=dev-python/PySocks-1.01[${PYTHON_USEDEP}]
-       >=dev-python/six-1.6.1[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
-       distutils-r1_python_prepare_all
-       sed -i \
-               -e '/SocksiPy-branch/d' \
-               setup.py || die
-       # Make sure the unittests aren't installed.
-       mv gcs_oauth2_boto_plugin/test_oauth2_client.py ./ || die
-}
-
-python_test() {
-       ${EPYTHON} "${S}"/test_oauth2_client.py || die
-}
diff --git a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.1.ebuild b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.1.ebuild
deleted file mode 100644 (file)
index ccc056b..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="OAuth 2.0 plugin for Google Cloud Storage credentials in the Boto library"
-HOMEPAGE="https://pypi.org/project/gcs-oauth2-boto-plugin/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-PATCHES=(
-       "${FILESDIR}/${PN}-1.13-use-friendy-version-checks.patch"
-)
-
-# Keep versions in sync with setup.py.
-DEPEND="${PYTHON_DEPS}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/freezegun[${PYTHON_USEDEP}]
-       )"
-RDEPEND="${PYTHON_DEPS}
-       >=dev-python/boto-2.29.1[${PYTHON_USEDEP}]
-       >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
-       >=dev-python/oauth2client-1.5.2[${PYTHON_USEDEP}]
-       !=dev-python/oauth2client-2.0*
-       >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
-       >=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
-       >=dev-python/PySocks-1.01[${PYTHON_USEDEP}]
-       >=dev-python/six-1.6.1[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
-       distutils-r1_python_prepare_all
-       sed -i \
-               -e '/SocksiPy-branch/d' \
-               setup.py || die
-       # Make sure the unittests aren't installed.
-       mv gcs_oauth2_boto_plugin/test_oauth2_client.py ./ || die
-}
-
-python_test() {
-       ${EPYTHON} "${S}"/test_oauth2_client.py || die
-}
diff --git a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.4.ebuild b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.4.ebuild
deleted file mode 100644 (file)
index f4f84a4..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="OAuth 2.0 plugin for Google Cloud Storage credentials in the Boto library"
-HOMEPAGE="https://pypi.org/project/gcs-oauth2-boto-plugin/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-PATCHES=(
-       "${FILESDIR}/${PN}-1.13-use-friendy-version-checks.patch"
-)
-
-# Keep versions in sync with setup.py.
-DEPEND="${PYTHON_DEPS}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/freezegun[${PYTHON_USEDEP}]
-       )"
-RDEPEND="${PYTHON_DEPS}
-       >=dev-python/boto-2.29.1[${PYTHON_USEDEP}]
-       dev-python/google-reauth-python[${PYTHON_USEDEP}]
-       >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
-       >=dev-python/oauth2client-1.5.2[${PYTHON_USEDEP}]
-       !=dev-python/oauth2client-2.0*
-       >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
-       >=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
-       >=dev-python/PySocks-1.01[${PYTHON_USEDEP}]
-       >=dev-python/six-1.6.1[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
-       distutils-r1_python_prepare_all
-       sed -i \
-               -e '/SocksiPy-branch/d' \
-               setup.py || die
-       # Make sure the unittests aren't installed.
-       mv gcs_oauth2_boto_plugin/test_oauth2_client.py ./ || die
-}
-
-python_test() {
-       ${EPYTHON} "${S}"/test_oauth2_client.py -v || die
-}