net-libs/nodejs: Old
authorJeroen Roovers <jer@gentoo.org>
Mon, 21 Oct 2019 09:55:24 +0000 (11:55 +0200)
committerJeroen Roovers <jer@gentoo.org>
Mon, 21 Oct 2019 09:55:37 +0000 (11:55 +0200)
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-libs/nodejs/Manifest
net-libs/nodejs/nodejs-12.11.1.ebuild [deleted file]

index 00ab88cc3645fc961b7df25ea306683ec38ad2a8..b33cf7a848df85c920a2ff260c8262f264b8488c 100644 (file)
@@ -1,5 +1,4 @@
 DIST node-v10.16.3.tar.xz 21505540 BLAKE2B 2ae6c3ce96a42cb72a388ca7727affb1e2eae06b997098bd8cad2b339b888f1f188c868d39631c51e10ef7b3a5a9173a3b016afe9fa7a4fb74c24a584781c329 SHA512 5d5457adaae87e41699cdf5bd62d32e9590248f7dadd583614cca9078a1749a4ee477433ebbe4278ec872fdfc377d99097c1e06073e0fd47c8c6597256ccdeb7
-DIST node-v12.11.1.tar.xz 22852156 BLAKE2B 38205c3ad52ccac2656c72b31c5714268e4771375b13d7c113e4a5fe7e9530d2826c43aeaa3ed3e30210f504d37221f90f3fb2a15f4c5fbca8878d0f2639b9fa SHA512 9567ee592ea8a05f899755d5e1c934413532676c78a663a1a861a6fa882c7eecae411c05c4b034191b7266776341609c098fbccfcd93c93eba7b84d138eeffb9
 DIST node-v12.12.0.tar.xz 22836688 BLAKE2B 81ff202fb807c557a30eeb08a76a8e95e2faec300d360caac5ce177cdfcda3963bcea904f3e79f9ced9fe2219e7e1d4a760a9c4e69dfe5b670c737e2a598cf6a SHA512 91872784a7a7e7e1e0beeb1166eb1ddd7a5432271e9f62265815d4c5b5d831f269916954bb36724e65108c57d6a7ebac3a2a5be2e49f51f7904a7d549c92176b
 DIST node-v12.13.0.tar.xz 22862096 BLAKE2B b0121f45b535bac7baa0103db538070b4beb4b40a6c871c217eebfb1abb5a7821d83d46946047b3385af182f901c0390eb85134c9201be2d03b5745b297271f8 SHA512 a7aa8b1f010ea1df122d9d7b88ee0a9d10e0d79ae2f3d18c706ac6ce36e2e2039c21ea6f3dba3a22a79ed3f6069850a8a3c463dbd64e1e8f4a9dbe8901a89cc8
 DIST node-v8.12.0.tar.xz 18310452 BLAKE2B 79634fc57cd76a97e72bab4be37da91d5eff4d13cdaa2b48e83f013885fa3590ba4a28378baf036ed26b7304bf234753d1d4014f72571496f5bb6cd5b221e5f0 SHA512 665d2dba287d78bcd723d7b4d00a6897fb996f4aa69a541e010a3dfeb2614257892117fcce7123966b1ecaddc9269a6667e0e262df693baea1f476c96de55c42
diff --git a/net-libs/nodejs/nodejs-12.11.1.ebuild b/net-libs/nodejs/nodejs-12.11.1.ebuild
deleted file mode 100644 (file)
index fdf342c..0000000
+++ /dev/null
@@ -1,210 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="threads"
-inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
-
-DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
-HOMEPAGE="https://nodejs.org/"
-SRC_URI="
-       https://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz
-"
-
-LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos"
-IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm +snapshot +ssl systemtap test"
-REQUIRED_USE="
-       inspector? ( icu ssl )
-       npm? ( ssl )
-"
-
-RDEPEND="
-       >=dev-libs/libuv-1.31.0:=
-       >=net-dns/c-ares-1.15.0
-       >=net-libs/http-parser-2.9.0:=
-       >=net-libs/nghttp2-1.39.2
-       sys-libs/zlib
-       icu? ( >=dev-libs/icu-64.2:= )
-       ssl? ( >=dev-libs/openssl-1.1.1:0= )
-"
-DEPEND="
-       ${RDEPEND}
-       ${PYTHON_DEPS}
-       systemtap? ( dev-util/systemtap )
-       test? ( net-misc/curl )
-"
-PATCHES=(
-       "${FILESDIR}"/${PN}-10.3.0-global-npm-config.patch
-       "${FILESDIR}"/${PN}-99999999-llhttp.patch
-)
-S="${WORKDIR}/node-v${PV}"
-
-pkg_pretend() {
-       (use x86 && ! use cpu_flags_x86_sse2) && \
-               die "Your CPU doesn't support the required SSE2 instruction."
-
-       ( [[ ${MERGE_TYPE} != "binary" ]] && ! test-flag-CXX -std=c++11 ) && \
-               die "Your compiler doesn't support C++11. Use GCC 4.8, Clang 3.3 or newer."
-}
-
-src_prepare() {
-       tc-export CC CXX PKG_CONFIG
-       export V=1
-       export BUILDTYPE=Release
-
-       # fix compilation on Darwin
-       # https://code.google.com/p/gyp/issues/detail?id=260
-       sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
-
-       # make sure we use python2.* while using gyp
-       sed -i -e "s/python/${EPYTHON}/" deps/npm/node_modules/node-gyp/gyp/gyp || die
-
-       # less verbose install output (stating the same as portage, basically)
-       sed -i -e "/print/d" tools/install.py || die
-
-       # proper libdir, hat tip @ryanpcmcquen https://github.com/iojs/io.js/issues/504
-       local LIBDIR=$(get_libdir)
-       sed -i -e "s|lib/|${LIBDIR}/|g" tools/install.py || die
-       sed -i -e "s/'lib'/'${LIBDIR}'/" deps/npm/lib/npm.js || die
-
-       # Avoid writing a depfile, not useful
-       sed -i -e "/DEPFLAGS =/d" tools/gyp/pylib/gyp/generator/make.py || die
-
-       sed -i -e "/'-O3'/d" common.gypi node.gypi || die
-
-       # Avoid a test that I've only been able to reproduce from emerge. It doesnt
-       # seem sandbox related either (invoking it from a sandbox works fine).
-       # The issue is that no stdin handle is openened when asked for one.
-       # It doesn't really belong upstream , so it'll just be removed until someone
-       # with more gentoo-knowledge than me (jbergstroem) figures it out.
-       rm test/parallel/test-stdout-close-unref.js || die
-
-       # debug builds. change install path, remove optimisations and override buildtype
-       if use debug; then
-               sed -i -e "s|out/Release/|out/Debug/|g" tools/install.py || die
-               BUILDTYPE=Debug
-       fi
-
-       default
-}
-
-src_configure() {
-       xdg_environment_reset
-
-       local myconf=(
-               --shared-cares --shared-http-parser --shared-libuv --shared-nghttp2
-               --shared-zlib
-       )
-       use debug && myconf+=( --debug )
-       use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )
-       use inspector || myconf+=( --without-inspector )
-       use npm || myconf+=( --without-npm )
-       use snapshot && myconf+=( --with-snapshot )
-       use ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) || myconf+=( --without-ssl )
-
-       local myarch=""
-       case ${ABI} in
-               amd64) myarch="x64";;
-               arm) myarch="arm";;
-               arm64) myarch="arm64";;
-               ppc64) myarch="ppc64";;
-               x32) myarch="x32";;
-               x86) myarch="ia32";;
-               *) myarch="${ABI}";;
-       esac
-
-       GYP_DEFINES="linux_use_gold_flags=0
-               linux_use_bundled_binutils=0
-               linux_use_bundled_gold=0" \
-       "${PYTHON}" configure \
-               --prefix="${EPREFIX}"/usr \
-               --dest-cpu=${myarch} \
-               $(use_with systemtap dtrace) \
-               "${myconf[@]}" || die
-}
-
-src_compile() {
-       emake -C out mksnapshot
-       pax-mark m "out/${BUILDTYPE}/mksnapshot"
-       emake -C out
-}
-
-src_install() {
-       local LIBDIR="${ED}/usr/$(get_libdir)"
-       default
-
-       pax-mark -m "${ED}"/usr/bin/node
-
-       # set up a symlink structure that node-gyp expects..
-       dodir /usr/include/node/deps/{v8,uv}
-       dosym . /usr/include/node/src
-       for var in deps/{uv,v8}/include; do
-               dosym ../.. /usr/include/node/${var}
-       done
-
-       if use doc; then
-               # Patch docs to make them offline readable
-               for i in `grep -rl 'fonts.googleapis.com' "${S}"/out/doc/api/*`; do
-                       sed -i '/fonts.googleapis.com/ d' $i;
-               done
-               # Install docs
-               docinto html
-               dodoc -r "${S}"/doc/*
-       fi
-
-       if use npm; then
-               dodir /etc/npm
-
-               # Install bash completion for `npm`
-               # We need to temporarily replace default config path since
-               # npm otherwise tries to write outside of the sandbox
-               local npm_config="usr/$(get_libdir)/node_modules/npm/lib/config/core.js"
-               sed -i -e "s|'/etc'|'${ED}/etc'|g" "${ED}/${npm_config}" || die
-               local tmp_npm_completion_file="$(emktemp)"
-               "${ED}/usr/bin/npm" completion > "${tmp_npm_completion_file}"
-               newbashcomp "${tmp_npm_completion_file}" npm
-               sed -i -e "s|'${ED}/etc'|'/etc'|g" "${ED}/${npm_config}" || die
-
-               # Move man pages
-               doman "${LIBDIR}"/node_modules/npm/man/man{1,5,7}/*
-
-               # Clean up
-               rm "${LIBDIR}"/node_modules/npm/{.mailmap,.npmignore,Makefile} || die
-               rm -rf "${LIBDIR}"/node_modules/npm/{doc,html,man} || die
-
-               local find_exp="-or -name"
-               local find_name=()
-               for match in "AUTHORS*" "CHANGELOG*" "CONTRIBUT*" "README*" \
-                       ".travis.yml" ".eslint*" ".wercker.yml" ".npmignore" \
-                       "*.md" "*.markdown" "*.bat" "*.cmd"; do
-                       find_name+=( ${find_exp} "${match}" )
-               done
-
-               # Remove various development and/or inappropriate files and
-               # useless docs of dependend packages.
-               find "${LIBDIR}"/node_modules \
-                       \( -type d -name examples \) -or \( -type f \( \
-                               -iname "LICEN?E*" \
-                               "${find_name[@]}" \
-                       \) \) -exec rm -rf "{}" \;
-       fi
-
-       mv "${ED}"/usr/share/doc/node "${ED}"/usr/share/doc/${PF} || die
-}
-
-src_test() {
-       out/${BUILDTYPE}/cctest || die
-       "${PYTHON}" tools/test.py --mode=${BUILDTYPE,,} -J message parallel sequential || die
-}
-
-pkg_postinst() {
-       elog "The global npm config lives in /etc/npm. This deviates slightly"
-       elog "from upstream which otherwise would have it live in /usr/etc/."
-       elog ""
-       elog "Protip: When using node-gyp to install native modules, you can"
-       elog "avoid having to download extras by doing the following:"
-       elog "$ node-gyp --nodedir /usr/include/node <command>"
-}