app-office/gnucash: Don't build gtest from source
authorPeter Levine <plevine457@gmail.com>
Sun, 25 Aug 2019 23:16:45 +0000 (19:16 -0400)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 13 Oct 2019 11:40:22 +0000 (13:40 +0200)
With gnucash-3.6, the build now looks for gtest headers and libraries
and uses them if found.

Closes: https://bugs.gentoo.org/691276
Package-Manager: Portage-2.3.72, Repoman-2.3.17
Signed-off-by: Peter Levine <plevine457@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/12792
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-office/gnucash/gnucash-3.6.ebuild

index 9999712e8bfd9b52575fae888330441b1dbefd99..00c0d0fd915ee3a00912644cd308a68aaa8396a0 100644 (file)
@@ -3,23 +3,20 @@
 
 EAPI=6
 
-# google{test,mock} version
-GV="1.8.0"
 PYTHON_COMPAT=( python3_{4,5,6} )
 
 inherit cmake-utils gnome2-utils python-single-r1 xdg-utils
 
 DESCRIPTION="A personal finance manager"
 HOMEPAGE="http://www.gnucash.org/"
-SRC_URI="https://github.com/Gnucash/${PN}/releases/download/${PV}/${P}.tar.bz2
-       https://github.com/google/googletest/archive/release-${GV}.tar.gz -> gtest-${GV}.tar.gz"
+SRC_URI="https://github.com/Gnucash/${PN}/releases/download/${PV}/${P}.tar.bz2"
 
 SLOT="0"
 LICENSE="GPL-2"
 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
 
 IUSE="aqbanking chipcard debug doc examples gnome-keyring +gui mysql nls ofx
-         postgres python quotes -register2 sqlite"
+         postgres python quotes -register2 sqlite test"
 
 REQUIRED_USE="
        chipcard? ( aqbanking )
@@ -70,12 +67,12 @@ RDEPEND="
 "
 
 DEPEND="${RDEPEND}
-       ~dev-cpp/gtest-${GV}
        >=sys-devel/gettext-0.19.6
        dev-lang/perl
        dev-perl/XML-Parser
        sys-devel/libtool
        virtual/pkgconfig
+       test? ( >=dev-cpp/gtest-1.8.0 )
 "
 
 PDEPEND="doc? (
@@ -104,8 +101,6 @@ src_configure() {
        fi
 
        local mycmakeargs=(
-               -DGMOCK_ROOT="${WORKDIR}"/googletest-release-${GV}/googlemock
-               -DGTEST_ROOT="${WORKDIR}"/googletest-release-${GV}/googletest
                # Disable fallback to guile-2.0
                -DCMAKE_DISABLE_FIND_PACKAGE_GUILE2=ON
                -DCOMPILE_GSCHEMAS=OFF