dev-python/xlwt: remove old
authorVirgil Dupras <vdupras@gentoo.org>
Wed, 8 May 2019 14:06:02 +0000 (10:06 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Wed, 8 May 2019 14:06:02 +0000 (10:06 -0400)
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-python/xlwt/Manifest
dev-python/xlwt/xlwt-1.0.0.ebuild [deleted file]

index c7577fc774e38949b83724a3e2e81c5fe84101aa..a8c2aff4dbc50106dc7aa955d902090e05f750d3 100644 (file)
@@ -1,3 +1,2 @@
-DIST xlwt-1.0.0.tar.gz 129588 BLAKE2B e900aec8efc254539936a7e5998c17116c3d95c66fe169aff8caaf11a9509cfbebe29f9cc5ea4a5f6b5b1cdf28f9e08cdd33ce7ae4bf474b4d51df491605f372 SHA512 45788a506635f1ef6380d46aa0af724e511e401e8347dcf48dbf4e2d90e7f4c7f66838cd9616cf58807ffb939daba1f47b0d2cf449f8cb528db41fba84cc8866
 DIST xlwt-1.2.0.tar.gz 153909 BLAKE2B 553315b6f6ba822122c18cfabaf5a30f25a6ccdc1c507bf7fbf293df42e380520ef647d3501b51443a90f77c59497b87c70f6a71d3b3ce53658d3a6cf2356f6a SHA512 e0be61f6a54ac39c91cf03a1a7535c464045539f6a040f000921815e3280bd341770d72f4353891a10dde7c1b51eab4ccb1ae1c10bbf779108346fba8484eef8
 DIST xlwt-1.3.0.tar.gz 153929 BLAKE2B f0edb823201e477aca23af1edaa2a7bcf95aeb5b9b191f4d9a8be9e052d68699887cd829c2304b26334fb3e92d4a1fc1d0dbfabb477889a1295255170408715c SHA512 e09c515bda7edadb9624b842796a537316c1e2e06f3e74aca5440a5797dbc259036539fd64ea61648a30894f4091d3be829411d36e6170894980728c798c5963
diff --git a/dev-python/xlwt/xlwt-1.0.0.ebuild b/dev-python/xlwt/xlwt-1.0.0.ebuild
deleted file mode 100644 (file)
index 747ef3f..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_5 pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library to create spreadsheet files compatible with Excel"
-HOMEPAGE="https://pypi.org/project/xlwt/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? (
-               >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}]
-               dev-python/pkginfo[${PYTHON_USEDEP}]
-       )
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-# Prevent d'loading in the doc build
-PATCHES=( "${FILESDIR}"/docbuild.patch )
-
-python_prepare_all() {
-       # Don't install documentation and examples in site-packages directories.
-       sed -e "/package_data/d" -i setup.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       nosetests tests || die "tests failed under ${EPYTHON}}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       use examples && local EXAMPLES=( examples/. )
-       distutils-r1_python_install_all
-}