Add patch to fix issues with hidden visibility disabled, bug #158146. Thanks Timothy...
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 14 Dec 2006 18:06:57 +0000 (18:06 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 14 Dec 2006 18:06:57 +0000 (18:06 +0000)
Package-Manager: portage-2.1.2_rc3-r4

kde-base/kdebase/ChangeLog
kde-base/kdebase/files/digest-kdebase-3.5.5-r3 [new file with mode: 0644]
kde-base/kdebase/files/kate-3.5.5-visibility.patch [new file with mode: 0644]
kde-base/kdebase/kdebase-3.5.5-r3.ebuild [new file with mode: 0644]

index 45439acec53e6b9a053218cd4554cd3b8a9e02c7..ef934782b3e0b7207cfe824a83636573fa5e1433 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for kde-base/kdebase
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.328 2006/12/11 10:56:33 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.329 2006/12/14 18:06:57 flameeyes Exp $
+
+*kdebase-3.5.5-r3 (14 Dec 2006)
+
+  14 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
+  +files/kate-3.5.5-visibility.patch, +kdebase-3.5.5-r3.ebuild:
+  Add patch to fix issues with hidden visibility disabled, bug #158146. Thanks
+  Timothy for reporting.
 
   11 Dec 2006; <kloeri@gentoo.org> kdebase-3.5.5-r1.ebuild:
   Stable on ia64.
diff --git a/kde-base/kdebase/files/digest-kdebase-3.5.5-r3 b/kde-base/kdebase/files/digest-kdebase-3.5.5-r3
new file mode 100644 (file)
index 0000000..f51965c
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 420445e2dbddfd83ebc25e85a9b9cdda kdebase-3.5-patchset-03.tar.bz2 21409
+RMD160 941b919097d03347b10bccb51db2fa5e89d7ba16 kdebase-3.5-patchset-03.tar.bz2 21409
+SHA256 59c691754627f78daf7693e82496d808cf1cc31e2d6f32af829ec4ccfd776574 kdebase-3.5-patchset-03.tar.bz2 21409
+MD5 0c685af1cbca75f9c77b3ed231ba0468 kdebase-3.5.5.tar.bz2 23851886
+RMD160 6cf804de0487347a3e1d4ea6e5ba5114d23d9806 kdebase-3.5.5.tar.bz2 23851886
+SHA256 f77632e44214648e2d0adfe1a79dd61a6a738c21fe5abb0baff16b72432baaa0 kdebase-3.5.5.tar.bz2 23851886
diff --git a/kde-base/kdebase/files/kate-3.5.5-visibility.patch b/kde-base/kdebase/files/kate-3.5.5-visibility.patch
new file mode 100644 (file)
index 0000000..4468a30
--- /dev/null
@@ -0,0 +1,77 @@
+SVN commit 599194 by dhaumann:
+
+fix missing KDE_EXPORTs which caused undefined references for kate plugins.
+
+CCMAIL: kwrite-devel@kde.org
+
+
+ M  +1 -1      application.h  
+ M  +1 -1      documentmanager.h  
+ M  +2 -2      plugin.h  
+ M  +1 -1      pluginconfiginterface.h  
+ M  +1 -1      pluginconfiginterfaceextension.h  
+
+
+--- branches/KDE/3.5/kdebase/kate/interfaces/application.h #599193:599194
+@@ -72,7 +72,7 @@
+  * Returns the application object
+  * @return Application application object
+  */
+-Application *application ();
++KDE_EXPORT Application *application ();
+ }
+--- branches/KDE/3.5/kdebase/kate/interfaces/documentmanager.h #599193:599194
+@@ -104,7 +104,7 @@
+  * Returns the document manager object
+  * @return DocumentManager document manager object
+  */
+-DocumentManager *documentManager ();
++KDE_EXPORT DocumentManager *documentManager ();
+ }
+--- branches/KDE/3.5/kdebase/kate/interfaces/plugin.h #599193:599194
+@@ -52,7 +52,7 @@
+     unsigned int myPluginNumber;
+ };
+-Plugin *createPlugin ( const char* libname, Application *application = 0, const char *name = 0,const QStringList &args = QStringList() );
++KDE_EXPORT Plugin *createPlugin ( const char* libname, Application *application = 0, const char *name = 0,const QStringList &args = QStringList() );
+ /*
+  * view plugin class
+@@ -80,7 +80,7 @@
+     unsigned int myPluginViewInterfaceNumber;
+ };
+-PluginViewInterface *pluginViewInterface (Plugin *plugin);
++KDE_EXPORT PluginViewInterface *pluginViewInterface (Plugin *plugin);
+ }
+--- branches/KDE/3.5/kdebase/kate/interfaces/pluginconfiginterface.h #599193:599194
+@@ -56,7 +56,7 @@
+ };
+ class Plugin;
+-PluginConfigInterface *pluginConfigInterface (Plugin *plugin);
++KDE_EXPORT PluginConfigInterface *pluginConfigInterface (Plugin *plugin);
+ }
+--- branches/KDE/3.5/kdebase/kate/interfaces/pluginconfiginterfaceextension.h #599193:599194
+@@ -97,7 +97,7 @@
+ };
+ class Plugin;
+-PluginConfigInterfaceExtension *pluginConfigInterfaceExtension (Plugin *plugin);
++KDE_EXPORT PluginConfigInterfaceExtension *pluginConfigInterfaceExtension (Plugin *plugin);
+ }
+_______________________________________________
+KWrite-Devel mailing list
+KWrite-Devel@kde.org
+https://mail.kde.org/mailman/listinfo/kwrite-devel
\ No newline at end of file
diff --git a/kde-base/kdebase/kdebase-3.5.5-r3.ebuild b/kde-base/kdebase/kdebase-3.5.5-r3.ebuild
new file mode 100644 (file)
index 0000000..48cddc3
--- /dev/null
@@ -0,0 +1,197 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.5.5-r3.ebuild,v 1.1 2006/12/14 18:06:57 flameeyes Exp $
+
+inherit kde-dist eutils flag-o-matic
+
+SRC_URI="${SRC_URI}
+       mirror://gentoo/kdebase-3.5-patchset-03.tar.bz2"
+
+DESCRIPTION="KDE base packages: the desktop, panel, window manager, konqueror..."
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="arts cups java ldap ieee1394 hal lm_sensors logitech-mouse openexr opengl
+pam samba ssl zeroconf xcomposite xscreensaver xinerama kdehiddenvisibility"
+# hal: enables hal backend for 'media:' ioslave
+
+DEPEND="arts? ( ~kde-base/arts-${PV} )
+       >=media-libs/freetype-2
+       media-libs/fontconfig
+       pam? ( kde-base/kdebase-pam )
+       >=dev-libs/cyrus-sasl-2
+       ldap? ( >=net-nds/openldap-2 )
+       cups? ( net-print/cups )
+       ssl? ( dev-libs/openssl )
+       opengl? ( virtual/opengl )
+       openexr? ( >=media-libs/openexr-1.2.2-r2 )
+       samba? ( >=net-fs/samba-3.0.4 )
+       lm_sensors? ( sys-apps/lm_sensors )
+       logitech-mouse? ( >=dev-libs/libusb-0.1.10a )
+       ieee1394? ( sys-libs/libraw1394 )
+       hal? ( || ( dev-libs/dbus-qt3-old ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.34 ) )
+                  =sys-apps/hal-0.5* )
+       zeroconf? ( net-misc/mDNSResponder )
+       xcomposite? ( || ( (
+                       x11-libs/libXcomposite
+                       x11-libs/libXdamage
+                       ) <x11-base/xorg-x11-7 )
+               )
+       || ( (
+                       x11-libs/libX11
+                       x11-libs/libXau
+                       x11-libs/libXfixes
+                       x11-libs/libXrender
+                       x11-libs/libXtst
+                       x11-libs/libXext
+                       xscreensaver? ( x11-libs/libXScrnSaver )
+                       xinerama? ( x11-libs/libXinerama )
+               ) <virtual/x11-7 )"
+
+RDEPEND="${DEPEND}
+       sys-apps/usbutils
+       java? ( >=virtual/jre-1.4 )
+       kernel_linux? ( || ( >=sys-apps/eject-2.1.5 sys-block/unieject ) )
+       || ( (
+                       x11-apps/xmessage
+                       x11-apps/xsetroot
+                       x11-apps/xset
+                       x11-apps/xrandr
+                       x11-apps/mkfontdir
+                       x11-apps/xinit
+                       || ( x11-misc/xkeyboard-config x11-misc/xkbdata )
+                       x11-apps/setxkbmap
+                       x11-apps/xprop
+               ) <virtual/x11-7 )"
+
+DEPEND="${DEPEND}
+       xcomposite? ( || ( (
+                       x11-proto/compositeproto
+                       x11-proto/damageproto
+                       ) <x11-base/xorg-x11-7 )
+               )
+       || ( (
+                       xscreensaver? ( x11-proto/scrnsaverproto )
+                       xinerama? ( x11-proto/xineramaproto )
+                       x11-apps/bdftopcf
+               ) <virtual/x11-7 )
+       dev-util/pkgconfig"
+
+PATCHES="${FILESDIR}/kdebase-startkde-3.5.3-xinitrcd.patch
+       ${FILESDIR}/kdebase-kioslaves-3.5.5-fstab.patch
+       ${FILESDIR}/kwin-3.5.5-input-shape.patch
+       ${FILESDIR}/nsplugins-3.5.5-npapi-64bit.patch
+       ${FILESDIR}/kate-3.5.5-visibility.patch"
+
+pkg_setup() {
+       kde_pkg_setup
+       if use hal && has_version '<sys-apps/dbus-0.90' && ! built_with_use sys-apps/dbus qt3; then
+               eerror "To enable HAL support in this package is required to have"
+               eerror "sys-apps/dbus compiled with Qt 3 support."
+               eerror "Please reemerge sys-apps/dbus with USE=\"qt3\"."
+               die "Please reemerge sys-apps/dbus with USE=\"qt3\"."
+       fi
+}
+
+src_unpack() {
+       kde_src_unpack
+
+       # Avoid using imake (kde bug 114466).
+       epatch "${WORKDIR}/patches/kdebase-3.5.0_beta2-noimake.patch"
+       rm -f "${S}/configure"
+
+       # FIXME - disable broken tests
+       sed -i -e "s:TESTS =.*:TESTS =:" ${S}/kioslave/smtp/Makefile.am || die "sed failed"
+       sed -i -e "s:TESTS =.*:TESTS =:" ${S}/kioslave/trash/Makefile.am || die "sed failed"
+       sed -i -e "s:SUBDIRS = viewer test:SUBDIRS = viewer:" ${S}/nsplugins/Makefile.am || die "sed failed"
+}
+
+src_compile() {
+       local myconf="--with-dpms
+                                 $(use_with arts) $(use_with ldap)
+                                 $(use_with opengl gl) $(use_with ssl)
+                                 $(use_with samba) $(use_with openexr)
+                                 $(use_with lm_sensors sensors) $(use_with logitech-mouse libusb)
+                                 $(use_with ieee1394 libraw1394) $(use_with hal)
+                                 $(use_enable zeroconf dnssd)
+                                 $(use_with xcomposite composite)
+                                 $(use_with xscreensaver)
+                                 $(use_with xinerama)
+                                 --with-usbids=/usr/share/misc/usb.ids"
+
+       if use pam; then
+               myconf="${myconf} --with-pam=yes"
+       else
+               myconf="${myconf} --with-pam=no --with-shadow"
+       fi
+
+       # the java test is problematic (see kde bug 100729) and
+       # useless. All that's needed for java applets to work is
+       # to have the 'java' executable in PATH.
+       myconf="${myconf} --without-java"
+
+       export BINDNOW_FLAGS="$(bindnow-flags)"
+
+       kde_src_compile
+}
+
+src_install() {
+       kde_src_install
+       cd ${S}/kdm && make DESTDIR=${D} GENKDMCONF_FLAGS="--no-old --no-backup --no-in-notice" install
+
+       # startup and shutdown scripts
+       insinto ${KDEDIR}/env
+       doins "${FILESDIR}/agent-startup.sh"
+
+       exeinto ${KDEDIR}/shutdown
+       doexe "${FILESDIR}/agent-shutdown.sh"
+
+       # freedesktop environment variables
+       cat <<EOF > "${T}/xdg.sh"
+export XDG_DATA_DIRS="${KDEDIR}/share:/usr/share"
+export XDG_CONFIG_DIRS="${KDEDIR}/etc/xdg"
+EOF
+       insinto ${KDEDIR}/env
+       doins "${T}/xdg.sh"
+
+       # x11 session script
+       cat <<EOF > "${T}/kde-${SLOT}"
+#!/bin/sh
+exec ${KDEDIR}/bin/startkde
+EOF
+       exeinto /etc/X11/Sessions
+       doexe "${T}/kde-${SLOT}"
+
+       # freedesktop compliant session script
+       sed -e "s:@KDE_BINDIR@:${KDEDIR}/bin:g;s:Name=KDE:Name=KDE ${SLOT}:" \
+               "${S}/kdm/kfrontend/sessions/kde.desktop.in" > "${T}/kde-${SLOT}.desktop"
+       insinto /usr/share/xsessions
+       doins "${T}/kde-${SLOT}.desktop"
+
+       # Customize the kdmrc configuration
+       sed -i -e "s:#SessionsDirs=:SessionsDirs=/usr/share/xsessions\n#SessionsDirs=:" \
+               "${D}/${KDEDIR}/share/config/kdm/kdmrc" || die
+
+       rmdir "${D}/${KDEDIR}/share/templates/.source/emptydir"
+}
+
+pkg_postinst() {
+       # set the default kdm face icon if it's not already set by the system admin
+       if [ ! -e "${ROOT}${KDEDIR}/share/apps/kdm/faces/.default.face.icon" ]; then
+               mkdir -p "${ROOT}${KDEDIR}/share/apps/kdm/faces"
+               cp "${ROOT}${KDEDIR}/share/apps/kdm/pics/users/default1.png" \
+                       "${ROOT}${KDEDIR}/share/apps/kdm/faces/.default.face.icon"
+       fi
+       if [ ! -e "${ROOT}${KDEDIR}/share/apps/kdm/faces/root.face.icon" ]; then
+               mkdir -p "${ROOT}${KDEDIR}/share/apps/kdm/faces"
+               cp "${ROOT}${KDEDIR}/share/apps/kdm/pics/users/root1.png" \
+                       "${ROOT}${KDEDIR}/share/apps/kdm/faces/root.face.icon"
+       fi
+
+       mkdir -p "${ROOT}${KDEDIR}/share/templates/.source/emptydir"
+
+       echo
+       einfo "To enable gpg-agent and/or ssh-agent in KDE sessions,"
+       einfo "edit ${KDEDIR}/env/agent-startup.sh and"
+       einfo "${KDEDIR}/shutdown/agent-shutdown.sh"
+       echo
+}