dev-ros/visp_hand2eye_calibration: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Thu, 24 Sep 2015 08:42:15 +0000 (10:42 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 24 Sep 2015 08:43:09 +0000 (10:43 +0200)
Package-Manager: portage-2.2.21

dev-ros/visp_hand2eye_calibration/Manifest [new file with mode: 0644]
dev-ros/visp_hand2eye_calibration/metadata.xml [new file with mode: 0644]
dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.8.0.ebuild [new file with mode: 0644]
dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-9999.ebuild [new file with mode: 0644]

diff --git a/dev-ros/visp_hand2eye_calibration/Manifest b/dev-ros/visp_hand2eye_calibration/Manifest
new file mode 100644 (file)
index 0000000..b773503
--- /dev/null
@@ -0,0 +1 @@
+DIST vision_visp-0.8.0.tar.gz 1010996 SHA256 5166e1f17601328d09716879ceb66135e07bdb71a375765a937e3b78a12b0e54 SHA512 2bf2d69b6e19de21b34869858672662162703ff8b2aea85fdb9a6dafa88d8fe1f97d18587e863f3f7c088697e931a1b6e4e2e37f31fc7caff0906e98debbad1a WHIRLPOOL 015778e4cff63a9dbb5bf5812e38f7564b68cb71886e472062be15ec31a87a7299bff7ef9df50124294e22906420f60075cf6cc69f77df1cd29267b401f655e5
diff --git a/dev-ros/visp_hand2eye_calibration/metadata.xml b/dev-ros/visp_hand2eye_calibration/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.8.0.ebuild b/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.8.0.ebuild
new file mode 100644 (file)
index 0000000..418297f
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/lagadic/vision_visp"
+KEYWORDS="~amd64 ~arm"
+VER_PREFIX="jade-"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Estimates the camera position with respect to its effector using the ViSP library"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/image_proc
+       dev-ros/roscpp
+       dev-ros/sensor_msgs
+       dev-ros/visp_bridge
+       dev-ros/visp_tracker
+       sci-libs/ViSP:=
+"
+DEPEND="${RDEPEND}"
+if [ "${PV#9999}" = "${PV}" ] ; then
+       S="${WORKDIR}/vision_visp-jade-${PV}/${ROS_SUBDIR}"
+fi
diff --git a/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-9999.ebuild b/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-9999.ebuild
new file mode 100644 (file)
index 0000000..418297f
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/lagadic/vision_visp"
+KEYWORDS="~amd64 ~arm"
+VER_PREFIX="jade-"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Estimates the camera position with respect to its effector using the ViSP library"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/image_proc
+       dev-ros/roscpp
+       dev-ros/sensor_msgs
+       dev-ros/visp_bridge
+       dev-ros/visp_tracker
+       sci-libs/ViSP:=
+"
+DEPEND="${RDEPEND}"
+if [ "${PV#9999}" = "${PV}" ] ; then
+       S="${WORKDIR}/vision_visp-jade-${PV}/${ROS_SUBDIR}"
+fi