dev-python/wsaccel: Enable py3.{7,8}, modernize
authorMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 15:04:40 +0000 (17:04 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 15:16:20 +0000 (17:16 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/wsaccel/wsaccel-0.6.2_p20170108.ebuild

index c436d65ad6d2925ec13dcf5b9de71359824e7366..d9e9393a9a2f058fbed44d057eca967349b6c6d0 100644 (file)
@@ -4,28 +4,21 @@
 EAPI=5
 
 COMMIT="0fbd074c257c51b73de05b25ccb6488801320a32"
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
 
 inherit distutils-r1
 
 DESCRIPTION="Accelerator for ws4py, autobahn and tornado"
 HOMEPAGE="https://pypi.org/project/wsaccel/ https://github.com/methane/wsaccel"
 SRC_URI="https://github.com/methane/wsaccel/archive/${COMMIT}.zip -> ${P}.zip"
+S="${WORKDIR}/${PN}-${COMMIT}"
 
 SLOT="0"
 LICENSE="Apache-2.0"
 KEYWORDS="amd64 arm ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
-RDEPEND=""
 DEPEND="
        dev-python/cython[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
 "
 
-S="${WORKDIR}/${PN}-${COMMIT}"
-
-python_test() {
-       py.test -v || die
-}
+distutils_enable_tests pytest