dev-lang/rust: allow llvm-10 for 1.42.0
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 30 Mar 2020 07:11:39 +0000 (00:11 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 30 Mar 2020 07:22:33 +0000 (00:22 -0700)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-lang/rust/rust-1.42.0.ebuild

index 484af8fa84f68099b738da9d40555ce10f928a7e..196b58683e690435b57df8becfbeca0ba445a519 100644 (file)
@@ -46,16 +46,17 @@ IUSE="clippy cpu_flags_x86_sse2 debug doc libressl miri nightly parallel-compile
 
 # How to use it:
 # 1. List all the working slots (with min versions) in ||, newest first.
-# 2. Update the := to specify *max* version, e.g. < 10.
-# 3. Specify LLVM_MAX_SLOT, e.g. 9.
+# 2. Update the := to specify *max* version, e.g. < 11.
+# 3. Specify LLVM_MAX_SLOT, e.g. 10.
 LLVM_DEPEND="
        || (
+               sys-devel/llvm:10[${LLVM_TARGET_USEDEPS// /,}]
                sys-devel/llvm:9[${LLVM_TARGET_USEDEPS// /,}]
-               wasm? ( =sys-devel/lld-9* )
+               wasm? ( >=sys-devel/lld-9 )
        )
-       <sys-devel/llvm-10:=
+       <sys-devel/llvm-11:=
 "
-LLVM_MAX_SLOT=9
+LLVM_MAX_SLOT=10
 
 BOOTSTRAP_DEPEND="|| ( >=dev-lang/rust-1.$(($(ver_cut 2) - 1)).0-r1 >=dev-lang/rust-bin-1.$(($(ver_cut 2) - 1)) )"