net-libs/gnutls: hack guile detection
authorAlon Bar-Lev <alonbl@gentoo.org>
Sun, 27 Jan 2019 18:33:01 +0000 (20:33 +0200)
committerAlon Bar-Lev <alonbl@gentoo.org>
Sun, 27 Jan 2019 18:34:49 +0000 (20:34 +0200)
upstream replaced guile.m4 and did not use it correctly.

for now, hack this to detect guile-2.0.

Closes: https://bugs.gentoo.org/show_bug.cgi?id=676402
Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

net-libs/gnutls/gnutls-3.6.6.ebuild

index 9070aaa4a3cc9ed87e456e4e63b23053b2fff981..ea49105d00bb11f7313d4d454bf4fd2c0a872688 100644 (file)
@@ -73,6 +73,11 @@ src_prepare() {
 
        # Use sane .so versioning on FreeBSD.
        elibtoolize
+
+       # detect also guile-2.2, bug#676402
+       # aclocal/autoreconf will require more dependencies
+       # that we want to have
+       sed -i 's/_guile_required_version=2.2$/_guile_required_version=2.0/' configure || die
 }
 
 multilib_src_configure() {