dev-libs/libofx: 0.9.15 version bump, fix CVE-2019-9656
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 12 Oct 2019 20:22:24 +0000 (22:22 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 12 Oct 2019 21:13:16 +0000 (23:13 +0200)
Drop src_prepare() hacks and use a patch, we don't rely on the
build system to install to docdir.
Drop superfluous src_configure().

Bug: https://bugs.gentoo.org/680098
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-libs/libofx/Manifest
dev-libs/libofx/files/libofx-0.9.15-docdir-nothanks.patch [new file with mode: 0644]
dev-libs/libofx/libofx-0.9.15.ebuild [new file with mode: 0644]

index a963d76fa3a3ad47fa05d61e32933ce9b6f7a3ca..e44a09335b19bf59ed81d3c2fff0126aacbf2186 100644 (file)
@@ -1,2 +1,3 @@
 DIST libofx-0.9.10.tar.gz 1433837 BLAKE2B 131be0243b8450d32417dd75f0421744412a3186c0f7a3451883b6572c0dd27427579baf280ac2ae6409d0738bd578f69eaa9debfe50024411c6b0ccad11f5c9 SHA512 061110702034dbbb9be3adaebe6236a4b0842169d8ee7671bad6c93960b380cbb33953bdf080c8b14f45930b0c817fcfe1bf71f15d9872dd2535a1415f5be895
 DIST libofx-0.9.14.tar.gz 210155 BLAKE2B 1b5ee8503dd9d4837415e53ae79889c32c50146b2b508aab052e8074a277f8181c6866470220758ed7997b0b6e3e524ac6f9e1cac9a673f60c30ce3093e5a3ee SHA512 785c5130fc6f6cfc019d4aee2bf6de6311835e5dc7f2bd56a83f1ecf5e62ecb320a95bf4a5ff8f9e14dcaf5ff1eabc833cd7974927e571a8469c9a02fb8362d2
+DIST libofx-0.9.15.tar.gz 207361 BLAKE2B c84fd4593a9888268c691653dc1b5fff5c38013f12ccc4a8454f9a5026ba190388e5747074aa800266efcfd49a0fdb391a605d5837f664bdcb8fe1dc5c064839 SHA512 6014bf9c457adbe9053a47718064e6246c911c3bf081c690bf761650220208aabe94824aaa38794c1834462894b7948a06b3ff6b517a9a84b9f881ba51aee3a1
diff --git a/dev-libs/libofx/files/libofx-0.9.15-docdir-nothanks.patch b/dev-libs/libofx/files/libofx-0.9.15-docdir-nothanks.patch
new file mode 100644 (file)
index 0000000..6b8cc21
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/Makefile.am      2019-09-30 22:33:58.000000000 +0200
++++ b/Makefile.am      2019-10-12 22:46:00.915146241 +0200
+@@ -4,18 +4,7 @@
+   MAYBE_OFXCONNECT = ofxconnect
+ endif
+ DIST_SUBDIRS = m4 inc dtd lib doc . ofx2qif ofxdump ofxconnect
+-SUBDIRS = m4 inc dtd lib doc . ofx2qif ofxdump $(MAYBE_OFXCONNECT)
+-
+-docdir = $(datadir)/doc/libofx
+-
+-doc_DATA = \
+-  AUTHORS \
+-  COPYING \
+-  INSTALL \
+-  NEWS \
+-  README \
+-  ChangeLog \
+-  totest.txt
++SUBDIRS = m4 inc dtd lib . ofx2qif ofxdump $(MAYBE_OFXCONNECT)
+ EXTRA_DIST = \
+   libofx.spec.in \
diff --git a/dev-libs/libofx/libofx-0.9.15.ebuild b/dev-libs/libofx/libofx-0.9.15.ebuild
new file mode 100644 (file)
index 0000000..5daccd3
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Library to support the Open Financial eXchange XML format"
+HOMEPAGE="https://github.com/libofx/libofx"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/7"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+BDEPEND="
+       dev-util/gengetopt
+       sys-apps/help2man
+       virtual/pkgconfig
+       test? ( app-crypt/gnupg )
+"
+RDEPEND="
+       >=dev-cpp/libxmlpp-2.40.1:2.6
+       >=net-misc/curl-7.9.7
+       virtual/libiconv
+"
+DEPEND="${RDEPEND}
+       >app-text/opensp-1.5
+"
+
+PATCHES=( "${FILESDIR}/${P}-docdir-nothanks.patch" )
+
+# workaround needed for ofxconnect to compile
+MAKEOPTS="-j1"
+
+src_prepare() {
+       default
+       eautoreconf
+       append-cxxflags -std=c++14 # bug #566456
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -type f -delete || die
+       if ! use static-libs; then
+               find "${D}" -name '*.a' -type f -delete || die
+       fi
+}