dev-ml/variantslib: bump to 113.33.03
authorAlexis Ballier <aballier@gentoo.org>
Tue, 28 Jun 2016 11:06:22 +0000 (13:06 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 28 Jun 2016 11:56:47 +0000 (13:56 +0200)
Package-Manager: portage-2.3.0

dev-ml/variantslib/Manifest
dev-ml/variantslib/variantslib-113.33.03.ebuild [new file with mode: 0644]

index eedfe56cd069d5c2992e0c06ec0b868369b08d76..58bc402de2f466c2a7a12458d1d1c3d6296bfe98 100644 (file)
@@ -1 +1,2 @@
 DIST variantslib-113.24.00.tar.gz 50841 SHA256 9cc2a39ee32977e05cb215b3fa53d29601dd644af05e3c1cf28287c9f11288de SHA512 bc583f92d4f3085c213dabf5e77e4628dc092dfe120ec8bb59185bb76068e676e7c60238e965f11f752d5d4fa69144d5e2f949bfd9100037db394f05160b71b0 WHIRLPOOL 470bb0a7a1f80b637a724d79172ee94a694e23349920ec83fa0fae204a5ba46e4ec6c4305a9368ba53bfe1d7bf7ccd21d5efa1cf76c8ba4ea84932283080765d
+DIST variantslib-113.33.03.tar.gz 49653 SHA256 3685a40f37117bbedb33d8c4abaeb52c01f8178fb5a88712dd0e0dba533a7717 SHA512 1d83321b1de709ef3bb9329544c6fff5b8dee1125faffefebf2d29b11d5c2139a2fa6664d2eaaff48e89932e5b344dfe1ea898069db60b25079c9cd7344aee04 WHIRLPOOL 9ef9cac585da68a121e1d49e1bd2872c5858373177caf7b5a7c2f08a1c8e9775fd52120bdb7cf588f38e7bd43785d6626c7d5224129efc65d4fffdba68c0ef5f
diff --git a/dev-ml/variantslib/variantslib-113.33.03.ebuild b/dev-ml/variantslib/variantslib-113.33.03.ebuild
new file mode 100644 (file)
index 0000000..45ce600
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="OCaml variants as first class values"
+HOMEPAGE="https://janestreet.github.io/ https://github.com/janestreet/variantslib"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND} dev-ml/opam dev-ml/js-build-tools"
+
+src_configure() {
+       emake setup.exe
+       OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+       emake
+}
+
+src_install() {
+       opam-installer -i \
+               --prefix="${ED}/usr" \
+               --libdir="${D}/$(ocamlc -where)" \
+               --docdir="${ED}/usr/share/doc/${PF}" \
+               ${PN}.install || die
+       dodoc CHANGES.md
+}