sys-kernel/dracut: Don't complain about missing sources
authorAmadeusz Żołnowski <aidecoe@gentoo.org>
Sun, 16 Aug 2015 09:47:49 +0000 (10:47 +0100)
committerAmadeusz Żołnowski <aidecoe@gentoo.org>
Sun, 16 Aug 2015 09:58:50 +0000 (10:58 +0100)
Use /proc/config.gz if sources are not installed.

Gentoo-Bug: 508652

Package-Manager: portage-2.2.20.1

sys-kernel/dracut/dracut-034-r4.ebuild
sys-kernel/dracut/dracut-040-r3.ebuild
sys-kernel/dracut/dracut-041-r3.ebuild
sys-kernel/dracut/dracut-043-r1.ebuild
sys-kernel/dracut/dracut-043.ebuild

index ea80f7f2d8275be5ddfd1db306bee8089af4725d..041e7e69962377be93ebf10f1c1c6e0af231fbc0 100644 (file)
@@ -284,7 +284,7 @@ src_install() {
 }
 
 pkg_postinst() {
-       if linux-info_get_any_version && linux_config_src_exists; then
+       if linux-info_get_any_version && linux_config_exists; then
                ewarn ""
                ewarn "If the following test report contains a missing kernel"
                ewarn "configuration option, you should reconfigure and rebuild your"
index 0ab6bd89b9a9218eb9b5af8ff387942b8fd85283..8bf31be63b58412887667b563ea36fe0c51c56a1 100644 (file)
@@ -198,7 +198,7 @@ src_install() {
 }
 
 pkg_postinst() {
-       if linux-info_get_any_version && linux_config_src_exists; then
+       if linux-info_get_any_version && linux_config_exists; then
                ewarn ""
                ewarn "If the following test report contains a missing kernel"
                ewarn "configuration option, you should reconfigure and rebuild your"
index a7318cbf1f8cf8fb3907d28d3b7685c160de8b03..d96e6477c089f6533287d4aae722bdbda3afab44 100644 (file)
@@ -206,7 +206,7 @@ src_install() {
 }
 
 pkg_postinst() {
-       if linux-info_get_any_version && linux_config_src_exists; then
+       if linux-info_get_any_version && linux_config_exists; then
                ewarn ""
                ewarn "If the following test report contains a missing kernel"
                ewarn "configuration option, you should reconfigure and rebuild your"
index e38d97c843dd478ab15b548b7006e03e6e7f431f..6c16464232896bd8138dc728cfc17e9f37c466a8 100644 (file)
@@ -202,7 +202,7 @@ src_install() {
 }
 
 pkg_postinst() {
-       if linux-info_get_any_version && linux_config_src_exists; then
+       if linux-info_get_any_version && linux_config_exists; then
                ewarn ""
                ewarn "If the following test report contains a missing kernel"
                ewarn "configuration option, you should reconfigure and rebuild your"
index 04eb96479f1e1b66ca3161868db42db150354c72..290055ae959a06758f045043a73e52942c3662e8 100644 (file)
@@ -197,7 +197,7 @@ src_install() {
 }
 
 pkg_postinst() {
-       if linux-info_get_any_version && linux_config_src_exists; then
+       if linux-info_get_any_version && linux_config_exists; then
                ewarn ""
                ewarn "If the following test report contains a missing kernel"
                ewarn "configuration option, you should reconfigure and rebuild your"