dev-lang/spark: fix compile
authorTupone Alfredo <tupone@gentoo.org>
Fri, 8 Nov 2019 19:00:28 +0000 (20:00 +0100)
committerTupone Alfredo <tupone@gentoo.org>
Fri, 8 Nov 2019 19:00:28 +0000 (20:00 +0100)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-lang/spark/files/spark-2017-gentoo.patch
dev-lang/spark/spark-2018-r1.ebuild
dev-lang/spark/spark-2018.ebuild

index 479a7ace4dc29f8274e5b8c5ef429dee842f316f..8258c9feab7e65158f99997c651eb8fed2e13163 100644 (file)
@@ -1,5 +1,5 @@
---- spark-gpl-2017-src/gnat2why/gnat2why_c.gpr.old     2017-10-04 21:41:41.613376056 +0200
-+++ spark-gpl-2017-src/gnat2why/gnat2why_c.gpr 2017-10-04 21:42:30.582572536 +0200
+--- a/gnat2why/gnat2why_c.gpr  2017-10-04 21:41:41.613376056 +0200
++++ b/gnat2why/gnat2why_c.gpr  2017-10-04 21:42:30.582572536 +0200
 @@ -1,4 +1,7 @@
  project Gnat2Why_C is
     for Languages use ("C");
@@ -8,3 +8,16 @@
 +      for Driver ("C") use External ("CC", "gcc");
 +   end Compiler;
  end Gnat2Why_C;
+--- a/gnatprove/configuration.adb      2019-11-08 19:20:16.876198539 +0100
++++ b/gnatprove/configuration.adb      2019-11-08 19:21:13.550201663 +0100
+@@ -694,7 +694,9 @@
+          Tree         : Project_Tree;
+       begin
+-         Set_Path_From_Gnatls (Proj_Env.all, "gnatls", GNAT_Version);
++         Set_Path_From_Gnatls (Proj_Env.all,
++                               "gnatls",
++                               GNAT_Version);
+          Free (GNAT_Version);
+          Set_Object_Subdir (Proj_Env.all, Subdir_Name);
+          Proj_Env.Register_Default_Language_Extension ("C", ".h", ".c");
index 3bdf63d22f4b713d976483431148f63351393cb4..62f2959951dc5a634277818c72e25b5784a9c331 100644 (file)
@@ -35,10 +35,10 @@ PATCHES=( "${FILESDIR}"/${PN}-2017-gentoo.patch )
 
 src_prepare() {
        ln -sf "${WORKDIR}"/gnat-gpl-2018-src/src/ada gnat2why/gnat_src || die
+       default
        sed -i \
                -e "s:gnatls:${GNATLS}:g" \
                gnatprove/configuration.adb || die
-       default
 }
 
 src_compile() {
index d538aa73fcb213f3f5ffad8872094d59f87d36b9..c6d8008d3a211fe062f92b632a505fe66a3f39bc 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -32,6 +32,7 @@ PATCHES=( "${FILESDIR}"/${PN}-2017-gentoo.patch )
 
 src_prepare() {
        ln -sf "${WORKDIR}"/gnat-gpl-2018-src/src/ada gnat2why/gnat_src || die
+       default
        GCC_PV=7.3.1
        sed -i \
                -e "s:gnatmake:gnatmake-${GCC_PV}:g" \
@@ -39,7 +40,6 @@ src_prepare() {
                Makefile \
                gnatprove/configuration.adb \
                gnat2why/Makefile || die
-       default
 }
 
 src_compile() {