x11-base/xorg-server: Warn about performance with USE="wayland -glamor"
authorKelly Ledford <stripes416@gmail.com>
Sat, 4 Mar 2017 02:03:30 +0000 (18:03 -0800)
committerMatt Turner <mattst88@gentoo.org>
Sat, 4 Mar 2017 04:37:53 +0000 (20:37 -0800)
Bug: https://bugs.gentoo.org/608856
Closes: https://github.com/gentoo/gentoo/pull/4116

x11-base/xorg-server/xorg-server-1.19.2.ebuild
x11-base/xorg-server/xorg-server-9999.ebuild

index 5aeddbe5ee85e54d819ac316e2de546de8eec5e1..3245f045a3558e5e8ce0afc819d81bb4f12e9274 100644 (file)
@@ -154,6 +154,13 @@ pkg_pretend() {
                die "Sorry, but gcc earlier than 4.0 will not work for xorg-server."
 }
 
+pkg_setup() {
+       if use wayland && ! use glamor; then
+               ewarn "glamor is necessary for acceleration under Xwayland."
+               ewarn "Performance may be unacceptable without it."
+       fi
+}
+
 src_configure() {
        # localstatedir is used for the log location; we need to override the default
        #       from ebuild.sh
index 812c9fb6f5f45fe954f2311cc51e9eb8314b3f5a..f4f1bdf79160c01d2fc3d50f81765fa085925c15 100644 (file)
@@ -152,6 +152,13 @@ pkg_pretend() {
                die "Sorry, but gcc earlier than 4.0 will not work for xorg-server."
 }
 
+pkg_setup() {
+       if use wayland && ! use glamor; then
+               ewarn "glamor is necessary for acceleration under Xwayland."
+               ewarn "Performance may be unacceptable without it."
+       fi
+}
+
 src_configure() {
        # localstatedir is used for the log location; we need to override the default
        #       from ebuild.sh