dev-python/dbutils: new package
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>
Wed, 18 Mar 2020 10:07:56 +0000 (11:07 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 18 Mar 2020 11:11:23 +0000 (13:11 +0200)
Database connections for multi-threaded environments

Package-Manager: Portage-2.3.94, Repoman-2.3.20
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/14980
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/dbutils/Manifest [new file with mode: 0644]
dev-python/dbutils/dbutils-1.3.ebuild [new file with mode: 0644]
dev-python/dbutils/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/dbutils/Manifest b/dev-python/dbutils/Manifest
new file mode 100644 (file)
index 0000000..85a6f92
--- /dev/null
@@ -0,0 +1 @@
+DIST DBUtils-1.3.tar.gz 91733 BLAKE2B 8fb3fd16208c27fbbbbcbf1e7b9de2d4d2e8008916309256bd2ae5494d0ff60071fd3fa839dc7ccbe8832f333bad52d97dc4d176c822cc1ce3d5ce0bb05d637e SHA512 47aaa63144e6a0f4d020adb54fc5f36af01848a12f8adfcbd9889825980a1479b32041c087992de5f44478cc25729d1c97ed6cb094def2b93165f0120f10c5b6
diff --git a/dev-python/dbutils/dbutils-1.3.ebuild b/dev-python/dbutils/dbutils-1.3.ebuild
new file mode 100644 (file)
index 0000000..d5d655b
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+MY_PN="DBUtils"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Database connections for multi-threaded environments"
+HOMEPAGE="
+       https://cito.github.io/DBUtils/
+       https://github.com/Cito/DBUtils
+       https://pypi.org/project/DBUtils/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="OSL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+       #prevent tests from being installed
+       #prevent docs being installed outside /usr/share
+       sed -i -e "s/, 'DBUtils.Tests'//" \
+               -e "/package_data=/d" \
+               setup.py || die "sed failed"
+       distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+       dodoc "${S}/${MY_PN}"/Docs/*.rst
+       rm -r "${S}/${MY_PN}"/Docs/*.rst
+       local HTML_DOCS=( "${S}/${MY_PN}"/Docs/. )
+       distutils-r1_python_install_all
+}
diff --git a/dev-python/dbutils/metadata.xml b/dev-python/dbutils/metadata.xml
new file mode 100644 (file)
index 0000000..a24feb9
--- /dev/null
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>lssndrbarbieri@gmail.com</email>
+    <name>Alessandro Barbieri</name>
+  </maintainer>
+  <maintainer type="project">
+    <email>proxy-maint@gentoo.org</email>
+    <name>Proxy Maintainers</name>
+  </maintainer>
+  <longdescription lang="en">
+DBUtils is a suite of tools providing solid, persistent and pooled connections
+to a database that can be used in all kinds of multi-threaded environments
+like Webware for Python or other web application servers. The suite supports
+DB-API 2 compliant database interfaces and the classic PyGreSQL interface.
+  </longdescription>
+  <upstream>
+    <remote-id type="github">Cito/DBUtils</remote-id>
+  </upstream>
+</pkgmetadata>